UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.
Captain
Captain
347 views

Designer Not Pulling GCVs from IDM

We have Designer 4.8 installed on a Windows Server 2019 Standard Edition (version 1809).  We can connect to and pull down data from a IDM Vault.  However, the GCV's are not copied down to Designer.   Neither is the Dirver Configuration Information present.  In fact, nothing is available when right clicking on the Driver Set and going to properties. 

Has anyone else experienced this problem?  If so, how were you able to remedy this?

Tags (3)
7 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

Make sure at the root of the tree, there is a server object, that is correctly configured in the Properties pop up box, but also the lower left Properties where there is are a couple of settings:

clearTextHost, cleartextPost, secureHost and ssecurePort. These should all be set.

Captain
Captain

Thanks for the reply.  I found the settings page you mentioned.  Although secureHost and ssecurePort are set (the IP address of the host and 636 respectively), the clearTextHost and cleartextPost are blank.  What should those be?  The IP address of the server and 389 (respectively)?

 

Thanks,
Frank

 

0 Likes
Captain
Captain

Another update:

The global GCVs are not present.  These show up in designer 4.6 (which is on an older jump box), but not in the new 4.8 version.  

The "Managed System Information" GCVs (on a per driver level) were pulled down from the server, but the tabs that we add (typically these have the name of the driver) are blank.

Any other ideas?

Thanks,
Frank

 

0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

The names are pretty descriptive, so you supposition is correct.  Designer behaves very funny when these are not set.

Silly question...  Are you sure that you are looking at the correct server for the GCVs?  Remembering these are per-replica ttributes.  If you had 2 servers, but only was being used and you only set the data in one of them, if now you were looking at the other server, it would be empty appropriately. 

0 Likes
Captain
Captain

Thanks again for your quick reply.  To answer your question, we imported the IDM data to designer from the main Vault server which has all of the IDM GCV data and such.

 

 

Commodore
Commodore

Hi,

I did not yet run into a problem like that, but if it would happen to me I would try:

  1. double-clicking on IDV and inserting connecting information and trying to reconnect then fulfill all other fields by clicking on the magnifying glass icon
  2. importing changes from IDV
  3. double-clicking on Driverset and inserting connecting information and trying to reconnect then fulfill all other fields by clicking on the magnifying glass icon
  4. importing changes from Driverset

You probably did all that but I figure it cannot do any damage to add the obvious solutions. My quick guess would be you have the wrong deployment context and Driverset name infromation entered.

The obvious and perhaps easiest solution for you perhaps would be to start from scratch, as I understand you don't have anything really useful in your Designer project till now?

 

Hi!

What is your engine version? If Designer is 4.8.0, I suggest testing the latest version, 4.8.3.

I have seen odd behavoiurs in 4.8 where you would be required to allow 389 (LDAP) to be accessible from Designer. I would try and open LDAP on 389 (verify with some LDAP tool) and try and import again.

If a compare or import does not work, I suggest trying a new blank project import as well.

Best regards

Marcus

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.