jburns80 Super Contributor.
Super Contributor.
341 views

Driverset Won't Compare or Deploy

So we're using Designer 4.7.2, but for some reason when running a compare of the driverset, not any particular driver, but the driverset it won't compare, it runs for a few minutes and then times out and stops. Also can't deploy, it does the same thing. We do have about 20 driver on the driverset but I wouldn't think this would cause the driverset to fail to compare or deploy. We have new servers that need the GCV's deployed to them and can't get the driverset to deploy them. Anyone have this issue?
Labels (1)
0 Likes
2 Replies
Knowledge Partner
Knowledge Partner

Re: Driverset Won't Compare or Deploy

jburns80 wrote:

>
> So we're using Designer 4.7.2, but for some reason when running a
> compare of the driverset, not any particular driver, but the driverset
> it won't compare, it runs for a few minutes and then times out and
> stops. Also can't deploy, it does the same thing. We do have about 20
> driver on the driverset but I wouldn't think this would cause the
> driverset to fail to compare or deploy. We have new servers that need
> the GCV's deployed to them and can't get the driverset to deploy them.
> Anyone have this issue?


What do you see at the server side in ndstrace for LDAP? anything interesting
in the workspace log? Temporarily allow cleartext connections and capture a
network trace...
______________________________________________
https://www.is4it.de/identity-access-management
0 Likes
Knowledge Partner
Knowledge Partner

Re: Driverset Won't Compare or Deploy

On 3/19/2019 2:14 PM, jburns80 wrote:
>
> So we're using Designer 4.7.2, but for some reason when running a
> compare of the driverset, not any particular driver, but the driverset
> it won't compare, it runs for a few minutes and then times out and
> stops. Also can't deploy, it does the same thing. We do have about 20
> driver on the driverset but I wouldn't think this would cause the
> driverset to fail to compare or deploy. We have new servers that need
> the GCV's deployed to them and can't get the driverset to deploy them.
> Anyone have this issue?
>


So first off, since working is more important than fixing the underlying
problem at first.

For the driver set GCV's not in a GCV object, right click on the
driverset in Designer, Live, DriverSet configuration, Compare Attributes.

This is faster and just does attrs of the object,not all children.

Then for GCV's that are DirXML-GlobalConfig objects (I.e. From packages)
you can go to each object (child of drievrset ) and Live compare them.

Finally if you have added GCV's, then the linkage is stored in
DirXML-Policies, and you can fix this via LDAP.

cn=GCV,cn=DriverName,cn=Driverset,ou=idm,o=data#X#14

X is the order you want this to appear in the list, starting at 0. 14
is the position in the policy flow, which you can see here:

https://www.netiq.com/communities/cool-solutions/talking-about-dirxml-policies-attributes/


0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.