skoehler Respected Contributor.
Respected Contributor.
280 views

Error when installing IDM 4.8.0 HF1

Hi,

on a fresh IDM 4.8.0 with eDir 9.2.0 (not the bundled one, but the independant download version) when installing the IDM 4.8.0-HF1 patch (after stopping eDir), I receive the following errors:

Preparing...                          ################################# [100%]
 file /opt/novell/eDirectory/lib from install of novell-DXMLbasenoarch-4.8.0-1.i586 conflicts with file from package novell-edirectory-expat-32bit-9.2.0-6.x86_64
 file /opt/novell/eDirectory/lib from install of novell-DXMLbasenoarch-4.8.0-1.i586 conflicts with file from package novell-edirectory-xdaslog-32bit-9.2.0-0.x86_64
Preparing...                          ################################# [100%]
Updating / installing...
   1:novell-DXMLeventx-4.8.0-1        ################################# [ 50%]
Cleaning up / removing...
   2:novell-DXMLeventx-4.8.0-0        ################################# [100%]

Also I notice, that there is a mismatch at the RELEASE:

rpm -qa novell-DXMLengnx returns novell-DXMLeventx-4.8.0-1.x86_64
rpm -q --qf "%{VERSION}" novell-DXMLengnx returns 4.8.0
rpm -q --qf "%{RELEASE}" novell-DXMLengnx returns 0 (should be 1 to  my understanding)

Any idea what's wrong here?

Steffen

 

Labels (1)
0 Likes
7 Replies
Adrian Rauta Frequent Contributor.
Frequent Contributor.

Re: Error when installing IDM 4.8.0 HF1

Hi Steffen,

What Linux distro do you use?

I had some various issues during the standard 4.8 installation on RedHat.
To me, they were fixed by setting the Selinux to permissive.

File:
/etc/selinux/config

Content:
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
# enforcing - SELinux security policy is enforced.
# permissive - SELinux prints warnings instead of enforcing.
# disabled - No SELinux policy is loaded.
SELINUX=permissive
# SELINUXTYPE= can take one of these three values:
# targeted - Targeted processes are protected,
# minimum - Modification of targeted policy. Only selected processes are protected.
# mls - Multi Level Security protection.
SELINUXTYPE=targeted

Adrian

0 Likes
skoehler Respected Contributor.
Respected Contributor.

Re: Error when installing IDM 4.8.0 HF1

Hi Adrian, thanks for your input.

In fact, I run on SLES 12 SP4. The IDM 4.8.0 install itself works fine.

regards Steffen

0 Likes
cpedersen Outstanding Contributor.
Outstanding Contributor.

Re: Error when installing IDM 4.8.0 HF1

Hi Adrian,

This is very interesting information, as last time I pursued this subject (selinux) I was told by the PM that eDirectory/IDM will work with selinux in enforcing setting. 

 

Casper

0 Likes
abergvall Trusted Contributor.
Trusted Contributor.

Re: Error when installing IDM 4.8.0 HF1

add a --force to the rpm command 🙂
0 Likes
cpedersen Outstanding Contributor.
Outstanding Contributor.

Re: Error when installing IDM 4.8.0 HF1

While I do not disagree with you that this will get the RPM installed, using '--force' is not a healthy option, as it might break other things.

I would suggest to open an SR, and get the rpm fixed as it's not build correctly.

 

Casper

0 Likes
aortiz1 Respected Contributor.
Respected Contributor.

Re: Error when installing IDM 4.8.0 HF1

Hi Skoehler

I'm finding myself with the same problem that you are experiencing, we even have the same gear but if i check on iManager it seems to present the 4.8.0.1 version. 

I guess we will open an SR too, but if you have any news on this issue please let us know, we will do the same.

Greetings

0 Likes
skoehler Respected Contributor.
Respected Contributor.

Re: Error when installing IDM 4.8.0 HF1

Hi, sorry to admit, but I didn't follow up. I experienced this in a Lab environment (that's what they are made for) and didn't find time to work on this so far.

I also noticed that in my first statement, I mixed up the rpms when doing the query, so it may not be THAT worse (with the version misinformation).

Steffen

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.