Anonymous_User Absent Member.
Absent Member.
252 views

Error while driver start up


Hi Guys ,

I have created a driver to do data synchronisation between eDir and
Active Dir .
Now when i start it doesn't start and shows dev.GenErr in following path

C:NetIQ/Identitymanager/iManager/Tomcat/webapps/nps/WEB-INF/logs/debug.html/.

Also , when i click on TraceOn in Remote Loader , it opens a black blank
screen .
Does that mean Remote loader is not properly configured to listen
iManager ?
where else can i see the detailed log of driver , i.e.: manually by
opening any file ?

Since my eDir and ActiveDir both are on same system , do i need to set
this driver as native instead of Remote while configuring ?

Please assist.

Thanks
Tshepo


--
tshepo01
------------------------------------------------------------------------
tshepo01's Profile: https://forums.netiq.com/member.php?userid=9834
View this thread: https://forums.netiq.com/showthread.php?t=53770

Labels (1)
0 Likes
7 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Error while driver start up


tshepo01;258435 Wrote:
> Hi Guys ,
>
> I have created a driver to do data synchronisation between eDir and
> Active Dir .
> Now when i start it doesn't start and shows dev.GenErr in following path
>
> C:NetIQ/Identitymanager/iManager/Tomcat/webapps/nps/WEB-INF/logs/debug.html/.
>
> Also , when i click on TraceOn in Remote Loader , it opens a black blank
> screen .
> Does that mean Remote loader is not properly configured to listen
> iManager ?
> where else can i see the detailed log of driver , i.e.: manually by
> opening any file ?
>
> Since my eDir and ActiveDir both are on same system , do i need to set
> this driver as native instead of Remote while configuring ?
>
> Please assist.
>
> Thanks
> Tshepo


In relation to above query , i am attaching a screens shot of
RemoteLoader-> Select Drive -> Properties .
an IP is provided here and port 8000 and 8090 . While configuring
Driver it showed me a drop down of 2 IP addresses and localhost option
..
Instead of localhost i chose one IP of given list. ( none of the IP was
of my machine ) because
I read in documents that we need to change each to IP of system where
ever localhost is appearing by default .

Now i am confused from where localhost has come in drop down , though
i had replaced all occurrence of localhost to my system's IP while
configuring.
Also, what the IP denotes ?

Thanks
Tshepo

296


+----------------------------------------------------------------------+
|Filename: RemoteLoader_01.png |
|Download: https://forums.netiq.com/attachment.php?attachmentid=296 |
+----------------------------------------------------------------------+

--
tshepo01
------------------------------------------------------------------------
tshepo01's Profile: https://forums.netiq.com/member.php?userid=9834
View this thread: https://forums.netiq.com/showthread.php?t=53770

0 Likes
Knowledge Partner
Knowledge Partner

Re: Error while driver start up

tshepo01 wrote:

> In relation to above query , i am attaching a screens shot of
> RemoteLoader-> Select Drive -> Properties .
> an IP is provided here and port 8000 and 8090 . While configuring
> Driver it showed me a drop down of 2 IP addresses and localhost option
> .
> Instead of localhost i chose one IP of given list. ( none of the IP was
> of my machine ) because
> I read in documents that we need to change each to IP of system where
> ever localhost is appearing by default .


This can be true, but rarely have needed to do this with remote loader.

> Now i am confused from where localhost has come in drop down , though
> i had replaced all occurrence of localhost to my system's IP while
> configuring.
> Also, what the IP denotes ?


This means you have a problem at the DHCP level with your test box.

This 169.x.x.x is assigned by Windows when a local DHCP address can't be assigned.
The device on the other end of your network connection is the one that should be assigning an IP. That device acts as a DHCP server.

As I guess you are running a virtual machine, then you have one of several options.

1. your virtual network is isolated from the host machine's network. In this scenario, you would be best advised to use static IP assignment
2. your virtual network is bridged to the host machine's network card. In this scenario, you would need to contact your IT department as they maintain the DHCP server which should provide your VM an IP

There are other ways to configure this, but these two are common.
Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Error while driver start up


Thanks Alex ,

After some investigation and configuration I am able to see logs for
the remoteLoader and Driver log.
I see in the trace of RemoteLoader it is showing below log
-------------------------------------------------------------------------------------
DirXML: [06/29/15 13:25:23.63]: Loader: Trace Level: 5
DirXML: [06/29/15 13:25:23.63]: Loader: Verifying command port...

DirXML: [06/29/15 13:25:24.66]: Loader: Verifying driver can be
loaded...
DirXML: [06/29/15 13:25:24.66]: ADDriver: Driver::destroy

DirXML: [06/29/15 13:25:24.66]: ADDriver: Driver::~Driver()

DirXML: [06/29/15 13:25:24.66]: Loader: Waiting for DirXML to connect on
'TCP server socket, port 8090, address 169.254.86.208'...
-------------------------------------------------------------------------------------------------------------------------------------------------------


What i want to know is what do i need to provide the value in IP
address ? Let's say it is XYZ ... what exactly will be runnign on that
IP and port 8090 ?
Hope i am able to ask my doubt clearly.

Thanks
Tshepo


--
tshepo01
------------------------------------------------------------------------
tshepo01's Profile: https://forums.netiq.com/member.php?userid=9834
View this thread: https://forums.netiq.com/showthread.php?t=53770

0 Likes
Knowledge Partner
Knowledge Partner

Re: Error while driver start up

tshepo01 wrote:

>
>
> DirXML: [06/29/15 13:25:24.66]: Loader: Waiting for DirXML to connect on
> 'TCP server socket, port 8090, address 169.254.86.208'...
> -------------------------------------------------------------------------------------------------------------------------------------------------------
>
>
> What i want to know is what do i need to provide the value in IP
> address ? Let's say it is XYZ ... what exactly will be runnign on that
> IP and port 8090 ?
> Hope i am able to ask my doubt clearly.



This is an operating system level issue. You should set a fixed IP address for your windows virtual machine and then restart.
It is actually called out in the eDirectory documentation (somewhere) that this is strongly recommended.
Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Error while driver start up

tshepo01 wrote:

> Now when i start it doesn't start and shows dev.GenErr in following path
>
> C:NetIQ/Identitymanager/iManager/Tomcat/webapps/nps/WEB-INF/logs/debug.html/.


This does not sound like the right place for a driver error to log.

Look at https://www.netiq.com/communities/cool-solutions/capturing-and-reading-novell-identity-manager-traces/ and post a trace
Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Error while driver start up


Thanks Alex for that link . I will check those log files in my system
..

One question has left unanswered

>>Since my eDir and ActiveDir both are on same system , do i need to set

this driver as native instead of Remote while configuring ?

.........??

Waiting for kind help.

though I am struggling to understand this product but I am enjoying it.

Thanks
Tshepo


--
tshepo01
------------------------------------------------------------------------
tshepo01's Profile: https://forums.netiq.com/member.php?userid=9834
View this thread: https://forums.netiq.com/showthread.php?t=53770

0 Likes
Knowledge Partner
Knowledge Partner

Re: Error while driver start up

tshepo01 <tshepo01@no-mx.forums.microfocus.com> wrote:
> Thanks Alex for that link . I will check those log files in my system
> ..
>
> One question has left unanswered


> this driver as native instead of Remote while configuring ?
>


You talking about in iManager/Designer or in the remote loader config?

In iManager it should be remote.

In remote loader driver config you need to pick the ad driver dll option.


--
If you find this post helpful and are logged into the web interface, show
your appreciation and click on the star below...
Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.