Anonymous_User Absent Member.
Absent Member.
180 views

Extra attribute for Object selector for Groups


Hi

Can I add extra attributes to the object selector for groups when doing
a role assignment ?
Having 6 different groups with the same name, and right now i can only
find the right group with firebug and some html inspection.

I know how to do it with Users (Search/require checked for the attribute
in DAL, then deploy and flush), but it does not seems to work the same
way for groups.

Anyone done this for groups ?

/Kristoffer


--
kristoffer
------------------------------------------------------------------------
kristoffer's Profile: https://forums.netiq.com/member.php?userid=274
View this thread: https://forums.netiq.com/showthread.php?t=52891

Labels (1)
0 Likes
3 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Extra attribute for Object selector for Groups

On 02/21/2015 01:09 PM, kristoffer wrote:
>
> Hi
>
> Can I add extra attributes to the object selector for groups when doing
> a role assignment ?
> Having 6 different groups with the same name, and right now i can only
> find the right group with firebug and some html inspection.
>
> I know how to do it with Users (Search/require checked for the attribute
> in DAL, then deploy and flush), but it does not seems to work the same
> way for groups.
>
> Anyone done this for groups ?
>
> /Kristoffer
>
>

Greetings,
You have to update the group attribute on the User Entity in the
DAL. I do believe that I have provided the steps here in the forums in
the past on this. Let me look for the thread.



--

Sincerely,
Steven Williams
Lead Software Engineer
NetIQ
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Extra attribute for Object selector for Groups

On 02/23/2015 07:27 AM, Steven Williams wrote:
> On 02/21/2015 01:09 PM, kristoffer wrote:
>>
>> Hi
>>
>> Can I add extra attributes to the object selector for groups when doing
>> a role assignment ?
>> Having 6 different groups with the same name, and right now i can only
>> find the right group with firebug and some html inspection.
>>
>> I know how to do it with Users (Search/require checked for the attribute
>> in DAL, then deploy and flush), but it does not seems to work the same
>> way for groups.
>>
>> Anyone done this for groups ?
>>
>> /Kristoffer
>>
>>

> Greetings,
> You have to update the group attribute on the User Entity in the
> DAL. I do believe that I have provided the steps here in the forums in
> the past on this. Let me look for the thread.
>
>
>

Greetings,
It was in the thread "UserApp - Group View on Name instead of
Description" on 01-May-2014. Here is my answer:

"
The non-workflow areas (Manage Mode, Role Assignment, Attestation
......etc) do not point directly to the "Group" Entity, but rather the
User Entity's Group Attribute. By default this Attribute is configured
as as DN Lookup control that points to Group with only the Description
Attribute. Therefore, if you want more attributes to appear that are
apart of the Group Entity lookup in these non-workflow areas you must
manually press the + sign, add the additional attribute(s) from the
Group Entity, and then Deploy.


In a workflow, when you use the DNLookup or MV Editor controls and
point them to the Group entity then you will see those attributes that
are marked Search and Required.


The two (2) different areas work completely different.
"

--

Sincerely,
Steven Williams
Lead Software Engineer
NetIQ
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Extra attribute for Object selector for Groups


Steven Williams;254454 Wrote:
> On 02/23/2015 07:27 AM, Steven Williams wrote:
> The non-workflow areas (Manage Mode, Role Assignment, Attestation
> ......etc) do not point directly to the "Group" Entity, but rather the
> User Entity's Group Attribute. By default this Attribute is configured
> as as DN Lookup control that points to Group with only the Description
> Attribute. Therefore, if you want more attributes to appear that are
> apart of the Group Entity lookup in these non-workflow areas you must
> manually press the + sign, add the additional attribute(s) from the
> Group Entity, and then Deploy.
>


Thank you.
Just tried it in the dev. environment, and it seems to work fine. (added
dirxml-adaliasname to test with an aux attr.)


/Kristoffer


--
kristoffer
------------------------------------------------------------------------
kristoffer's Profile: https://forums.netiq.com/member.php?userid=274
View this thread: https://forums.netiq.com/showthread.php?t=52891

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.