Knowledge Partner
Knowledge Partner
836 views

IDM 4.5.4 is out

Dunno what is in it yet, dl.netiq.com and Patches to see it.

Engine, UA, and Designer patches so far.
Labels (1)
0 Likes
12 Replies
Knowledge Partner
Knowledge Partner

Re: IDM 4.5.4 is out

Geoffrey Carman <geoffreycarmanNOSPAM@NOSPAMgmail.com> wrote:
> Dunno what is in it yet, dl.netiq.com and Patches to see it.
>
> Engine, UA, and Designer patches so far.
>


Keen to see what is fixed in Designer.

--
If you find this post helpful and are logged into the web interface, show
your appreciation and click on the star below...
Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
haringka Absent Member.
Absent Member.

Re: IDM 4.5.4 is out


Dear community,

Has anybody installed the patch yet? I tried to do so today as I am
currently in an upgrade process at a customer. Wanted to upgrade to PL3
but decided to go for PL4 immediately as this makes sense to me.
Unfortunately I have an error at the very beginning already.
The environment is IDM Engine and eDir on Win Server 2012 R2, everything
running on version 4.5 before and eDir 8.8.8 PL7. Upgraded eDir to
version 8.8.8PL8 and installed the new iManager Plugins to version
2.7.7. When I try to patch the Engine and Remote Loader the upgrade
fails with the error 'Identity Manager 4.5.4.0 is not Suite B compliant.
For more information, see the Identity Manager 4.5.4.0 Release
Notes...'
I checked the Release Notes and see that it is not Suite B compliant but
I cannot find any Suite B configuration (LDAP Options or CA) in my
setup.
Any ideas on what is going wrong or if I missed an important step? I
can't really get my head around it.

Thanks a lot and warm regards
Katharina


--
haringka
------------------------------------------------------------------------
haringka's Profile: https://forums.netiq.com/member.php?userid=8212
View this thread: https://forums.netiq.com/showthread.php?t=56117

0 Likes
Knowledge Partner
Knowledge Partner

Re: IDM 4.5.4 is out

On 6/23/2016 3:57 PM, haringka wrote:
>
> Dear community,
>
> Has anybody installed the patch yet? I tried to do so today as I am
> currently in an upgrade process at a customer. Wanted to upgrade to PL3
> but decided to go for PL4 immediately as this makes sense to me.
> Unfortunately I have an error at the very beginning already.
> The environment is IDM Engine and eDir on Win Server 2012 R2, everything
> running on version 4.5 before and eDir 8.8.8 PL7. Upgraded eDir to
> version 8.8.8PL8 and installed the new iManager Plugins to version
> 2.7.7. When I try to patch the Engine and Remote Loader the upgrade
> fails with the error 'Identity Manager 4.5.4.0 is not Suite B compliant.
> For more information, see the Identity Manager 4.5.4.0 Release
> Notes...'
> I checked the Release Notes and see that it is not Suite B compliant but
> I cannot find any Suite B configuration (LDAP Options or CA) in my
> setup.
> Any ideas on what is going wrong or if I missed an important step? I
> can't really get my head around it.


eDir 9.0 is the Suite B complaint version of eDir. I was not sure you
had to have eDir 9,0 though to run 4.5.4.


0 Likes
Knowledge Partner
Knowledge Partner

Re: IDM 4.5.4 is out

haringka <haringka@no-mx.forums.microfocus.com> wrote:
>

Dear community,
>
> try to patch the Engine and Remote Loader the upgrade

fails with the error 'Identity Manager 4.5.4.0 is not Suite B compliant.

My interpretation of the release notes is that the suite b stuff is only
for eDir 9. So not relevant to eDir 8.8. Not sure why the updates
complains (will try myself shortly)

--
If you find this post helpful and are logged into the web interface, show
your appreciation and click on the star below...

Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
haringka Absent Member.
Absent Member.

Re: IDM 4.5.4 is out


Thanks for the fast replies.

For System requirements the release notes say:
Novell Identity Manager 4.5
eDirectory 8.8 SP8 Patch 8 prior to installing this patch

so eDirectory 8.8.8.8 ist what I upgraded to first.
There is a seperate installer for using eDir version 9 in the package.
I used the other one though and getting the error for Suite B with the
result message that the upgrade fails.
Maybe I am still missing something. I'll try again tomorrow. But still
any input is highly appreaciated 🙂


--
haringka
------------------------------------------------------------------------
haringka's Profile: https://forums.netiq.com/member.php?userid=8212
View this thread: https://forums.netiq.com/showthread.php?t=56117

0 Likes
ScorpionSting Absent Member.
Absent Member.

Re: IDM 4.5.4 is out

Same thing here....

1. eDir 8.8.8.7 -> 8.8.8.8
2. IDM 4.5.3 -> 4.5.4 (complains!)
3. eDir 8.8.8.8 -> 9.0.1

As IDM < 4.5.4 doesn't support eDir 9 and IDM 4.5.4 requires eDir 8.8.8.8 minimum...the upgrade path is always going to cause this *unnecessary* error.

Visit my Website for links to Cool Solution articles.
0 Likes
Knowledge Partner
Knowledge Partner

Re: IDM 4.5.4 is out

ScorpionSting <ScorpionSting@no-mx.forums.microfocus.com> wrote:
>
> Same thing here....


> 1. eDir 8.8.8.7 -> 8.8.8.8
> 2. IDM 4.5.3 -> 4.5.4 (complains!)



The release notes/readme specifically calls this out. It is just a warning
(and doesn't break the actual upgrade process).

--
If you find this post helpful and are logged into the web interface, show
your appreciation and click on the star below...
Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
haringka Absent Member.
Absent Member.

Re: IDM 4.5.4 is out


Still i get the result that the Upgrade failed.
I assumed it had to do with Suite B. Probably not. But it does not give
me information about why it failed in the log. It just says:
Installation failed. Upgrade failed.


--
haringka
------------------------------------------------------------------------
haringka's Profile: https://forums.netiq.com/member.php?userid=8212
View this thread: https://forums.netiq.com/showthread.php?t=56117

0 Likes
Knowledge Partner
Knowledge Partner

Re: IDM 4.5.4 is out

haringka wrote:

>
> Still i get the result that the Upgrade failed.
> I assumed it had to do with Suite B. Probably not. But it does not
> give me information about why it failed in the log. It just says:
> Installation failed. Upgrade failed.


I suggest you roll back, review the release notes and try again.
If that doesn't work. Raise a SR.
Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
haringka Absent Member.
Absent Member.

Re: IDM 4.5.4 is out


In the end it was Windows again... and of course stupid me. It is not
possible to run install.bat when selecting 'run as Administrator' from
context menu. It is necessary to run cmd as administrator and start via
command. Then it finishes successfully. Thanks for your help though
guys!


--
haringka
------------------------------------------------------------------------
haringka's Profile: https://forums.netiq.com/member.php?userid=8212
View this thread: https://forums.netiq.com/showthread.php?t=56117

0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: IDM 4.5.4 is out

haringka <haringka@no-mx.forums.microfocus.com> wrote:
>

In the end it was Windows again... and of course stupid me. It is not
possible to run install.bat when selecting 'run as Administrator' from
context menu. It is necessary to run cmd as administrator and start via
command. Then it finishes successfully. Thanks for your help though
guys!

Thanks for type follow up with solution.
I always take that approach with Windows.

- place the patches in a path that contains no spaces or special characters
and is as short as possible. For example C:\temp\idm454
- via elevated powershell run:
gci -recourse -path c:\temp\idm454 | unblock-file"

- command prompt run as admin

copy/launch files as required exclusively from command prompt.


This avoids nearly all of the common Windows specific potential pitfalls.


--
If you find this post helpful and are logged into the web interface, show
your appreciation and click on the star below...
Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
Knowledge Partner
Knowledge Partner

Re: IDM 4.5.4 is out

alexmchugh;2432513 wrote:
haringka <haringka@no-mx.forums.microfocus.com> wrote:
>

Dear community,
>
> try to patch the Engine and Remote Loader the upgrade

fails with the error 'Identity Manager 4.5.4.0 is not Suite B compliant.

My interpretation of the release notes is that the suite b stuff is only
for eDir 9. So not relevant to eDir 8.8. Not sure why the updates
complains (will try myself shortly)

--
If you find this post helpful and are logged into the web interface, show
your appreciation and click on the star below...


Thank you for the update, Geoffrey!
I'm not sure, how I missed this important news and related to this eDirectory 9.0.1 update couple of days ago...
(just busy with another activities and didn't have a chance to look on website and forum)

I believe, that now is time to plan eDir upgrade to 9.0.1!
9.0.1 release include support for IDM.
I hope that next release will include support for REST API! 🙂

Alex
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.