tschloesser Contributor.
Contributor.
1204 views

IDM 4.5 SP3 problem


After updating the webapplications to SP3 I can not use any application
anymore 😞

I did the OSP Update, SSPR 3.3.1.1 and APPS and I run the SAML 1.1.1
update on the eDir Server.

When restarting tomcat I can not see any error. (except that the jvm
parameter maxPermSize is not supported anymore in version 😎

All deployments (/landing, etc.) were listed as successful and I can
even see the refreshing of the mapping tables (resources) in
catalina.out

Whenever I try to login to any of the applications I am receiving the
new login mask (nice) but after providing the credentials osp does not
forward to the corresponding application. The only thing remaining is
the login mask 😞

When looking at catalina.out I can see that the authentication was
successful but nothing more - not even an error regarding the forwarding
.....

Any hints ?


--
tschloesser
------------------------------------------------------------------------
tschloesser's Profile: https://forums.netiq.com/member.php?userid=3232
View this thread: https://forums.netiq.com/showthread.php?t=55272

Labels (1)
0 Likes
18 Replies
Knowledge Partner
Knowledge Partner

Re: IDM 4.5 SP3 problem

tschloesser wrote:

> Any hints ?


Did you follw the exact installation order outlined in
https://www.netiq.com/documentation/idm45/idm453-releasenotes/data/idm453-releas
enotes.html ?
A colleague of mine ran into problems with the OSP update today, too. UA
updates seem to remain a challenge even in the latest version...

--
http://www.is4it.de/en/solution/identity-access-management/
______________________________________________
https://www.is4it.de/identity-access-management
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: IDM 4.5 SP3 problem

On 1/29/16 11:20 AM, Lothar Haeger wrote:
> tschloesser wrote:
>
>> Any hints ?

>
> Did you follw the exact installation order outlined in
> https://www.netiq.com/documentation/idm45/idm453-releasenotes/data/idm453-releas
> enotes.html ?
> A colleague of mine ran into problems with the OSP update today, too. UA
> updates seem to remain a challenge even in the latest version...
>

Greetings,
You have to make sure you follow all of the instructions about
cleaning out the different directories under Tomcat. As well, you
should delete all of the cache and cookies in your browser.

--
Sincerely,
Steven Williams
Lead Software Engineer
Micro Focus
0 Likes
ScorpionSting Absent Member.
Absent Member.

Re: IDM 4.5 SP3 problem


Have exact same problem with all OSP, SSPR, and Apps running on tomcat (
https://forums.netiq.com/showthread.php?55268-OSP-6 )

And all patch readme's were followed to the letter.....

There has to be a significant failure in the SP3 product.


--
-"Also now available in 'G+'
(http://plus.google.com/+BenWalter-Kiwi) and 'Website'
(https://www.isam.kiwi/) format".- 😉
------------------------------------------------------------------------
ScorpionSting's Profile: https://forums.netiq.com/member.php?userid=469
View this thread: https://forums.netiq.com/showthread.php?t=55272


Visit my Website for links to Cool Solution articles.
0 Likes
tschloesser Contributor.
Contributor.

Re: IDM 4.5 SP3 problem


Hi,

I removed all the files/directories from the tomcat directories and I
guess I did clean the chaches from the browser as well.

The only thing I had trouble with was following the instructions from
the configupdate hotfix. I was not able to locate most of the files
contained in this patch?!

Is there any suggested order in which to install the SP3 files?

Thanks!


--
tschloesser
------------------------------------------------------------------------
tschloesser's Profile: https://forums.netiq.com/member.php?userid=3232
View this thread: https://forums.netiq.com/showthread.php?t=55272

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: IDM 4.5 SP3 problem

On 2/1/16 7:34 AM, tschloesser wrote:
>
> Hi,
>
> I removed all the files/directories from the tomcat directories and I
> guess I did clean the chaches from the browser as well.
>
> The only thing I had trouble with was following the instructions from
> the configupdate hotfix. I was not able to locate most of the files
> contained in this patch?!
>
> Is there any suggested order in which to install the SP3 files?
>
> Thanks!
>
>

Greetings,
Can you please be more specific about your issue with configupdate
patch instructions?

--
Sincerely,
Steven Williams
Lead Software Engineer
Micro Focus
0 Likes
tschloesser Contributor.
Contributor.

Re: IDM 4.5 SP3 problem


the issue is step 5 of installing the patch: *-Move the following files
from the extracted folder location to the original installation
folder-*!

in my environment I can not find the following files:


-jackson-annotations-2.6.0.jar
-jackson-core-2.6.0.jar
-jackson-core-asl-1.7.1.jar
-jackson-databind-2.6.0.jar
-oidp-cfg-6.0.0.jar
-oidp-cfg-naaf-6.0.0.jar
-osp-common-6.0.0.jar

I addition to this I am missing instructions in which order to roll out
the SP3 patches on a server running all the apps in IDM45SP2 or on an
unpached server!


--
tschloesser
------------------------------------------------------------------------
tschloesser's Profile: https://forums.netiq.com/member.php?userid=3232
View this thread: https://forums.netiq.com/showthread.php?t=55272

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: IDM 4.5 SP3 problem

Hi Thorsten,

On 01.02.2016 15:24, tschloesser wrote:

> I addition to this I am missing instructions in which order to roll out
> the SP3 patches on a server running all the apps in IDM45SP2 or on an
> unpached server!
>


See
https://www.netiq.com/documentation/idm45/idm453-releasenotes/data/idm453-releasenotes.html#b1hc6ied

Step 4 in the first column should probably reference configupdate
4.5.0.2 and not 4.5.0.2
DCS Driver 4.0.1.0 needs to be added as well. And a hint to Java 8 would
be welcome.

--
Norbert
0 Likes
tschloesser Contributor.
Contributor.

Re: IDM 4.5 SP3 problem


Hi Norbert,

thanks for the link to the release notes - I did follow this order, but
I am guessing that the update from OSP 4.5.2 to OSP 6! needs something
more 😞
BTW: Why OSP 6? All other modules are 4.5.3?

For me it seams that OSP somehow is not able to redirect to the url of
the service asking for authentication - since I can see the successful
authentication in catalina.out but after this nothing more.

Is there any other log which could help?

Thanks!

Thorsten


--
tschloesser
------------------------------------------------------------------------
tschloesser's Profile: https://forums.netiq.com/member.php?userid=3232
View this thread: https://forums.netiq.com/showthread.php?t=55272

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: IDM 4.5 SP3 problem

On 2/1/16 10:14 AM, tschloesser wrote:
>
> Hi Norbert,
>
> thanks for the link to the release notes - I did follow this order, but
> I am guessing that the update from OSP 4.5.2 to OSP 6! needs something
> more 😞
> BTW: Why OSP 6? All other modules are 4.5.3?
>
> For me it seams that OSP somehow is not able to redirect to the url of
> the service asking for authentication - since I can see the successful
> authentication in catalina.out but after this nothing more.
>
> Is there any other log which could help?
>
> Thanks!
>
> Thorsten
>
>

Greetings Thorsten,
Sorry about sending send to early. To continue answering your
questions:

OSP is not apart of IDM. It is used by IDM, SSPR, and Access
Review. IDM 4.5.0, 4.5.1 and 4.5.2 were using version 5.0.0.x of OSP.
OSP was moved to version 6.0.0.x and with Service Pack 3 for IDM we
updated to take this new version of OSP.


--
Sincerely,
Steven Williams
Lead Software Engineer
Micro Focus
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: IDM 4.5 SP3 problem

On 02/01/2016 09:54 AM, Steven Williams wrote:
> On 2/1/16 10:14 AM, tschloesser wrote:
>>
>> Hi Norbert,
>>
>> thanks for the link to the release notes - I did follow this order, but
>> I am guessing that the update from OSP 4.5.2 to OSP 6! needs something
>> more 😞
>> BTW: Why OSP 6? All other modules are 4.5.3?
>>
>> For me it seams that OSP somehow is not able to redirect to the url of
>> the service asking for authentication - since I can see the successful
>> authentication in catalina.out but after this nothing more.
>>
>> Is there any other log which could help?
>>
>> Thanks!
>>
>> Thorsten
>>
>>

> Greetings Thorsten,
> Sorry about sending send to early. To continue answering your questions:
>
> OSP is not apart of IDM. It is used by IDM, SSPR, and Access Review.


These are all components of the IDM environment. I do not see the
difference based on what tschloesser is asking, but whatever.

> IDM 4.5.0, 4.5.1 and 4.5.2 were using version 5.0.0.x of OSP. OSP was
> moved to version 6.0.0.x and with Service Pack 3 for IDM we updated to


It may be worthwhile to note that, as far as public documentation is
concerned, 5.0 was the first version released. Not sure why, or what
products may have used previous versions, but everything I've found
indicates 5.0 was either 1.0, or the version right after a version-less 1.0.

None of this matters, I suppose; numbers are only meant for humans. It's
just a shame they were not chosen to be more-indicative of things as they
are, a product that's years old instead of a new addition to a bunch of
products that have well over a decade of use, both which are relevant to
version-number-interpreting humans.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: IDM 4.5 SP3 problem

On 2/1/16 9:24 AM, tschloesser wrote:
>
> the issue is step 5 of installing the patch: *-Move the following files
> from the extracted folder location to the original installation
> folder-*!
>
> in my environment I can not find the following files:
>
>
> -jackson-annotations-2.6.0.jar
> -jackson-core-2.6.0.jar
> -jackson-core-asl-1.7.1.jar
> -jackson-databind-2.6.0.jar
> -oidp-cfg-6.0.0.jar
> -oidp-cfg-naaf-6.0.0.jar
> -osp-common-6.0.0.jar
>
> I addition to this I am missing instructions in which order to roll out
> the SP3 patches on a server running all the apps in IDM45SP2 or on an
> unpached server!
>
>

Greetings Th

When I unzip (extract) the IDM45-configupdate-HF-2.zip, I see the
following files referenced in the configupdate Hotfix 2 Release Notes:

myserver:/home/lab/Software/IDM45-configupdate-HF-2 # l
jackson-annotations-2.6.0.jar
jackson-core-2.6.0.jar
jackson-core-asl-1.7.1.jar
jackson-databind-2.6.0.jar
ldapconfig_support.jar
oidp-cfg-6.0.0.jar
oidp-cfg-naaf-6.0.0.jar
osp-common-6.0.0.jar
sentinel-client-base-7.1.1.0.jar
sentinel-client-base-java-7.1.1.0.jar




--
Sincerely,
Steven Williams
Lead Software Engineer
Micro Focus
0 Likes
tschloesser Contributor.
Contributor.

Re: IDM 4.5 SP3 problem


it is not the problem that the files are not part of the zip file - I
found all the files in the patch, but not the place to copy them.
According to the documentation the files from the zip should replace the
original (existing) version of those files. Except
ldapconfig_support.jar and sentinel*.jar I do not find the remaining
files under /opt/netiq/...... or somewhere else on the server.

If this is O.k. since I have not jet installed reporting and/or access
review this is o.k., but I am wondering if this could be the root of the
problem I am facing (that the redirect from OSP to the application is
broken after authentication was successful)


--
tschloesser
------------------------------------------------------------------------
tschloesser's Profile: https://forums.netiq.com/member.php?userid=3232
View this thread: https://forums.netiq.com/showthread.php?t=55272

0 Likes
tschloesser Contributor.
Contributor.

Re: IDM 4.5 SP3 problem


just as an quick update:

As usual Steven was right:
After clearing the browser cache as well the redirection from osp was
working as expected!

Thanks to all!

Thorsten


--
tschloesser
------------------------------------------------------------------------
tschloesser's Profile: https://forums.netiq.com/member.php?userid=3232
View this thread: https://forums.netiq.com/showthread.php?t=55272

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: IDM 4.5 SP3 problem


I understand this may be the case that this all works with clearing the
cache, BUT, for some of us that deal with un-managed client devices
(BYOD), how do we deal with updates? To me this seems like improper
error-case handling, improper cache header tagging, or bad cookie
expiration/handling.


--
schwoerb
------------------------------------------------------------------------
schwoerb's Profile: https://forums.netiq.com/member.php?userid=2338
View this thread: https://forums.netiq.com/showthread.php?t=55272

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.