Anonymous_User Absent Member.
Absent Member.
154 views

IDM 4.5 - User Application DB


Hi all,
I'm taking a look to the new release IDM 4.5 and I have a question
related to the upgrade process.

It looks like IDM 4.5 no longer supports the database MySQL. The section
"6.14.6 System Requirements for the Identity Applications" of the Setup
Guide lists the following requirements:


Code:
--------------------

Database Microsoft SQL Server 2014
Oracle 12c
PostgreSQL 9.3.4, at a minimum

--------------------


Does Novell provide any utility to migrate User Application's data from
MySQL to other platforms? Any suggestion will be appreciated.

Thanks. Best regards,

Alessandro


--
afolli
------------------------------------------------------------------------
afolli's Profile: https://forums.netiq.com/member.php?userid=172
View this thread: https://forums.netiq.com/showthread.php?t=52324

Labels (1)
0 Likes
2 Replies
Anonymous_User Absent Member.
Absent Member.

Re: IDM 4.5 - User Application DB

afolli wrote:

> I'm taking a look to the new release IDM 4.5 and I have a question
> related to the upgrade process.
>
> It looks like IDM 4.5 no longer supports the database MySQL. The section
> "6.14.6 System Requirements for the Identity Applications" of the Setup
> Guide lists the following requirements:


MySQL has been on the way out since (I believe) IDM 4.0 when the default switched to PostgreSQL.

>
> Does Novell provide any utility to migrate User Application's data from
> MySQL to other platforms? Any suggestion will be appreciated.


I believe Steven has answered this before:

https://forums.netiq.com/showthread.php?48299-Migrating-the-UA-and-keeping-ongoing-workflows&p=232103#post232103
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: IDM 4.5 - User Application DB


Thanks for the answer.

There wasn't a real need to replace DB for old installations (put in
place before IDM 4.0) since MySQL was still supported until IDM 4.0.2.

If I understand it correctly, we have basically two options:
1. Start from scratch with the new DB, losing current data.
2. Choose a third-party tool to migrate data and hope/check that
everything is correct. Novell will not assist us during the migration
process, and that's fine. Anyway, will Novell support the solution after
that the DB has been migrated?

Thanks. Best regards,

Alessandro

alexmchugh;251600 Wrote:
> afolli wrote:
>
> > I'm taking a look to the new release IDM 4.5 and I have a question
> > related to the upgrade process.
> >
> > It looks like IDM 4.5 no longer supports the database MySQL. The

> section
> > "6.14.6 System Requirements for the Identity Applications" of the

> Setup
> > Guide lists the following requirements:

>
> MySQL has been on the way out since (I believe) IDM 4.0 when the default
> switched to PostgreSQL.
>
> >
> > Does Novell provide any utility to migrate User Application's data

> from
> > MySQL to other platforms? Any suggestion will be appreciated.

>
> I believe Steven has answered this before:
>
> http://tinyurl.com/mkkx9n8



--
afolli
------------------------------------------------------------------------
afolli's Profile: https://forums.netiq.com/member.php?userid=172
View this thread: https://forums.netiq.com/showthread.php?t=52324

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.