Highlighted
Respected Contributor.
Respected Contributor.
218 views

IDM 4.8 Install on Rhel 8.1

Jump to solution

What are the options for installing IDM 4.8.1 on Red Hat 8.1? This is for a new installation. Doco states that IDM 4.8.1 is supported on Rhel 8.1 but IDM 4.8 is not supported on Rhel 8.1. So if our Base OS is Rhel 8.1 we can’t install IDM v4.8. Has anyone done this? Do we need to install IDM 4.8.1 on a lower Rhel version and then upgrade the OS? Seems like there should be a better way to do the install.   

Labels (2)
1 Solution

Accepted Solutions
Highlighted
Outstanding Contributor.
Outstanding Contributor.
Hi,
I did install the Identity Application on my second server (no edir and no IDM engine).
The installation failed with LDAP error, until I configure the SecretStore on eDirectory with ssscfg -c on the other server.
It's also required to change the attribute sssAdminAccess = TRUE in the secretstore object.

After that I reinstalled and everything works fine.

Hope this will help.

Thx

Sylvain

View solution in original post

4 Replies
Highlighted
Outstanding Contributor.
Outstanding Contributor.
HI,
I'm currently installing IDM 4.8 on RHEL 8.2:
- Run RHEL-Prerequisite.sh and add missing library -->OK
- Install edir 9.2.2 --> OK
- Install iManager 3.2.2 --> OK
- I will install IDM 4.8 + 4.8.1 tomorow and let you know.

Thx
Sylvain
Highlighted
Outstanding Contributor.
Outstanding Contributor.
Hi,
This morning, I did the following steps:
- Install IDM 4.8 from iso source.
After successful installation, I had to extend manually the schema to be able to create a driverset:
/opt/novell/eDirectory/bin/idm-install-schema .
Then I deployed userapp + rolesservicesdriver (needed for Identity Application) and drivers did not start.
Errors in ndstrace was :
DirXML could not initialize password decryption subsystem: failed, 1165509723 (0x4578445b), unloading DirXML

After applying IDM 4.8.1 all drivers starts.

I will now install Identity Application on the second server.

Hope this will help.

Sylvain
Highlighted
Respected Contributor.
Respected Contributor.

Thanks, Sylvain,

Looks like you didn't have too many issues. Maybe the trick is to install eDir 9.2.2 first. I tried with RHL 8.1 and the eDir on the IDM 4.8 install media. (I think eDir 9.2).

Thanks again for your updates and good to know that it works.

Matt 

Highlighted
Outstanding Contributor.
Outstanding Contributor.
Hi,
I did install the Identity Application on my second server (no edir and no IDM engine).
The installation failed with LDAP error, until I configure the SecretStore on eDirectory with ssscfg -c on the other server.
It's also required to change the attribute sssAdminAccess = TRUE in the secretstore object.

After that I reinstalled and everything works fine.

Hope this will help.

Thx

Sylvain

View solution in original post

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.