Highlighted
Absent Member.
Absent Member.
583 views

IDM_AD_Ex2010_Service - Error 1053


Hello,

I get this error when trying to start IDM_AD_Ex2010_Service:


Code:
--------------------

error 1053 - the service did not respond to the start or control request in a timely fashion

--------------------


Info:

IDM version 4.0.1
AD driver version: 4.0.0.2
IDM_AD_Ex2010_Service.exe and IDMEx2010ManagementServer.dll versions:
1.0.0.3 (the ones that comes with AD patch 4.0.0.2)
Remote Loader running on DC (Windows Server 2012 R2)

I have a test environment, where this works. Same ISO used, all Windows
Updates applied in both production and test.

Same .NET versions in both test and production.

I have tried multiple different versions of the
IDM_AD_Ex2010_Service.exe and IDMEx2010ManagementServer.dll - versions
tried:

1.0.0.3
4.0.0.4
4.0.1.0

I get same error every time.

I have both tried starting the service as local system, and as a users
which has all the rights needed. Same error.

I know that upgrading to IDM 4.5.x is recommended, but this is a
secondary solution and will be closed down in the future. All it has is
an AD driver.

So, this works in test, but not production.

Only thing that has been done on the DC is dcpromo, no antivirus or
other applications.

I have also tried this:


Code:
--------------------

Go to Start > Run > and type regedit
Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
With the control folder selected, right click in the pane on the right and select new DWORD Value
Name the new DWORD: ServicesPipeTimeout
Right-click ServicesPipeTimeout, and then click Modify
Click Decimal, type '180000', and then click OK
Restart the computer

--------------------


No luck.

The error is shown the second I try to start the service.

The .exe and .dll files are not blocked by the OS.

Any ideas?

Thanks in advance,

Jacob.


--
jacmarpet
------------------------------------------------------------------------
jacmarpet's Profile: https://forums.netiq.com/member.php?userid=415
View this thread: https://forums.netiq.com/showthread.php?t=56298

Labels (1)
0 Likes
10 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: IDM_AD_Ex2010_Service - Error 1053

Hi Jacob,
What is your .Net version?

According to MS this is "well known" .Net issue. First time reported (corrected) in .Net 1.1, but it can be similar issues with other versions of .Net.

The ServiceBase class calls the OnStop method directly from the Service command handler that is defined in the ScDispatcherLoop of the Advapi32.dll file. After 30 seconds, if the ScDispatcherLoop thread is not ready to receive a new service command from the service control manager, Windows Service Controller marks the service as "time out." Therefore, you receive this error message.


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft .NET Framework 1.1 Service Pack 1.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: IDM_AD_Ex2010_Service - Error 1053

jacmarpet;2434904 wrote:

I have also tried this:


Code:
--------------------

Go to Start > Run > and type regedit
Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
With the control folder selected, right click in the pane on the right and select new DWORD Value
Name the new DWORD: ServicesPipeTimeout
Right-click ServicesPipeTimeout, and then click Modify
Click Decimal, type '180000', and then click OK
Restart the computer

--------------------


No luck.

The error is shown the second I try to start the service.



According to Symantec maximum value for ServicePipTimeout can be 86400000 (24 hours).
In worst case scenario you can try to increase this value.

https://support.symantec.com/en_US/article.TECH193916.html
Click Start > Run, then type regedit
Locate, and then right-click the following registry subkey: KEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
Point to New, and then click DWORD Value. In the right pane of Registry Editor, notice that New Value #1 (the name of a new registry entry) is selected for editing.
Type ServicesPipeTimeout to replace New Value #1, and then press ENTER.
Right-click the ServicesPipeTimeout registry entry that you created in step 3, and then click Modify. The Edit DWORD Value dialog box appears.
In the Value data text box, type 86400000, and then click OK ( It is the timeout period (in milliseconds) that you want to set for the service. Setting time-out period to 86400000 will set it to 24 hours (86400000 milliseconds)
Restart the computer.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: IDM_AD_Ex2010_Service - Error 1053


I have .NET 4.6.1. The newest I would think. All Windows updates have
been applied to the server.

I have tried the other suggestion with ServicePipTimeout. No difference.


--
jacmarpet
------------------------------------------------------------------------
jacmarpet's Profile: https://forums.netiq.com/member.php?userid=415
View this thread: https://forums.netiq.com/showthread.php?t=56298

0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: IDM_AD_Ex2010_Service - Error 1053

Did you see anything in your event viewer?

I have tried the other suggestion with ServicePipTimeout. No difference.

Did you restarted your box? (required)
How fast you got your error message after attempt to start?
According to "Symantec settings" ServicesPipeTimeout will wait 24 hours until service start before than report about issue.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: IDM_AD_Ex2010_Service - Error 1053

How to debug Windows services
https://support.microsoft.com/en-us/kb/824344

Maybe Windows Service debugging can provide more info...
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: IDM_AD_Ex2010_Service - Error 1053


Did you install all documented dependencies ? (You mentioned .NET but
nothing else)

PowerShell for example.

Also is there an Exchange server available in the same site?

Even if you are just using it for powershell support, it requires Exchange
available.

--
If you find this post helpful and are logged into the web interface, show
your appreciation and click on the star below...

Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: IDM_AD_Ex2010_Service - Error 1053


alexmchugh;269861 Wrote:
> Did you install all documented dependencies ? (You mentioned .NET but
> nothing else)
>
> PowerShell for example.
>
> Also is there an Exchange server available in the same site?
>
> Even if you are just using it for powershell support, it requires
> Exchange
> available.
>
> --
> If you find this post helpful and are logged into the web interface,
> show
> your appreciation and click on the star below...


Thank you for pointing this out. Never had any problems with PS or the
Exchange tools. But, it looks like there was a mismatch in the Exchange
service pack versions! Although I do not understand why it works in
test. Same images and files used. But, I made the Exchange versions
match (the actual version of Exchange and the tools installed on the RL
server), and now it works! Thank you so much!

Jacob.


--
jacmarpet
------------------------------------------------------------------------
jacmarpet's Profile: https://forums.netiq.com/member.php?userid=415
View this thread: https://forums.netiq.com/showthread.php?t=56298

0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: IDM_AD_Ex2010_Service - Error 1053


jacmarpet;269878 Wrote:
> Thank you for pointing this out. Never had any problems with PS or the
> Exchange tools. But, it looks like there was a mismatch in the Exchange
> service pack versions! Although I do not understand why it works in
> test. Same images and files used. But, I made the Exchange versions
> match (the actual version of Exchange and the tools installed on the RL
> server), and now it works! Thank you so much!
>
> Jacob.


Thank you for your update, Jacob!

I want just confirm your sentence (in very simplified view): you had
Exchange 2010 SP1 on server side and Exchange 2010 tools installed on RL
box? Is it right?

Alex


--
If you find this post helpful, please show your appreciation by clicking
on the star below :cool:
------------------------------------------------------------------------
al_b's Profile: https://forums.netiq.com/member.php?userid=209
View this thread: https://forums.netiq.com/showthread.php?t=56298

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: IDM_AD_Ex2010_Service - Error 1053


al_b;269903 Wrote:
> Thank you for your update, Jacob!
>
> I want just confirm your sentence (in very simplified view): you had
> Exchange 2010 SP1 on server side and Exchange 2010 tools installed on RL
> box? Is it right?
>
> Alex


Yes, that is correct.

Jacob.


--
jacmarpet
------------------------------------------------------------------------
jacmarpet's Profile: https://forums.netiq.com/member.php?userid=415
View this thread: https://forums.netiq.com/showthread.php?t=56298

0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: IDM_AD_Ex2010_Service - Error 1053

jacmarpet <jacmarpet@no-mx.forums.microfocus.com> wrote:
>
>
> Thank you for pointing this out. Never had > any problems with PS or the
> Exchange tools. But, it looks like there was > a mismatch in the Exchange
> service pack versions!


Have seen this also. Often you can use an older exchange tools, but best to
keep these patched at same level.

--
jacmarpet
------------------------------------------------------------------------
jacmarpet's Profile: https://forums.netiq.com/member.php?userid=415
View this thread: https://forums.netiq.com/showthread.php?t=56298

>




--
If you find this post helpful and are logged into the web interface, show
your appreciation and click on the star below...

Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.