Anonymous_User Absent Member.
Absent Member.
229 views

Installation issue - NIM 402 advance/integrated on Windows R


Hello Friends,

I am facing issue with Novell IDM 402 Advance(integrated) installation
on Windows 2008 R2.

Steps-
1. Through installer i installed(fresh) all the component on Windows
2008 R2 (except Reporting)
2. Now , at the time of configuration i provided all info. But at the
last it gave error - 'RBPM has not configured'

below is the ii_configure log-

"cmd" /c del ""
"C:\Users\<user_Loged_in>\AppData\Local\Temp\\rbpm_userapp_admin.ldif"
exitValue = 1

"C:\Users\<user_Loged_in>\Desktop\Identity_Manager_4.0.2_Windows_Advanced\products\RBPM\JBossPostgreSQL.exe"
-DIA_USER_JRE_HOME="C:\Novell\IdentityManager\jre" -i silent -f
"C:\Users\user_Loged_in\AppData\Local\Temp\\rbpm_postgresql_configure.properties"
exitValue = 1

it seems there is some password issue for postgres sql, i am not sure.
How to process now. I have given complex password for postreeSql also.

I am sure someone has faced it.. This issue will appear if any one try
to install. I am doing this on a VM server.

Regards,
Amit Singh


--
ameet140
------------------------------------------------------------------------
ameet140's Profile: https://forums.netiq.com/member.php?userid=4993
View this thread: https://forums.netiq.com/showthread.php?t=48105

Labels (1)
0 Likes
5 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Installation issue - NIM 402 advance/integrated on Windows R

On 02.07.2013 09:44, ameet140 wrote:
>
> Hello Friends,
>
> I am facing issue with Novell IDM 402 Advance(integrated) installation
> on Windows 2008 R2.
>
> Steps-
> 1. Through installer i installed(fresh) all the component on Windows
> 2008 R2 (except Reporting)
> 2. Now , at the time of configuration i provided all info. But at the
> last it gave error - 'RBPM has not configured'
>
> below is the ii_configure log-
>
> "cmd" /c del ""
> "C:\Users\<user_Loged_in>\AppData\Local\Temp\\rbpm_userapp_admin.ldif"
> exitValue = 1
>
> "C:\Users\<user_Loged_in>\Desktop\Identity_Manager_4.0.2_Windows_Advanced\products\RBPM\JBossPostgreSQL.exe"
> -DIA_USER_JRE_HOME="C:\Novell\IdentityManager\jre" -i silent -f
> "C:\Users\user_Loged_in\AppData\Local\Temp\\rbpm_postgresql_configure.properties"
> exitValue = 1
>
> it seems there is some password issue for postgres sql, i am not sure.
> How to process now. I have given complex password for postreeSql also.


Have you checked the password complexity rules required by your specific
Windows 2008 R2 environment? It may be different to the defaults.

Can you post a (sanitised) copy of the
rbpm_postgresql_configure.properties & the whole ii_configure log

We can't really help you troubleshoot without detailed log files.


> I am sure someone has faced it.. This issue will appear if any one try
> to install. I am doing this on a VM server.


There have been several issues with the integrated installer, I
generally only use it for the most simple installs (everything - as you
have installed)


--
----------------------------------------------------------------------
Alex McHugh
NetIQ Knowledge Partner http://forums.netiq.com

Please post questions in the forums. No support is provided via email.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Installation issue - NIM 402 advance/integrated on Windows R


I am working on VM , i have admin rights, but not able to disable the
password policy '*password must meet complexity requirement*'

I am giveing the password complexer than what(password) i used to login
to the VM.

Here is the *rbpm_postgresql_configure.property *file-

USER_MAGIC_FOLDER_1=C:\\Novell\\IdentityManager\\rbpm\\postgresql
#PostgreSQL Database params
NOVL_DB_NAME=idmuserappdb
NOVL_DB_USERNAME=idmadmin
NOVL_DB_PASSWORD=
NOVL_DB_PASSWORD_CONFIRM=
NOVL_DB_PORT=5432
NOVL_USE_INSTALLED_POSTGRES=not installed
NOVL_INSTALL_POSTGRES=0
NOVL_DB_PSQL_PORT=5432

& II_CONFIGURE.LOG FILE INFOR--

==== Invoke Configure Binaries =============================
IA_RESULT_IDM_FRAMEWORK_CONFIGURED=false
Configuring the product:::Metadirectory Server
IA_RESULT_IDM_FRAMEWORK_CONFIGURED=false
IA_RESULT_IDVAULT_SERVER_CONFIGURED=false
IA_RESULT_IDVAULT_SERVER_CONFIGURED=false
"C:\Users\346164\Desktop\Identity_Manager_4.0.2_Windows_Advanced\products\eDirectory\x64\windows\x64\NDSonNT\install.exe"
/silent /nopleasewait
/template=C:\Users\346164\AppData\Local\Temp\\eDirectory_configure.properties
exitValue = 0
IA_RESULT_IDM_FRAMEWORK_CONFIGURED=true
IA_RESULT_RBPM_USERAPP_CONFIGURED=false
Configuring the product:::Roles Based Provisioning Module (RBPM)
IA_RESULT_RBPM_USERAPP_CONFIGURED=false
cmd /c dir
exitValue = 0
"C:\Users\346164\Desktop\Identity_Manager_4.0.2_Windows_Advanced\products\RBPM\JBossPostgreSQL.exe"
-DIA_USER_JRE_HOME="C:\Novell\IdentityManager\jre" -i silent -f
"C:\Users\346164\AppData\Local\Temp\\rbpm_postgresql_configure.properties"
exitValue = 1
"cmd" /c del ""
"C:\Users\346164\AppData\Local\Temp\\rbpm_userapp_admin.ldif"
exitValue = 1
IA_RESULT_RBPM_USERAPP_CONFIGURED=false
IA_RESULT_IMANAGER_CONFIGURED=false
Configuring the product:::iManager
IA_RESULT_IMANAGER_CONFIGURED=false
"C:\Novell\IdentityManager\jre\bin\java" -jar
"C:\Users\346164\Desktop\Identity_Manager_4.0.2_Windows_Advanced\products\iManager\installs\win\configuration\iManagerConfig.jar"
"8090" "8443" "C:\Novell\IdentityManager\iManager"
exitValue = 0
IA_RESULT_IMANAGER_CONFIGURED=true
==== Complete ==============================================
INSTALL_SUCCESS=SUCCESS
RESTART_NEEDED=false
MISSING KEY: Confirm.Button.Label DEFAULT VALUE: Continue for
configuration
==== copy logs =============================================
copying log files
src:C:\Users\346164\AppData\Local\Temp\\ii_configure.log
dest:C:\Novell\IdentityManager\install\logs\ii_configure.log


--
ameet140
------------------------------------------------------------------------
ameet140's Profile: https://forums.netiq.com/member.php?userid=4993
View this thread: https://forums.netiq.com/showthread.php?t=48105

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Installation issue - NIM 402 advance/integrated on Windows R


Mine iManager is working fine. I am able to add/edit user in eDirectory
through iManager.
installed and configured component - IdM vault/Meta directory,
iManager, Designer

Hi i am runnning out of time, so If from the above log gives the cause
of error then ok, otherwise can you provide me the alternate way to use
UserApp/RBPM.

for RBPM my JBOSS is also throwing lot of error, when JBoss started
after configuration. I m not sure if i am missing something. kindly
reply.

Regards,
Amit Singh


--
ameet140
------------------------------------------------------------------------
ameet140's Profile: https://forums.netiq.com/member.php?userid=4993
View this thread: https://forums.netiq.com/showthread.php?t=48105

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Installation issue - NIM 402 advance/integrated on Windows R

On 02.07.2013 20:14, ameet140 wrote:
> Hi i am runnning out of time, so If from the above log gives the cause
> of error then ok, otherwise can you provide me the alternate way to use
> UserApp/RBPM.


Was there a log file for the actual JBossPostgreSQL.exe install? I was
pretty sure it created a log, that would be the place to look for the
actual reason for that sub-component failing to install with an error.

If you are pressed for time, you can still install/configure the
database manually - this is likely the fastest way to resolve your issue.

Just uninstall the JBoss and PostgreSQL components (if possible) and
then run the JBossPostgreSQL.exe directly from it's subdirectory on the
install media.

(as per the documentation here)
https://www.netiq.com/documentation/idm402/install/data/bf7ojtd.html#b8dfuhj

Then proceed to install User Application and configure it (as per the
documentation here)

https://www.netiq.com/documentation/idm402/install/data/bcz57yw.html

The Integrated Installer is just a wrapper around the various IDM
component installers. Because it spans the whole IDM product, it's
sometimes hard


> for RBPM my JBOSS is also throwing lot of error, when JBoss started
> after configuration. I m not sure if i am missing something. kindly
> reply.


That's not surprising, if as I suspect your database didn't install
properly and as such RBPM won't ever start properly.

--
----------------------------------------------------------------------
Alex McHugh
NetIQ Knowledge Partner http://forums.netiq.com

Please post questions in the forums. No support is provided via email.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Installation issue - NIM 402 advance/integrated on Windows R


Thank you very much Alexmchugh! ... it worked.

I would like to add one thing here, The postgreSQL exception occers
becoze the service user for this db was not remove after even
uninstallation of postgreSQL DB.
So i need to manually delete through CMD: *net user posetgres\delete*.

Thanks again for the quick help!


--
ameet140
------------------------------------------------------------------------
ameet140's Profile: https://forums.netiq.com/member.php?userid=4993
View this thread: https://forums.netiq.com/showthread.php?t=48105

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.