Highlighted
Absent Member.
Absent Member.
250 views

Installing IDM 3.5.1 - ELF class error?


Getting the following error when trying to install IDM 3.5.1 on SLES
11.1_64 and OES 11_64:

Loader Failed:for /opt/novell/eDirectory/lib64/libspmclnt.so,error
/opt/novell/eDirectory/lib64/libspmclnt.so: wrong ELF class:
ELFCLASS64,errno 2

So I guess someone is going to tell me that 64 bit OES, Edirectory, or
SLES is not supported with this version? Just want to make sure, because
it will add much complexity to what I am doing.

Thanks.


--
Hawk312
------------------------------------------------------------------------
Hawk312's Profile: https://forums.netiq.com/member.php?userid=874
View this thread: https://forums.netiq.com/showthread.php?t=47471

Labels (1)
0 Likes
7 Replies
Highlighted
Absent Member.
Absent Member.

Re: Installing IDM 3.5.1 - ELF class error?

OES 11 only comes with eDirectory x86_64. IDM 3.5.1 only came in x86_32.
Mixing the two will not work because the libvrdim module's type (ELF or
ELF64) must match the eDir binary. IDM 3.5.1, and 3.6.1 for that matter,
is outside of support so you need to get a supported version (4.x).
Alternatively, put 32-bit eDir on SLES 11 SP2 (x86_32 or x86_64, doesn't
matter) using the regular eDir install instead of OES. IDM 3.5.x is
probably not supported on SLES 11, so you may have issues, but at least it
might work and it'd be the simplest solution other than rebuilding the box
with SLES 10.

Good luck.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Installing IDM 3.5.1 - ELF class error?

On Thu, 04 Apr 2013 22:04:02 +0000, Hawk312 wrote:

> Getting the following error when trying to install IDM 3.5.1 on SLES
> 11.1_64 and OES 11_64:


You need IDM 4.02 for OES11.


> So I guess someone is going to tell me that 64 bit OES, Edirectory, or
> SLES is not supported with this version?


Yup. And IDM 3.5.1 is I think now out of general support. Unless you're
running NetWare, you shouldn't be installing IDM 3.5.1.


> Just want to make sure, because
> it will add much complexity to what I am doing.


Why? The IDM4 installer is about the same as the IDM3 installer. The
driver shims are newer (fewer bugs). You can use the new packages and
driver configurations, or you can use your old (existing?) driver
configurations. It's really a pretty painless upgrade.


--
--------------------------------------------------------------------------
David Gersic dgersic_@_niu.edu
Knowledge Partner http://forums.netiq.com

Please post questions in the forums. No support provided via email.

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Installing IDM 3.5.1 - ELF class error?


Identity Manager 4.0.2 Bundle Edition is available to the Novell Open
Enterprise Server customers.

Hi Hawk312,
If you tried to install IDM 3.5.1 like BE engine, please be aware that
now you can use IDM 4.0.2 BE.

Alex


--
al_b
------------------------------------------------------------------------
al_b's Profile: https://forums.netiq.com/member.php?userid=209
View this thread: https://forums.netiq.com/showthread.php?t=47471

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Installing IDM 3.5.1 - ELF class error?


Thanks for the help everyone. To answer some of your questions, I am
trying to upgrade from Identity Manager 2.0 and Netware 6.5. :eek: I am
trying to ultimately get to SLES 11/OES 11 running IDM 4.0.2 (I guess).

So, if ab`s solution above doesnt work out, it sounds as though I will
need to upgrade to 3.5.1 on the Netware server, export the driver and
import it onto a server running SLES 10/OES10 and IDM 3.5.1, then
upgrade IDM on that server to 4, then export the driver again and import
it onto the server running SLES 11/OES11 and IDM 4.0.2?
Thanks.


--
Hawk312
------------------------------------------------------------------------
Hawk312's Profile: https://forums.netiq.com/member.php?userid=874
View this thread: https://forums.netiq.com/showthread.php?t=47471

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Installing IDM 3.5.1 - ELF class error?

On 4/5/2013 9:54 AM, Hawk312 wrote:
>
> Thanks for the help everyone. To answer some of your questions, I am
> trying to upgrade from Identity Manager 2.0 and Netware 6.5. :eek: I am
> trying to ultimately get to SLES 11/OES 11 running IDM 4.0.2 (I guess).
>
> So, if ab`s solution above doesnt work out, it sounds as though I will
> need to upgrade to 3.5.1 on the Netware server, export the driver and
> import it onto a server running SLES 10/OES10 and IDM 3.5.1, then
> upgrade IDM on that server to 4, then export the driver again and import
> it onto the server running SLES 11/OES11 and IDM 4.0.2?
> Thanks.
>
>

Upgrade to 3.5.1.
Then install the 4.0.2 stack on your new box and perform a migration from the old to the new.
The basic steps are outlined here:
https://www.netiq.com/documentation/idm402/idm_upgrade/data/br8h2js.html


0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Installing IDM 3.5.1 - ELF class error?

On Fri, 05 Apr 2013 14:54:02 +0000, Hawk312 wrote:

> Thanks for the help everyone. To answer some of your questions, I am
> trying to upgrade from Identity Manager 2.0 and Netware 6.5.


IDM2? Ugh. Ok, so first, upgrade that in place to IDM3.5.1.

Then choose, are you moving this to SLES11 + eDir, or to OES11? Get that
base up and running first.

Then:

Install IDM402
Bring your existing configuration in to IDM Designer.
Bring your new *server* in to IDM Designer.
Use Designer to "migrate" your old server to your new server.
Deploy the changes.
Relax and enjoy.

You *may* then want to rework your driver configs to use modern packages
and policies.


--
--------------------------------------------------------------------------
David Gersic dgersic_@_niu.edu
Knowledge Partner http://forums.netiq.com

Please post questions in the forums. No support provided via email.

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Installing IDM 3.5.1 - ELF class error?

Also, do you have a complete list of drivers running in IDM 2? While just
upgrading to 3.5.1 on NetWare should be just fine, and will let you
convert the configs' policy linkage stuff (a trivial task that happens
automatically thanks to iManager) some of the drivers (meaning shims) may
have new requirements in GCVs or driver config options in 3.5.1 and so
they could error out. The one that always comes to mind from this time
period is JDBC, but if you lack JDBC drivers then no worries there.

Good luck.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.