jburns80 Super Contributor.
Super Contributor.
850 views

Installing IDM 4.7 to existing Tree

So I'm trying to install the new IDM 4.7 into our existing tree. I have many complaints about the new install method but I digress. The issue I seem to be having is that the configuration takes so long it seems to time out. It gets to a certain point and says "Installing Identity Store" and never does anything productive after that. I've also tried running ndsconfig to add the server and it throws the error that it can't start ndsd and it needs to be started manually. I've never had this much issue with the previous software versions. This new installer seems quite shoddy and the wording in the installer is kind of misleading. Any help would be appreciated.
Labels (1)
0 Likes
10 Replies
Knowledge Partner
Knowledge Partner

Re: Installing IDM 4.7 to existing Tree

On 12/17/2018 11:04 AM, jburns80 wrote:
>
> So I'm trying to install the new IDM 4.7 into our existing tree. I have
> many complaints about the new install method but I digress. The issue I
> seem to be having is that the configuration takes so long it seems to
> time out. It gets to a certain point and says "Installing Identity
> Store" and never does anything productive after that. I've also tried
> running ndsconfig to add the server and it throws the error that it
> can't start ndsd and it needs to be started manually. I've never had
> this much issue with the previous software versions. This new installer
> seems quite shoddy and the wording in the installer is kind of
> misleading. Any help would be appreciated.


David Gersic had an issue like this, but with User App stuff. I cannot
find his message this second. I can ask him if he remembers.

0 Likes
Knowledge Partner
Knowledge Partner

Re: Installing IDM 4.7 to existing Tree

If I recall correctly, that was caused by me running the GUI installer backgrounded (install &). It doesn't seem to like that. If you run it foregrounded (install), then it works.
0 Likes
jburns80 Super Contributor.
Super Contributor.

Re: Installing IDM 4.7 to existing Tree

I'm not running a gui. This is to do an install from scratch on a RHEL7.5 VM. The config gets to the point where it says "Configuring Identity Store" and never finishes. Just runs and runs, but edirectory doesn't seem to ever get configured. Support has been minimal help as they say they've never had this issue before.

dgersic;2492711 wrote:
If I recall correctly, that was caused by me running the GUI installer backgrounded (install &). It doesn't seem to like that. If you run it foregrounded (install), then it works.[/QUOTE
0 Likes
Knowledge Partner
Knowledge Partner

Re: Installing IDM 4.7 to existing Tree

jburns80;2492713 wrote:
I'm not running a gui. This is to do an install from scratch on a RHEL7.5 VM. The config gets to the point where it says "Configuring Identity Store" and never finishes. Just runs and runs, but edirectory doesn't seem to ever get configured. Support has been minimal help as they say they've never had this issue before.

dgersic;2492711 wrote:
If I recall correctly, that was caused by me running the GUI installer backgrounded (install &). It doesn't seem to like that. If you run it foregrounded (install), then it works.


Can you run this using typescript or bash +x and post the output to show what you're seeing?
0 Likes
jburns80 Super Contributor.
Super Contributor.

Re: Installing IDM 4.7 to existing Tree

So here's what I did and here's what his happening to this point.
I have a fresh VM with RHEL 7.5
I uploaded the 4.7 Linux ISO, mounted it and ran install.sh
I chose to install the engine and imanager. The installation completed fine. I then ran configure.sh. I chose the custom option, I chose to add to an existing vault. I then put in all the parameters required, it then proceeded to the point where it said "configuring identity engine" and just hung for a couple of hours. I Checked the master vault that I was trying to attach to and it did add the server to the list of servers, however ndsd never started, it was as if it tried to add the service and didn't complete. I opened a ticket with MF to see if they've seen this before and the tech I have has never tried to do this on RHEL and says that they repackaged the installer for 4.7 in october due to issues. The main issue is that the configuration never finishes though the log says it does.
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Installing IDM 4.7 to existing Tree

On 12/17/2018 09:04 AM, jburns80 wrote:
>
> So I'm trying to install the new IDM 4.7 into our existing tree. I have
> many complaints about the new install method but I digress. The issue I
> seem to be having is that the configuration takes so long it seems to


What configuration step? Are you following the documentation?

> time out. It gets to a certain point and says "Installing Identity
> Store" and never does anything productive after that. I've also tried


I wonder if you are running the configuration script nedlessly. The
install script upgrades the packages, which is all you really need to
upgrade the engine and drivers, and it's usually pretty simple; run the
script, wait for a couple minutes, done.

> running ndsconfig to add the server and it throws the error that it
> can't start ndsd and it needs to be started manually. I've never had
> this much issue with the previous software versions. This new installer
> seems quite shoddy and the wording in the installer is kind of
> misleading. Any help would be appreciated.


I suppose I can understand how you would feel that way if running the
configuration script when not doing a new install. I am pretty sure that
step is only applicable when creating a new vault, not upgrading an
existing one.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.
0 Likes
jburns80 Super Contributor.
Super Contributor.

Re: Installing IDM 4.7 to existing Tree

I'm not really sure why you'd think this was an upgrade. This is a fresh install of 4.7 to RHEL 7.5 that I want to add to an existing tree. But because this 4.7 installer is so worthless I think it would have been easier to install 4.6 and then upgrade instead of trying a clean install. The MF tech even admitted he's never installed on RHEL and that they repackaged the 4.7 installer in October because of issues it had.


ab;2492736 wrote:
On 12/17/2018 09:04 AM, jburns80 wrote:
>
> So I'm trying to install the new IDM 4.7 into our existing tree. I have
> many complaints about the new install method but I digress. The issue I
> seem to be having is that the configuration takes so long it seems to


What configuration step? Are you following the documentation?

> time out. It gets to a certain point and says "Installing Identity
> Store" and never does anything productive after that. I've also tried


I wonder if you are running the configuration script nedlessly. The
install script upgrades the packages, which is all you really need to
upgrade the engine and drivers, and it's usually pretty simple; run the
script, wait for a couple minutes, done.

> running ndsconfig to add the server and it throws the error that it
> can't start ndsd and it needs to be started manually. I've never had
> this much issue with the previous software versions. This new installer
> seems quite shoddy and the wording in the installer is kind of
> misleading. Any help would be appreciated.


I suppose I can understand how you would feel that way if running the
configuration script when not doing a new install. I am pretty sure that
step is only applicable when creating a new vault, not upgrading an
existing one.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Installing IDM 4.7 to existing Tree

jburns80;2492765 wrote:
I'm not really sure why you'd think this was an upgrade. This is a fresh install of 4.7 to RHEL 7.5 that I want to add to an existing tree. But because this 4.7 installer is so worthless I think it would have been easier to install 4.6 and then upgrade instead of trying a clean install. The MF tech even admitted he's never installed on RHEL and that they repackaged the 4.7 installer in October because of issues it had.


So I don't have any RedHat here to test this with. I've done installs and upgrades on SLES, and that went ok for me. Probably that's not especially helpful for you though.

Can you run this in typescript so I can see what it looks like for you?
0 Likes
jburns80 Super Contributor.
Super Contributor.

Re: Installing IDM 4.7 to existing Tree

I'll do that first thing in the morning. Thanks
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Installing IDM 4.7 to existing Tree

On 12/18/2018 07:04 AM, jburns80 wrote:
>
> I'm not really sure why you'd think this was an upgrade. This is a


Looking back I made a bad assumption; sorry about that.

> fresh install of 4.7 to RHEL 7.5 that I want to add to an existing tree.
> But because this 4.7 installer is so worthless I think it would have
> been easier to install 4.6 and then upgrade instead of trying a clean


You could also just do the install portion and then use the old steps to
"configure" IDM, i.e. configure eDirectory (if not already done on this
box) using ndsmanage, load Designer, connect to eDirectory, and create a
new driverset.

> install. The MF tech even admitted he's never installed on RHEL and
> that they repackaged the 4.7 installer in October because of issues it
> had.


I think there was more to it, but I only base that on the post that the
Product Manager (PM) in these forums at the time, specifically calling out
the need for an updated installer for new installs on OES 2018, which came
out after IDM 4.7: https://forums.novell.com/showthread.php?t=508787

For what it's worth, I've done a few new installs with IDM, even using the
configure portion to build a new tree from scratch, including with a
pre-release build (the first ISO, not the current one re-released for OES
2018 support), and never had any issues. To be fair, I do not recall ever
using the 'configure' option to join an existing tree on a new server.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.