Highlighted
Anonymous_User Absent Member.
Absent Member.
171 views

Loopback driver


I have a loopback driver that is supposed to move users into different
containers when their user role changes. I was going to debug it by
checking the trace but I don't see any output from the driver at all in
the trace. The driver is running and everything. I just don't know what
I am overlooking. Even if the code doesn't work the way I want it to
shouldn't I at least be seeing something in the trace?


--
bobbintb
------------------------------------------------------------------------
bobbintb's Profile: https://forums.netiq.com/member.php?userid=5629
View this thread: https://forums.netiq.com/showthread.php?t=48670

Labels (1)
0 Likes
3 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Loopback driver

Hey bobbintb, on 12.09.2013 18:05:06, you wrote:
>
>
> I have a loopback driver that is supposed to move users into different
> containers when their user role changes. I was going to debug it by
> checking the trace but I don't see any output from the driver at all
> in the trace. The driver is running and everything. I just don't know
> what I am overlooking. Even if the code doesn't work the way I want
> it to shouldn't I at least be seeing something in the trace?


1. How are you viewing the trace? The best method is to configure trace
to file per driver.
2. Have you increased the trace level to 3, that is usually enough to
debug most problems with.
3. How is your driver filter configured? You won't see anything in the
driver trace if you aren't at least subscribing to that object class.

--
If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Loopback driver


Well, don't I feel silly. The trace was at 0. I always keep them at 3 or
more so I didn't even think to check it. I figured it was something
simple I was overlooking. Thanks.


--
bobbintb
------------------------------------------------------------------------
bobbintb's Profile: https://forums.netiq.com/member.php?userid=5629
View this thread: https://forums.netiq.com/showthread.php?t=48670

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Loopback driver

On Thu, 12 Sep 2013 16:05:06 +0000, bobbintb wrote:

> I have a loopback driver that is supposed to move users into different
> containers when their user role changes. I was going to debug it by
> checking the trace but I don't see any output from the driver at all in
> the trace.


Is the driver running on a server with a replica of the user object? Is
the driver filter configured to watch for changes to whatever attributes
you're looking for?


--
--------------------------------------------------------------------------
David Gersic dgersic_@_niu.edu
Knowledge Partner http://forums.netiq.com

Please post questions in the forums. No support provided via email.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.