Highlighted
Knowledge Partner
Knowledge Partner

Re: Newbie: fast entry into IDM 4.5

0 Likes
KP03
Visitor.

Re: Newbie: fast entry into IDM 4.5

As i am doing an upgradation process from 4.5 to 4.6.2 so needed to do an upgrade to 4.5.1.1 and

then, only to the following versions.

 

thank you very much for you quick reponse.

0 Likes
Knowledge Partner
Knowledge Partner

Re: Newbie: fast entry into IDM 4.5

Where did you find that info? I think you can safely go to the latest 4.5.x version and then on to 4.6+ - see https://www.netiq.com/documentation/identity-manager-46/setup/data/t42g78tly91u.html for details.
______________________________________________
https://www.is4it.de/identity-access-management
0 Likes
KP03
Visitor.

Re: Newbie: fast entry into IDM 4.5

Actually i was asking for the url for the designer Updates which exits in the path -->> in the Designer,

 Window menu, Preferences,  NetIQ, and  then Identity Manager side tab and the url specified there.

As i found that the URL has been changed and since i am not able to get the update to 4.5.1.1

0 Likes
Knowledge Partner
Knowledge Partner

Re: Newbie: fast entry into IDM 4.5

Do not update Designer, install a fresh copy side by side.

Even with IDM 4.6.3 I'd use the latest Designer version (4.7.3 as of now) rather than 4.6.3 as it's backwards-compatible and settings are saved in the workspace, not the Designer install anyway. Most recent Designer patches are available as full installers, so do not bother with 4.7.0 + Updates, go directly to the latest version available as full install (4.7.2) and only patch from there.
______________________________________________
https://www.is4it.de/identity-access-management
0 Likes
KP03
Visitor.

Re: Newbie: fast entry into IDM 4.5

Thank you for the information. I do pretty much  agree with you but  we have constraints its the client call and i can not do anything

0 Likes
Knowledge Partner
Knowledge Partner

Re: Newbie: fast entry into IDM 4.5

Good luck then! 😉

As you know Designer 4.6 came in NCP and LDAP flavours, if you cannot use a current version and have a choice, my recommendation would be to stick with the NCP version, earlier LDAP Designer versions had some nasty bugs around schema management.
______________________________________________
https://www.is4it.de/identity-access-management
0 Likes
Knowledge Partner
Knowledge Partner

Re: Newbie: fast entry into IDM 4.5

On 1/25/2017 6:15 AM, Gotthard Anger wrote:
> Am 23.01.2017 um 11:11 schrieb Gotthard Anger:
>> Hello,
>>
>> I´m remembering about an article in netiq´s cool solutions with above
>> theme.
>> I can´t find it again.
>> Has someone a link to this article or an other howto for fast start?
>> System is running in test mode and 90 days are a short time to find the
>> answers for the important questions...

>
> Thanks for all answers
> I have some checked already.
> ATM I´m struggling with the software itself. Installation on SLES 12 has
> failed, so I switched to MS Server 2008.
>
> Installation of IDM seems to be generally a pain.


The Linux issue is one of dependencies usually. They are actually
called out in the docs. One subtlety I have not seen if they updated in
the docs is that all dependant packages seem to need the 32 bit and 64
bit versions installed.

Default is to get 64 bit only.


0 Likes
Knowledge Partner
Knowledge Partner

Re: Newbie: fast entry into IDM 4.5

Geoffrey Carman wrote:

> > Installation of IDM seems to be generally a pain.

>
> The Linux issue is one of dependencies usually.


Using Edir 9 instead of 8.8.8 might have complicated things, too, as the IDM
4.5 install source needs to be patched from the IDM 4.5.4+ patch download to
make this work. This as called out in the docs but not exactly intuitive and
easy to overlook. Still waiting for an updated ISO image to get published...

--
http://www.is4it.de/en/solution/identity-access-management/

(If you find this post helpful, please click on the star below.)
______________________________________________
https://www.is4it.de/identity-access-management
0 Likes
Knowledge Partner
Knowledge Partner

Re: Newbie: fast entry into IDM 4.5

Let me guess that the updated iso will be called 4.6 😉
0 Likes
Knowledge Partner
Knowledge Partner

Re: Newbie: fast entry into IDM 4.5

On 1/25/2017 10:40 AM, Lothar Haeger wrote:
> Geoffrey Carman wrote:
>
>>> Installation of IDM seems to be generally a pain.

>>
>> The Linux issue is one of dependencies usually.

>
> Using Edir 9 instead of 8.8.8 might have complicated things, too, as the IDM
> 4.5 install source needs to be patched from the IDM 4.5.4+ patch download to
> make this work. This as called out in the docs but not exactly intuitive and
> easy to overlook. Still waiting for an updated ISO image to get published...


My understanding is that will be known as IDM 4.6. The unified ISO.
Alas. I am with you, a quick update would be wise.


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Newbie: fast entry into IDM 4.5

Am 25.01.2017 um 15:05 schrieb Geoffrey Carman:
> On 1/25/2017 6:15 AM, Gotthard Anger wrote:
>> Am 23.01.2017 um 11:11 schrieb Gotthard Anger:
>>> Hello,
>>>
>>> I´m remembering about an article in netiq´s cool solutions with above
>>> theme.
>>> I can´t find it again.
>>> Has someone a link to this article or an other howto for fast start?
>>> System is running in test mode and 90 days are a short time to find the
>>> answers for the important questions...

>>
>> Thanks for all answers
>> I have some checked already.
>> ATM I´m struggling with the software itself. Installation on SLES 12 has
>> failed, so I switched to MS Server 2008.
>>
>> Installation of IDM seems to be generally a pain.

>
> The Linux issue is one of dependencies usually. They are actually
> called out in the docs. One subtlety I have not seen if they updated in
> the docs is that all dependant packages seem to need the 32 bit and 64
> bit versions installed.
>
> Default is to get 64 bit only.


Trashed the windows server also. Found in the docs, a linux server must
be because of event auditing service, which requires linux.

Restart with sles 12 sp2. Found the integrated installation guide
extremely outdated (4/2015). On netiq doc site the setup guide reported
as 7/2015. In fact the guide is from July 2016. At least the
installation binaries are now correct documented.

Start with Identity Vault. Installing edir 8.8.8 not supported under
SLES 12 SP2. New download: eDir 9.0.0. New install breaks because the
8.8.8 install leaves some rpms in the system.
Have to remove some 8.8.8 rpm´s manually
New install of eDir 9 now successful.
Creating eDir tree w/o issues
Installing IDM engine. NMAS not found. Argh

rpm -q novell-nmas-* reports 4 rpms not installed. If I reinstall them,
rpm tells me, they were already installed.

Biting in desk...

Go
>
>



--
Gotthard Anger
Anwenderbetreuung Netzwerkadministration
Landeskirchenamt der EKM
gotthardanger@no-mx.forums.novell.com
https://forums.novell.com/member.php/35038-gotthardanger

Mails an diese Adresse werden nur nach vorheriger Ansage gelesen!
Mails for this address will only be read if you trigger me before.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Newbie: fast entry into IDM 4.5

On 02/01/2017 07:36 AM, Gotthard Anger wrote:
> Installing IDM engine. NMAS not found. Argh
>
> rpm -q novell-nmas-* reports 4 rpms not installed. If I reinstall them,
> rpm tells me, they were already installed.


As mentioned previously by a couple of us, if you using eDirectory 9.x
then you MUST use the modified installer that comes as part of SP4 or SP5,
or else, yes, the renamed NMAS module causes IDM to halt you.

You could also create and install a blank RPM with the right NMAS-based
name for the old installer, but that was a hack I proved a few months ago
just to be cantankerous. The right way is to get the SP4 or SP5 install,
get the modified installer, and use that to install the IDM engine with
the 4.5 SP0 media, then later patch to SP5, and all is well.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
0 Likes
Knowledge Partner
Knowledge Partner

Re: Newbie: fast entry into IDM 4.5

On 2/1/2017 9:55 AM, ab wrote:
> On 02/01/2017 07:36 AM, Gotthard Anger wrote:
>> Installing IDM engine. NMAS not found. Argh
>>
>> rpm -q novell-nmas-* reports 4 rpms not installed. If I reinstall them,
>> rpm tells me, they were already installed.

>
> As mentioned previously by a couple of us, if you using eDirectory 9.x
> then you MUST use the modified installer that comes as part of SP4 or SP5,
> or else, yes, the renamed NMAS module causes IDM to halt you.
>
> You could also create and install a blank RPM with the right NMAS-based
> name for the old installer, but that was a hack I proved a few months ago
> just to be cantankerous. The right way is to get the SP4 or SP5 install,
> get the modified installer, and use that to install the IDM engine with
> the 4.5 SP0 media, then later patch to SP5, and all is well.


I do wish NetIQ had just re-released that SP0 media with the one JAR
changed so that this complexity would be unnecessary.

It is obvious how confusing it is to most people. Even to some of us
here it is non-trivial, when it really should be.


0 Likes
Knowledge Partner
Knowledge Partner

Re: Newbie: fast entry into IDM 4.5

On 2/1/2017 9:36 AM, Gotthard Anger wrote:
> Am 25.01.2017 um 15:05 schrieb Geoffrey Carman:
>> On 1/25/2017 6:15 AM, Gotthard Anger wrote:
>>> Am 23.01.2017 um 11:11 schrieb Gotthard Anger:
>>>> Hello,
>>>>
>>>> I´m remembering about an article in netiq´s cool solutions with above
>>>> theme.
>>>> I can´t find it again.
>>>> Has someone a link to this article or an other howto for fast start?
>>>> System is running in test mode and 90 days are a short time to find the
>>>> answers for the important questions...
>>>
>>> Thanks for all answers
>>> I have some checked already.
>>> ATM I´m struggling with the software itself. Installation on SLES 12 has
>>> failed, so I switched to MS Server 2008.
>>>
>>> Installation of IDM seems to be generally a pain.

>>
>> The Linux issue is one of dependencies usually. They are actually
>> called out in the docs. One subtlety I have not seen if they updated in
>> the docs is that all dependant packages seem to need the 32 bit and 64
>> bit versions installed.
>>
>> Default is to get 64 bit only.

>
> Trashed the windows server also. Found in the docs, a linux server must
> be because of event auditing service, which requires linux.
>
> Restart with sles 12 sp2. Found the integrated installation guide
> extremely outdated (4/2015). On netiq doc site the setup guide reported
> as 7/2015. In fact the guide is from July 2016. At least the
> installation binaries are now correct documented.
>
> Start with Identity Vault. Installing edir 8.8.8 not supported under
> SLES 12 SP2. New download: eDir 9.0.0. New install breaks because the
> 8.8.8 install leaves some rpms in the system.
> Have to remove some 8.8.8 rpm´s manually
> New install of eDir 9 now successful.
> Creating eDir tree w/o issues
> Installing IDM engine. NMAS not found. Argh
>
> rpm -q novell-nmas-* reports 4 rpms not installed. If I reinstall them,
> rpm tells me, they were already installed.


One issue you have is, eDir has been revved (to 9.0). The OS has been
revved. (SLES 12).

There is a pending IDM release we keep getting teased with (4.6) that
will reset the clock on the installer.

I personally think the approcach taken of eDir 9 support in IDM of a
patch to the 4.5 installer is a mistake. They should have re-released
the 4.5 installer with that patch and been done with it. But my guess is
they felt 4.6 was far enough along that the testing resources required
to re-release that installer would not be worth removing from 4.6. I
just wish they would get 4.6 out the door already to get away from
nonsense like this that you are experiencing.



0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.