Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Anonymous_User Absent Member.
Absent Member.
176 views

NoDefaultFoundException EmailTemplateResolver


Greetings,

I am moving a new workflow into production. It is a simple messaging
workflow that sends a message to a user under certain conditions.
Everything works up to the point of the create E-Mail activity. No
E-Mail is ever sent. I do get an E-Mail from UserApp stating that the
resource request was approved. This comes from the Finish activity.
Here is the error in the server.log:

2013-02-13 08:57:42,174 INFO [STDOUT] (pool-13-thread-10) ERROR [RBPM]
[com.novell.soa.af.impl.LogEvent:logError] [Workflow_Error] Initiated by
cn=idm-userapp,ou=people,dc=med,dc=umich,dc=edu, Error Message:
com.novell.soa.common.i18n.LocalizedResourceResolverNoDefaultFoundException:
The resource resolver
com.novell.soa.notification.impl.vdx.LocalizedEmailTemplateResolver did
not return a resource for the default locale of en. It is required that
a resource exist for the default locale., Process ID:
8c9ec5d1025c4b358d23f68a498f8623, Process Name:
CN=Messaging_PRD,CN=RequestDefs,CN=AppConfig,CN=UserApplication,CN=UserApp,O=services:17,
Activity: Activity1, Recipient:
CN=Bud-Wieser,OU=people,dc=med,dc=umich,dc=edu


I searched project checker for an local messages including "en, but
found none. This same workflow works correctly in QA environment..

-Thanks in advance for any ideas!

-Mike K


--
mkijewsk
------------------------------------------------------------------------
mkijewsk's Profile: https://forums.netiq.com/member.php?userid=2181
View this thread: https://forums.netiq.com/showthread.php?t=46822

Labels (1)
0 Likes
4 Replies
Anonymous_User Absent Member.
Absent Member.

Re: NoDefaultFoundException EmailTemplateResolver

On 02/13/2013 09:34 AM, mkijewsk wrote:
>
> Greetings,
>
> I am moving a new workflow into production. It is a simple messaging
> workflow that sends a message to a user under certain conditions.
> Everything works up to the point of the create E-Mail activity. No
> E-Mail is ever sent. I do get an E-Mail from UserApp stating that the
> resource request was approved. This comes from the Finish activity.
> Here is the error in the server.log:
>
> 2013-02-13 08:57:42,174 INFO [STDOUT] (pool-13-thread-10) ERROR [RBPM]
> [com.novell.soa.af.impl.LogEvent:logError] [Workflow_Error] Initiated by
> cn=idm-userapp,ou=people,dc=med,dc=umich,dc=edu, Error Message:
> com.novell.soa.common.i18n.LocalizedResourceResolverNoDefaultFoundException:
> The resource resolver
> com.novell.soa.notification.impl.vdx.LocalizedEmailTemplateResolver did
> not return a resource for the default locale of en. It is required that
> a resource exist for the default locale., Process ID:
> 8c9ec5d1025c4b358d23f68a498f8623, Process Name:
> CN=Messaging_PRD,CN=RequestDefs,CN=AppConfig,CN=UserApplication,CN=UserApp,O=services:17,
> Activity: Activity1, Recipient:
> CN=Bud-Wieser,OU=people,dc=med,dc=umich,dc=edu
>
>
> I searched project checker for an local messages including "en, but
> found none. This same workflow works correctly in QA environment..
>
> -Thanks in advance for any ideas!
>
> -Mike K
>
>

Greetings,
When you create an Email template, you have to have at least two (2):

#1 is the name without a language

#2 is the name with the default language for the User Application

For Example:
Provisioning Notification
Provisioning Notification_en

*I do believe this requirement is outlined in the documentation.*

You would then add a version of the Email template for each language you
will support after the above two have been satisfied.


--

Sincerely,
Steven Williams
Lead Software Engineer
NetIQ
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: NoDefaultFoundException EmailTemplateResolver


Thanks for your reply William. That wasn't exactly what was wrong, but
your reply got me looking at the email template. It turns out that when
I deployed it into production, the deployment failed. The tool I was
using (Softerra LDAP Admin) didn't appear to throw an error but it did
and I missed it! Once I redeployed the template the error cleared.

-Thanks again!


--
mkijewsk
------------------------------------------------------------------------
mkijewsk's Profile: https://forums.netiq.com/member.php?userid=2181
View this thread: https://forums.netiq.com/showthread.php?t=46822

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: NoDefaultFoundException EmailTemplateResolver

On 02/13/2013 02:24 PM, mkijewsk wrote:
>
> Thanks for your reply William. That wasn't exactly what was wrong, but
> your reply got me looking at the email template. It turns out that when
> I deployed it into production, the deployment failed. The tool I was
> using (Softerra LDAP Admin) didn't appear to throw an error but it did
> and I missed it! Once I redeployed the template the error cleared.
>
> -Thanks again!
>
>

Greetings,
You are aware that the only supported tool to use is the Designer
and not Softerra LDAP Admin?

--

Sincerely,
Steven Williams
Lead Software Engineer
NetIQ
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: NoDefaultFoundException EmailTemplateResolver


It was not a problem with the tool, it was my oversight that missed the
error that was causing the import to fail. Once I realized the template
was not being imported I made the correction needed and imported the
template successfully.

We have a many apps, cots and custom built, that are consuming and
adding data to our LDAP vault. LDAP Admin is one of them and has been
used here for years. We do use Designer extensively as well for IDM and
UA development, modifications, deployments etc...

-Mike K


--
mkijewsk
------------------------------------------------------------------------
mkijewsk's Profile: https://forums.netiq.com/member.php?userid=2181
View this thread: https://forums.netiq.com/showthread.php?t=46822

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.