Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Anonymous_User Absent Member.
Absent Member.
206 views

Null driver fails to start, no log no errors


We run IDM 4.0.2 on Sles 11.

Yesterday we discovered a large .TAO file for a Null driver that handles
some automated account creation tasks (moves, renames, role assignments
& etc.) Attempts to restart the driver fail and nothing is written to
the trace file. No error messages are displayed. The status icon in
iManager changes from the red-with-white-bar to a slowly pulsing green
and the driver status is reported as 'Starting' indefinitely.

The driverset in question spans two servers and the driver will start
and operate normally (so far) on the other server, but we have almost
nothing to go on to troubleshoot the original problem. Anyone ever see
anything similar?


--
keithbmartin
------------------------------------------------------------------------
keithbmartin's Profile: https://forums.netiq.com/member.php?userid=524
View this thread: https://forums.netiq.com/showthread.php?t=51791

Labels (1)
0 Likes
5 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Null driver fails to start, no log no errors

keithbmartin <keithbmartin@no-mx.forums.netiq.com> wrote:
> We run IDM 4.0.2 on Sles 11.


Engine patch level?

> Yesterday we discovered a large .TAO file for a Null driver that handles
> some automated account creation tasks (moves, renames, role assignments
> & etc.)


So not a driver where you can simply clear the cache and resync then?

> Attempts to restart the driver fail and nothing is written to
> the trace file. No error messages are displayed. The status icon in
> iManager changes from the red-with-white-bar to a slowly pulsing green
> and the driver status is reported as 'Starting' indefinitely.
>
> The driverset in question spans two servers and the driver will start
> and operate normally (so far) on the other server, but we have almost
> nothing to go on to troubleshoot the original problem.


Have you restarted ndsd on the problematic server?

> Anyone ever see
> anything similar?
>


Only with drivers hosted in remote loaders.

--
If you find this post helpful and are logged into the web interface, show
your appreciation and click on the star below...
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Null driver fails to start, no log no errors

On Fri, 19 Sep 2014 13:47:13 +0000, keithbmartin wrote:

> We run IDM 4.0.2 on Sles 11.
>
> Yesterday we discovered a large .TAO file for a Null driver that handles
> some automated account creation tasks (moves, renames, role assignments
> & etc.) Attempts to restart the driver fail and nothing is written to
> the trace file. No error messages are displayed. The status icon in
> iManager changes from the red-with-white-bar to a slowly pulsing green
> and the driver status is reported as 'Starting' indefinitely.
>
> The driverset in question spans two servers and the driver will start
> and operate normally (so far) on the other server, but we have almost
> nothing to go on to troubleshoot the original problem. Anyone ever see
> anything similar?


Is more than one instance of the ndsd process running?



--
--------------------------------------------------------------------------
David Gersic dgersic_@_niu.edu
Knowledge Partner http://forums.netiq.com

Please post questions in the forums. No support provided via email.
If you find this post helpful, please click on the star below.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Null driver fails to start, no log no errors


keithbmartin;248933 Wrote:
> We run IDM 4.0.2 on Sles 11.
>
> Yesterday we discovered a large .TAO file for a Null driver that handles
> some automated account creation tasks (moves, renames, role assignments
> & etc.) Attempts to restart the driver fail and nothing is written to
> the trace file. No error messages are displayed. The status icon in
> iManager changes from the red-with-white-bar to a slowly pulsing green
> and the driver status is reported as 'Starting' indefinitely.
>
> The driverset in question spans two servers and the driver will start
> and operate normally (so far) on the other server, but we have almost
> nothing to go on to troubleshoot the original problem. Anyone ever see
> anything similar?


Check the first Event in Cache using Identity Manager Driver Cache
Inspector, Note that a driver's cache can only be read from a server if
the driver is in a ''Stopped'' State. We had an issue once and it was a
corrupt/null event, deleted that first event and the driver started and
processed cache successfully.


--
Kgallogly
------------------------------------------------------------------------
Kgallogly's Profile: https://forums.netiq.com/member.php?userid=2387
View this thread: https://forums.netiq.com/showthread.php?t=51791

0 Likes
Knowledge Partner
Knowledge Partner

Re: Null driver fails to start, no log no errors

On 9/19/2014 12:16 PM, Kgallogly wrote:
>
> keithbmartin;248933 Wrote:
>> We run IDM 4.0.2 on Sles 11.
>>
>> Yesterday we discovered a large .TAO file for a Null driver that handles
>> some automated account creation tasks (moves, renames, role assignments
>> & etc.) Attempts to restart the driver fail and nothing is written to
>> the trace file. No error messages are displayed. The status icon in
>> iManager changes from the red-with-white-bar to a slowly pulsing green
>> and the driver status is reported as 'Starting' indefinitely.
>>
>> The driverset in question spans two servers and the driver will start
>> and operate normally (so far) on the other server, but we have almost
>> nothing to go on to troubleshoot the original problem. Anyone ever see
>> anything similar?

>
> Check the first Event in Cache using Identity Manager Driver Cache
> Inspector, Note that a driver's cache can only be read from a server if
> the driver is in a ''Stopped'' State. We had an issue once and it was a
> corrupt/null event, deleted that first event and the driver started and
> processed cache successfully.


Seen that before as well! Or else that first event kicks off a huge
process (I like toolkit rules that do that) and you cannot stop the
driver tll that event completes.


0 Likes
cpedersen Outstanding Contributor.
Outstanding Contributor.

Re: Null driver fails to start, no log no errors

On 9/19/14, 3:47 PM, keithbmartin wrote:
>
> We run IDM 4.0.2 on Sles 11.
>
> Yesterday we discovered a large .TAO file for a Null driver that handles
> some automated account creation tasks (moves, renames, role assignments
> & etc.) Attempts to restart the driver fail and nothing is written to
> the trace file. No error messages are displayed. The status icon in
> iManager changes from the red-with-white-bar to a slowly pulsing green
> and the driver status is reported as 'Starting' indefinitely.
>
> The driverset in question spans two servers and the driver will start
> and operate normally (so far) on the other server, but we have almost
> nothing to go on to troubleshoot the original problem. Anyone ever see
> anything similar?


Exceptions are not send to the driver log, they are only send to ndstrace.

Run ndstrace with +time +tags +dxml +dvrs and try to start the driver;
it might give you more information.

Also restart ndsd, it's not the first time people have seen that
something is stuck, which gets cleared on a restart.


Casper
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.