dave g Frequent Contributor.
Frequent Contributor.
283 views

PasswordSync Tool does not run on win2016 member RL server

Jump to solution

when attempting to run the Passwordsync Tool.exe on a win2016 RL box it generates the following error message 

~~~~begin error message~~~~~~~

Activation context generation failed for "C:\Users\idmsvcaccount\Downloads\PassSyncTroubleshootingTool\x86\PassSync Troubleshooting Tool.exe". Dependent Assembly Microsoft.VC80.MFC,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.762" could not be found. Please use sxstrace.exe for detailed diagnosis.

~~~~end error message~~~~~~~~~

ideas?

 

 

0 Likes
1 Solution

Accepted Solutions
Knowledge Partner
Knowledge Partner

Re: PasswordSync Tool does not run on win2016 member RL server

Jump to solution
From another forum that complains to missing the same library:

You are missing the Visual C++ 2005 Sp1 Runtime (x86):

http://www.microsoft.com/downloads/details.aspx?familyid=200b2fd9-ae1a-4a14-984d-389c36f85647&displaylang=en

Download and install it and you can run the application.

View solution in original post

5 Replies
kristoffer Trusted Contributor.
Trusted Contributor.

Re: PasswordSync Tool does not run on win2016 member RL server

Jump to solution

From the latest AD patch readme, see below.

I had to install vcredist to make the applet work when i patched.

/Kristoffer

 

---

System Requirements

 

  • Identity Manager 4.7 or later

    Or

    • Identity Manager 4.6 or later
    • Microsoft Visual C++ 2017 Redistributable Packages (vcredist_x64-2017 and vcredist_x86-2017) for Identity Manager Password Synchronization utility

       

      NOTE: These packages are automatically installed with Identity Manager 4.7 or later versions.

0 Likes
dave g Frequent Contributor.
Frequent Contributor.

Re: PasswordSync Tool does not run on win2016 member RL server

Jump to solution

re-applied that ( it was installed), same error message

0 Likes
Knowledge Partner
Knowledge Partner

Re: PasswordSync Tool does not run on win2016 member RL server

Jump to solution

Do you have VC library version 8.0.50727.762 in your system?

0 Likes
Knowledge Partner
Knowledge Partner

Re: PasswordSync Tool does not run on win2016 member RL server

Jump to solution
From another forum that complains to missing the same library:

You are missing the Visual C++ 2005 Sp1 Runtime (x86):

http://www.microsoft.com/downloads/details.aspx?familyid=200b2fd9-ae1a-4a14-984d-389c36f85647&displaylang=en

Download and install it and you can run the application.

View solution in original post

dave g Frequent Contributor.
Frequent Contributor.

Re: PasswordSync Tool does not run on win2016 member RL server

Jump to solution

that's what it was.... thanks! 

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.