wxcn Absent Member.
Absent Member.
163 views

Problem on set E-Mail Notification in a driver


hello!

Follow the E-Mail Notification Guide I configred SMTP server with IP
192.168.1.156 , mail account: nopost@mydomain.com.
In the policy I also configred with the smtp server and mail account to
send something to michael@hisdomain.com. But after the policy run ,the
driver log show a "root@hostname " has been used as the sender's
account. It not use the account "nopost@mydomain.com" I cofigred in SMTP
server or policy.
Why this happend?
Thanks for reply!


--
wxcn
------------------------------------------------------------------------
wxcn's Profile: http://forums.novell.com/member.php?userid=6738
View this thread: http://forums.novell.com/showthread.php?t=451863

Labels (1)
0 Likes
2 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Problem on set E-Mail Notification in a driver

Unfortunately we are going to need a level three trace to be able to see where your policy went
awry. It could be the from address on the default notification collection object. There is a
setting there as well.

On 2/6/2012 9:26 AM, wxcn wrote:
>
> hello!
>
> Follow the E-Mail Notification Guide I configred SMTP server with IP
> 192.168.1.156 , mail account: nopost@mydomain.com.
> In the policy I also configred with the smtp server and mail account to
> send something to michael@hisdomain.com. But after the policy run ,the
> driver log show a "root@hostname " has been used as the sender's
> account. It not use the account "nopost@mydomain.com" I cofigred in SMTP
> server or policy.
> Why this happend?
> Thanks for reply!
>
>


0 Likes
wxcn Absent Member.
Absent Member.

Re: Problem on set E-Mail Notification in a driver


Will Schneider;2173545 Wrote:
> Unfortunately we are going to need a level three trace to be able to see
> where your policy went
> awry. It could be the from address on the default notification
> collection object. There is a
> setting there as well.
>
> On 2/6/2012 9:26 AM, wxcn wrote:
> >
> > hello!
> >
> > Follow the E-Mail Notification Guide I configred SMTP server with IP
> > 192.168.1.156 , mail account: nopost@mydomain.com.
> > In the policy I also configred with the smtp server and mail account

> to
> > send something to michael@hisdomain.com. But after the policy run

> ,the
> > driver log show a "root@hostname " has been used as the sender's
> > account. It not use the account "nopost@mydomain.com" I cofigred in

> SMTP
> > server or policy.
> > Why this happend?
> > Thanks for reply!
> >
> >



Here is the log with level 5.
[02/06/12 22:15:00.082]:IdTree_to_AuTree ST:Applying policy:
%+C%14Cmailtest%-C.
[02/06/12 22:15:00.083]:IdTree_to_AuTree ST: Applying to modify #1.
[02/06/12 22:15:00.084]:IdTree_to_AuTree ST: Evaluating selection
criteria for rule 'mailtest'.
[02/06/12 22:15:00.085]:IdTree_to_AuTree ST: (if-class-name equal
"User") = TRUE.
[02/06/12 22:15:00.086]:IdTree_to_AuTree ST: (if-op-attr
'nspmDistributionPassword' available) = TRUE.
[02/06/12 22:15:00.087]:IdTree_to_AuTree ST: Rule selected.
[02/06/12 22:15:00.088]:IdTree_to_AuTree ST: Applying rule
'mailtest'.
[02/06/12 22:15:00.089]:IdTree_to_AuTree ST: Action:
do-send-email(id="nopost@mydomain.com",server="192.168.1.156",arg-password("password"),"
michael@hisdomain.com","test","test").
[02/06/12 22:15:00.090]:IdTree_to_AuTree ST:
arg-password("portal")
[02/06/12 22:15:00.091]:IdTree_to_AuTree ST:
token-text("portal")
[02/06/12 22:15:00.092]:IdTree_to_AuTree ST: Arg Value: "--
suppressed --".
[02/06/12 22:15:00.093]:IdTree_to_AuTree ST: to("
michael@hisdomain.com")
[02/06/12 22:15:00.094]:IdTree_to_AuTree ST: token-text("
michael@hisdomain.com")
[02/06/12 22:15:00.095]:IdTree_to_AuTree ST: Arg Value: "
michael@hisdomain.com".
[02/06/12 22:15:00.096]:IdTree_to_AuTree ST: subject("test")
[02/06/12 22:15:00.096]:IdTree_to_AuTree ST:
token-text("test")
[02/06/12 22:15:00.097]:IdTree_to_AuTree ST: Arg Value:
"test".
[02/06/12 22:15:00.098]:IdTree_to_AuTree ST: message("test")
[02/06/12 22:15:00.099]:IdTree_to_AuTree ST:
token-text("test")
[02/06/12 22:15:00.100]:IdTree_to_AuTree ST: Arg Value:
"test".
[02/06/12 22:15:00.123]:IdTree_to_AuTree ST:
DirXML Log Event -------------------
Driver: \IDTREE\services\IdTreeDriverSet2\IdTree_to_AuTree
Channel: Subscriber
Status: Error
Message: Code(-9195) Error in
vnd.nds.stream://IDTREE/services/IdTreeDriverSet2/IdTree_to_AuTree/Subscriber/mailtest#XmlData:11
: Couldn't send email: com.sun.mail.smtp.SMTP
SendFailedException: 451 4.1.8 Domain of sender address root@testid
does not resolve

The words marked by red color “root@testid” is the IDM egine server's
hostname


--
wxcn
------------------------------------------------------------------------
wxcn's Profile: http://forums.novell.com/member.php?userid=6738
View this thread: http://forums.novell.com/showthread.php?t=451863

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.