Anonymous_User Absent Member.
Absent Member.
1434 views

Query Parameter not found for Reporting


Hi,

I am working on Reporting module of NetIQ Identity Management 4.5
I am using Jaspersoft iReport Designer 5.6.0 to customize the reports.
To display the reports in tabular format, I am dragging 'Table' from
'Palette' window and then implementing the following query:

select
full_name,
job_title,
employee_status
from
idm_rpt_cfg.idmrpt_identity_cs_v
where
idmrpt_valid_from >= $P{FromDate} AND
idmrpt_valid_from <= $P{ToDate}

Following error is displayed:

Query Parameter not found : FromDate
net.sf.jasperreports.engine.design.JRDesignQuery@47e48459
Query parameter not found :
ToDate net.sf.jasperreports.engine.design.JRDesignQuery@47e48459


--
smita92
------------------------------------------------------------------------
smita92's Profile: https://forums.netiq.com/member.php?userid=9283
View this thread: https://forums.netiq.com/showthread.php?t=53115

Labels (1)
0 Likes
3 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Query Parameter not found for Reporting


Are those parameters (FromDate and ToDate) actuallly defined as
parameters (the left menu, under parameter) in the designer view?


--
mickelarsson
------------------------------------------------------------------------
mickelarsson's Profile: https://forums.netiq.com/member.php?userid=224
View this thread: https://forums.netiq.com/showthread.php?t=53115

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Query Parameter not found for Reporting


Hi,

@mickelarsson: Yes. The parameters (FromDate and ToDate) are defined as
parameters in the left menu, under parameter in the designer view .

THE ISSUE IS RESOLVED BY FOLLOWING STEPS:
1. Create the parameter in the main report
- Right click on the parameters section of main report
- Add parameter
- Set the properties (from property window in right)
2. Create parameters within the sub data source
- Set name , data type as same as main report parameters
3. Map the parameters in main report
- Right click on the table
- Click on Edit Table Dataset
- Select the parameters (middle option)
- Click on Add.
- Choose the parameter (created in dataset)
- Assign Value Expression as $P{Parameter_name}


--
smita92
------------------------------------------------------------------------
smita92's Profile: https://forums.netiq.com/member.php?userid=9283
View this thread: https://forums.netiq.com/showthread.php?t=53115

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Query Parameter not found for Reporting


Hi,

I am now able to add parameters to the custom reports. Everything is
working fine, when previewed by Jaspersoft iReport Designer 5.6.0.
But, after importing the report in NetIQ Reporting module, the
added/custom parameters are *NOT* displayed in the -'Criteria'- section
(Click on -edit- option of the report to view the 'Criteria' section).

HOW TO DISPLAY/PROMPT THE ADDED PARAMETERS WHILE RUNNING THE REPORTS?

Please help as soon as possible.


--
smita92
------------------------------------------------------------------------
smita92's Profile: https://forums.netiq.com/member.php?userid=9283
View this thread: https://forums.netiq.com/showthread.php?t=53115

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.