Knowledge Partner
Knowledge Partner
308 views

Re: AD Driver-Exchange 2010-Powershell snap-ins not registered

On 03.05.2012 16:06, darenr wrote:
>
> The error presented from the AD Driver when attempting to provision an
> account with the homeMDB set: "exchange 2010 exception. code: 0x00000092
> error completing exchange 2010 command. No snap-ins have been registered
> for windows powershell version 2"
>
> - I have the remote loaded installed on the DC but Exchange 2010
> running on another server.
> - The DC has the IDMEx2010Service.exe service running
> - AD Driver account member of Recipient Management and Organization
> Management AD Groups
> - PowerShell: Set-ExecutionPolicy RemoteSigned
> Note: Same AD Driver works in my lab with Remote Loader,
> IDMEx2010Service.exe and Exchange on the same server.
>
> =>The 'Enable-Mailbox' cmdlet could be made to work on the DC when I
> did tried the following in PowerShell:
>
> $Session = New-PSSession -ConfigurationName Microsoft.Exchange
> -ConnectionUri http://<exchangeserver_fqdn>/PowerShell/ -Authentication
> Kerberos
> Import-PSSession $Session
>
> The issue is that when the Powershell session is terminated then so is
> the PSSession to Exchange.
>
> I feel I have overlooked something and would appreciate any
> assistance.


May be a stupid question, but have you installed the Exchange 2010
Management Tools for 64-bit on the DC running the remote loader? This is
a pre-req as per the docs.

http://www.novell.com/documentation/idm401drivers/ad/data/bnutll4.html

Haven't tested it myself, but I suspect you'd get these kind of errors
if you hadn't installed this on the DC (as the IDMEx2010Service makes
use of this local exchange management tools install)

Would also explain why you don't have the issue in test (where Exchange
is on the same box as your DC and thus you do have Exchange management
tools installed on your DC)
Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
Labels (1)
0 Likes
1 Reply
Knowledge Partner
Knowledge Partner

Re: AD Driver-Exchange 2010-Powershell snap-ins not registered

On 04.05.2012 16:16, darenr wrote:
>
> Thanks alexmchugh..
> Reinstalled Exchange 2010 Management Tools for 64-bit and it looks like
> the cmdlets are running.
> Get a new issue that I have seen in the forums before but the
> resolution was unknown in that case:
> =>Exchange 2010 Exception. code:0x00000058 Error completing exchange
> 2010 command. ERROR: No provisioning handler is installed.


Is the IDMEx2010Service running as the AD Driver account? By default
this service is configured to run using the LocalSystem credentials.

Have you looked at the following knowledge base entry?

http://www.novell.com/support/kb/doc.php?id=3608183

The two groups this account needs to be a member of are:
- Recipient Management
- View-Only Organization Management
Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.