Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Anonymous_User Absent Member.
Absent Member.
229 views

Re: IDVault.get not working

No need to use fireEvent in this case - you can simply add this in the
onchange event of the "UserName" field:

This assumes that - like you indicated - both, the field name and the
DAL attribute name, is 'FirstName'

____

function getDetail( dn, fldName, attrName )
{
if ( dn == "" ) return;
try
{
var av = IDVault.get( fldName, dn, "user", attrName );
alert( "Debug: " + av );
}
catch(e)
{
alert( fldName+": error getting "+attrName+" for "+dn+": "+e );
}
}

getDetail( field.getValue(), 'FirstName', 'FirstName' );

____

Wolfgang

On 15.06.2012 20:26, lvaradha wrote:
>
> Hi Wolfgang,
> I changed my code as above, but nothing is getting displayed in the
> form and i am not seeing any error in form and logs either.
>
> Basically i am trying to search for user in UserName field and get
> users FirstName attribute value in the "FirstName" form field for
> modification..
>
> Do you have any idea?
>
>

Labels (1)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.