Anonymous_User Absent Member.
Absent Member.
549 views

Remote Loader/ PassSync (IDM 2.0.1) upgrade to (IDM 4.0.2)


Hello,

I have an old Remote Loader/PassSync within IDM 2.0.1 environnement on
Active Directory 2003

I have to update the environnement to IDM 4.0.2

Any good Ideas about upgrading RemoteLoader/PasSync smoothly ?

I entend to do in place upgrade, may be by istalling IDM 4.0.2 Remote
Loader on a different Folder location than RL IDM 4.0.1, but how about
PassSync upgdare ?

Things are not clear in my mind please help

Regards


--
iammi
------------------------------------------------------------------------
iammi's Profile: https://forums.netiq.com/member.php?userid=382
View this thread: https://forums.netiq.com/showthread.php?t=46324

Labels (1)
0 Likes
12 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Remote Loader/ PassSync (IDM 2.0.1) upgrade to (IDM 4.0.2)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hmmm....... well, the biggest question is:

Are you using Password Sync 1.0 or 2.0? The latter is just like things
are today using Universal Password. The former was a brilliant use of
the Novell Client, new objects in eDirectory, and a lot of good luck to
do everything despite only using NDS Passwords. If the former, this
will be a big part of the project to rip out, but replacing shouldn't be
too bad. If the latter, just upgrade the RL and then upgrade filters
from the applet like you would do with any version of the filters and
driver.

Good luck.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
Comment: Using GnuPG with undefined - http://www.enigmail.net/

iQIcBAEBAgAGBQJQv3SMAAoJEF+XTK08PnB59RwP/ie5y68OdPUMzuaTDtt2Eu+u
LomL8y0nnGm59ZfkS0SqQ/5V1iQshHc2RYzi2/WVL+0kQ6t+A4oa/MPlXyFT1qeP
pW0HPgC1LqRmg6AukIW+fo4zhSntE8KKY5Foq+vf6op/YKiqq1iYTm0Fg+L3Q0r9
4yqT/PhnsYaphxtkaOHVBqEsIrMFvgcmtxSV1CnE5PL5QHPrljVt3easVf5Ke1pS
50bfbs31fGezThj3F2jvszL1DzaZLxAaSSNYm2sq0E6Rgk9PUb9QRon/W5ODkOJS
eFStjc7ciwT8UsbCtZgFq6FRGUhdCrMW6dlQ7C4+g54kN3rO+kJKvUlM4iftuSYD
6H/lEJfLZYotgY/Y698ZqYcnlfaYbZkdT6OxrUVz+70W1l2pWpU2m71cOhHAiGFP
OwRWaZVJcMZy0xiPGNXHTGG+c3j6OpS8PXJeWHDQcZaLk+ULiiXYrgSrKyff/6vh
vrcQ4pB419ea4Uh3GAA69JlRHYitZ8/HbIxghtFkd4xPm9xsx2sCRhbijBNnfEfu
KISi+OgMcaV22BFa5Ww/mwc81nN6Lsy2EH7fnN4RU6AJ8+mmI4qBibgOwDSYhgaP
Z2vGSS4naSqiu+Qsz8iTMw2f0aPi4IQbnZw707vhgolMqgSljWPX1zoAqhoiA2eY
4ky+WvlVNPinmIbmaSyK
=lwWs
-----END PGP SIGNATURE-----
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Remote Loader/ PassSync (IDM 2.0.1) upgrade to (IDM 4.0.2)

On Wed, 05 Dec 2012 14:44:01 +0000, iammi wrote:

> I have an old Remote Loader/PassSync within IDM 2.0.1 environnement on
> Active Directory 2003
>
> I have to update the environnement to IDM 4.0.2
>
> Any good Ideas about upgrading RemoteLoader/PasSync smoothly ?


For the password filter dlls, just use the control panel, deploy the new
ones, and restart the DCs.

For the remote loader, just install the new remote loader.


--
--------------------------------------------------------------------------
David Gersic dgersic_@_niu.edu
Knowledge Partner http://forums.netiq.com

Please post questions in the forums. No support provided via email.

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Remote Loader/ PassSync (IDM 2.0.1) upgrade to (IDM 4.0.2)


Note that installing the 402 RL (402 Ad shim) requires IDM 402 AD
activation credentials.
---------------------------------------------------------------------------------------

For the password filter dlls, just use the control panel, deploy the
new
ones, and restart the DCs.

For the remote loader, just install the new remote loader.


--
--------------------------------------------------------------------------
David Gersic
dgersic_@_niu.edu
Knowledge Partner
http://forums.netiq.com

Please post questions in the forums. No support provided via email.


--
vivekbm
------------------------------------------------------------------------
vivekbm's Profile: https://forums.netiq.com/member.php?userid=528
View this thread: https://forums.netiq.com/showthread.php?t=46324

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Remote Loader/ PassSync (IDM 2.0.1) upgrade to (IDM 4.0.2)


How to know the version of PassSync installed ? from RL traces ?

Regards


--
iammi
------------------------------------------------------------------------
iammi's Profile: https://forums.netiq.com/member.php?userid=382
View this thread: https://forums.netiq.com/showthread.php?t=46324

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Remote Loader/ PassSync (IDM 2.0.1) upgrade to (IDM 4.0.2)

On Thu, 06 Dec 2012 11:04:02 +0000, iammi wrote:

> How to know the version of PassSync installed ? from RL traces ?


If anything, it's probably in the control panel.


--
--------------------------------------------------------------------------
David Gersic dgersic_@_niu.edu
Knowledge Partner http://forums.netiq.com

Please post questions in the forums. No support provided via email.

0 Likes
Knowledge Partner
Knowledge Partner

Re: Remote Loader/ PassSync (IDM 2.0.1) upgrade to (IDM 4.0.2)

On 12/6/2012 9:30 AM, David Gersic wrote:
> On Thu, 06 Dec 2012 11:04:02 +0000, iammi wrote:
>
>> How to know the version of PassSync installed ? from RL traces ?

>
> If anything, it's probably in the control panel.


Version of PassSync as V1 vs V2. i am not sure.

version of Pwfilter.dll is NOT shown in any useful way. Be a nice
enhancement, to have the applet that shows the version of the
pwfilter.dll as well as its running state... But it does not.

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Remote Loader/ PassSync (IDM 2.0.1) upgrade to (IDM 4.0.2)


Well, We are not used to such thing from Novell ( impossible to
determine component Version )

Now I have an IDM 2.0.1 infrastructure that I dont now what Passync
Version is

Any advices abour upgrading to IDM 4.0.2 ( Passync )

Geoffrey please answer, I rely on you !

Rgards


--
iammi
------------------------------------------------------------------------
iammi's Profile: https://forums.netiq.com/member.php?userid=382
View this thread: https://forums.netiq.com/showthread.php?t=46324

0 Likes
Knowledge Partner
Knowledge Partner

Re: Remote Loader/ PassSync (IDM 2.0.1) upgrade to (IDM 4.0.2)

On 12/6/2012 10:04 AM, iammi wrote:
>
> Well, We are not used to such thing from Novell ( impossible to
> determine component Version )


You can. It is a DLL, so you look at the file on the NTFS file system
on each server, (c:\windows\system32\pwfilter.dll I think) and check the
version there.

> Now I have an IDM 2.0.1 infrastructure that I dont now what Passync
> Version is


Trace will reveal it pretty quick. Does a password change out of AD
remain a <modify-password> event or does it become a <modify> event for
the attribute nspmDistributionPassword ?

Former is 1.0. Later is 2.0 I think.

Now it may actually be that it is Sub channel to get the hint, by
looking at what event starts a password change. If it is a modify of
nspmDistributionPassword it is 2.0. Otherwise 1.0.


> Any advices abour upgrading to IDM 4.0.2 ( Passync )
>
> Geoffrey please answer, I rely on you !


Turn that into a Star Wars reference and I will help. (Help me Obi-wan,
you're my only hope..)

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Remote Loader/ PassSync (IDM 2.0.1) upgrade to (IDM 4.0.2)

On Thu, 06 Dec 2012 15:04:02 +0000, iammi wrote:

> Well, We are not used to such thing from Novell ( impossible to
> determine component Version )
>
> Now I have an IDM 2.0.1 infrastructure that I dont now what Passync
> Version is


Assume it's v2. Upgrade to 4.02. Then the version you had won't matter.


--
--------------------------------------------------------------------------
David Gersic dgersic_@_niu.edu
Knowledge Partner http://forums.netiq.com

Please post questions in the forums. No support provided via email.

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Remote Loader/ PassSync (IDM 2.0.1) upgrade to (IDM 4.0.2)


Thanks all of you,

It's 2.0

Best regards !


--
iammi
------------------------------------------------------------------------
iammi's Profile: https://forums.netiq.com/member.php?userid=382
View this thread: https://forums.netiq.com/showthread.php?t=46324

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Remote Loader/ PassSync (IDM 2.0.1) upgrade to (IDM 4.0.2)

Geoffrey Carman wrote:

> version of Pwfilter.dll is NOT shown in any useful way. Be a nice
> enhancement, to have the applet that shows the version of the pwfilter.dll as
> well as its running state... But it does not.


the pwsync control applet shows remote filters as outdated if they are older
versions than the one the RL has (not which file it takes for reference, since
the RL does not have to be DC and might not have the filter installed at all).

See http://www.novell.com/support/kb/doc.php?id=3976631:

"If the PWFILTER.DLL file on a Domain controller is older than the PWFILTER.DLL
file on the system running the remote loader, the status will be "Outdated"
Please update all the Domain Controllers with the latest PWFILTER.DLL. After
doing this make sure that the updated Domain Controllers have been rebooted."

--

0 Likes
Knowledge Partner
Knowledge Partner

Re: Remote Loader/ PassSync (IDM 2.0.1) upgrade to (IDM 4.0.2)

On 12/6/2012 10:57 AM, Lothar Haeger wrote:
> Geoffrey Carman wrote:
>
>> version of Pwfilter.dll is NOT shown in any useful way. Be a nice
>> enhancement, to have the applet that shows the version of the pwfilter.dll as
>> well as its running state... But it does not.

>
> the pwsync control applet shows remote filters as outdated if they are older
> versions than the one the RL has (not which file it takes for reference, since
> the RL does not have to be DC and might not have the filter installed at all).
>
> See http://www.novell.com/support/kb/doc.php?id=3976631:
>
> "If the PWFILTER.DLL file on a Domain controller is older than the PWFILTER.DLL
> file on the system running the remote loader, the status will be "Outdated"
> Please update all the Domain Controllers with the latest PWFILTER.DLL. After
> doing this make sure that the updated Domain Controllers have been rebooted."


Cool! That is quite useful.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.