Highlighted
Absent Member.
Absent Member.
194 views

Reporting fails with "REST Error UnparsableJSONResponse, 500"

Reporting Module version 4.0.2 B, Build revision 4490
Roles Based Provisioning Module Version 4.0.2 Patch B, Build Revision 39286

After enabling https on UA Reorting fails with "REST Error
UnparsableJSONResponse, 500".
In jboss.log it says:
Authenticated User cn=uaadmin,ou=sa,ou=entities,ou=idv,o=top
13:26:24,954 INFO [STDOUT] INFO [RPT]
[com.novell.idm.rpt.auth.server.rest.Tokens:createToken] REST Endpoint:
Authentication token is created for
cn=uaadmin,ou=sa,ou=entities,ou=idv,o=top.
13:26:25,016 ERROR [[REST]] Servlet.service() for servlet REST threw
exception
java.lang.IllegalStateException
at com.novell.idm.rpt.core.server.security.UserInfo.isExpired
(UserInfo.java:228)
at com.novell.idm.rpt.core.server.j2ee.AuthFilter.checkPermission
(AuthFilter.java:112)
at com.novell.idm.rpt.core.server.j2ee.AuthFilter.doFilter
(AuthFilter.java:59)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter
(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter
(ApplicationFilterChain.java:206)
Labels (1)
0 Likes
5 Replies
Highlighted
Absent Member.
Absent Member.

Sorry! Posted before finishing. Reporting fails with "REST ErrorUnparsableJSONResponse, 500"

UA running 11sp1 64-bit
4 GB RAM
46 GB disk on / (37G free)

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Sorry! Posted before finishing. Reporting fails with "REST ErrorUnparsableJSONResponse, 500"

On 02/28/2013 07:39 AM, Martin Oldin wrote:
> UA running 11sp1 64-bit
> 4 GB RAM
> 46 GB disk on / (37G free)
>

Greetings,

1) Close all open instances of the browser
2) Start 1 new browser and clear the cache and cookies and then close it
3) Start 1 new browser, access Reporting and try to login

--

Sincerely,
Steven Williams
Lead Software Engineer
NetIQ
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Sorry! Posted before finishing. Reporting fails with "RESTError UnparsableJSONResponse, 500"

On Thu, 28 Feb 2013 13:04:29 +0000, Steven Williams wrote:

> On 02/28/2013 07:39 AM, Martin Oldin wrote:
>> UA running 11sp1 64-bit
>> 4 GB RAM
>> 46 GB disk on / (37G free)
>>

> Greetings,
>
> 1) Close all open instances of the browser 2) Start 1 new browser and
> clear the cache and cookies and then close it 3) Start 1 new browser,
> access Reporting and try to login


Tried from two different computers (one SLES, One Windows) which have
never launched reporting --> the result is the same.
I was using https://uasrv:8534/IDMRPT (since it is now SSL'ed).
After clearing the browser cache it works with http://uasrv:8180/IDMRPT

Thank you very much for your help.

- martin
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Sorry! Posted before finishing. Reporting fails with "REST ErrorUnparsableJSONResponse, 500"

On 02/28/2013 08:37 AM, Martin Oldin wrote:
> On Thu, 28 Feb 2013 13:04:29 +0000, Steven Williams wrote:
>
>> On 02/28/2013 07:39 AM, Martin Oldin wrote:
>>> UA running 11sp1 64-bit
>>> 4 GB RAM
>>> 46 GB disk on / (37G free)
>>>

>> Greetings,
>>
>> 1) Close all open instances of the browser 2) Start 1 new browser and
>> clear the cache and cookies and then close it 3) Start 1 new browser,
>> access Reporting and try to login

>
> Tried from two different computers (one SLES, One Windows) which have
> never launched reporting --> the result is the same.
> I was using https://uasrv:8534/IDMRPT (since it is now SSL'ed).
> After clearing the browser cache it works with http://uasrv:8180/IDMRPT
>
> Thank you very much for your help.
>
> - martin
>

Greetings Martin,
If you want to use HTTPS, then the certificate that jboss is running
with has to be added to the cacerts file (which will require a restart
of JBoss once that is done). Otherwise Login operation of Reporting
will fail.

--

Sincerely,
Steven Williams
Lead Software Engineer
NetIQ
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Sorry! Posted before finishing. Reporting fails with "RESTError UnparsableJSONResponse, 500"

On Thu, 28 Feb 2013 14:11:51 +0000, Steven Williams wrote:
>>

> Greetings Martin,
> If you want to use HTTPS, then the certificate that jboss is running
> with has to be added to the cacerts file (which will require a restart
> of JBoss once that is done). Otherwise Login operation of Reporting
> will fail.


Right. Pretty sure I did that, but will do it again.

Thank you.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.