Highlighted
Absent Member.
Absent Member.
567 views

Silent Install Questions for IDM v4.5 UserApp


Silent install of IDM v4.5 UserApp on RHEL v6.5 using the
user_app.configure.properties and configupdate.properties files from the
IDM v4.5 media as my template. The components installed are Tomcat,
PostgreSQL, OSP and UserApp. No SSPR.


/mnt/products/RBPM/user_app_install/IdmUserApp.bin -i silent -f
/root/user_app.configure.properties

The install runs with no errors, and everything is configured except the
following items. To get around the problem, I run configupdate.sh to set
the values before starting Tomcat for the first time. The goal is to be
able to run the the silent install, and start Tomcat without having to
run configupdate.

1) The "Identity Vault Administrator Password" field is blank, despite
in the configupdate.properties file having a value for
"com.novell.idm.ldap.admin.pass=novell".
BTW, if I start Tomcat, early in the startup I see the following
exception in the catalina.out file. If I run the configupdate utility
and set the admin password, this error goes away.


2016-06-19 22:36:43,418 [localhost-startStop-1] FATAL
com.sssw.fw.directory.api.EboDirectoryFactory- The admin user null could
not be authenticated against authority 192.168.0.51. Please verify the
admin credentials.
com.sssw.fw.directory.api.EboInvalidCredentialsException

2) How is the "OAuth client secret" values set under the "SSO Clients"
tab when doing a silent install? It seems the fields get a value set to
something. Again I get around this by running the configupdate utility,
and I set them to a known value.

3) Since I am not using SSPR, how can I *_NOT_* set a value for the "OSP
Oauth redirect url" field under the "SSO Clients" tab in the SSPR
section when using the silent install?

Thanks in advance for any solutions or ideas!


--
rsimonsatidentropy
------------------------------------------------------------------------
rsimonsatidentropy's Profile: https://forums.netiq.com/member.php?userid=3816
View this thread: https://forums.netiq.com/showthread.php?t=56054

Labels (1)
0 Likes
4 Replies
Highlighted
Absent Member.
Absent Member.

Rsimonsatidentropy,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.
https://www.partnernetprogram.com/partnerfinder/find.html

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.microfocus.com/faq.php

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team
http://forums.microfocus.com



0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Hi,

On 20.06.2016 05:59, rsimonsatidentropy wrote:
>
> Silent install of IDM v4.5 UserApp on RHEL v6.5 using the
> user_app.configure.properties and configupdate.properties files from the
> IDM v4.5 media as my template. The components installed are Tomcat,
> PostgreSQL, OSP and UserApp. No SSPR.
>
>
> /mnt/products/RBPM/user_app_install/IdmUserApp.bin -i silent -f
> /root/user_app.configure.properties
>
> The install runs with no errors, and everything is configured except the
> following items. To get around the problem, I run configupdate.sh to set
> the values before starting Tomcat for the first time. The goal is to be
> able to run the the silent install, and start Tomcat without having to
> run configupdate.
>
> 1) The "Identity Vault Administrator Password" field is blank, despite
> in the configupdate.properties file having a value for
> "com.novell.idm.ldap.admin.pass=novell".
> BTW, if I start Tomcat, early in the startup I see the following
> exception in the catalina.out file. If I run the configupdate utility
> and set the admin password, this error goes away.


I've noticed the same in all my silent installs and have opened an SR
for this. You should file one as well.


>
>
> 2016-06-19 22:36:43,418 [localhost-startStop-1] FATAL
> com.sssw.fw.directory.api.EboDirectoryFactory- The admin user null could
> not be authenticated against authority 192.168.0.51. Please verify the
> admin credentials.
> com.sssw.fw.directory.api.EboInvalidCredentialsException
>
> 2) How is the "OAuth client secret" values set under the "SSO Clients"
> tab when doing a silent install? It seems the fields get a value set to
> something. Again I get around this by running the configupdate utility,
> and I set them to a known value.
>
> 3) Since I am not using SSPR, how can I *_NOT_* set a value for the "OSP
> Oauth redirect url" field under the "SSO Clients" tab in the SSPR
> section when using the silent install?
>
> Thanks in advance for any solutions or ideas!
>
>



--
Norbert
--
Norbert
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

On 6/19/16 11:59 PM, rsimonsatidentropy wrote:
>
> Silent install of IDM v4.5 UserApp on RHEL v6.5 using the
> user_app.configure.properties and configupdate.properties files from the
> IDM v4.5 media as my template. The components installed are Tomcat,
> PostgreSQL, OSP and UserApp. No SSPR.
>
>
> /mnt/products/RBPM/user_app_install/IdmUserApp.bin -i silent -f
> /root/user_app.configure.properties
>
> The install runs with no errors, and everything is configured except the
> following items. To get around the problem, I run configupdate.sh to set
> the values before starting Tomcat for the first time. The goal is to be
> able to run the the silent install, and start Tomcat without having to
> run configupdate.
>
> 1) The "Identity Vault Administrator Password" field is blank, despite
> in the configupdate.properties file having a value for
> "com.novell.idm.ldap.admin.pass=novell".
> BTW, if I start Tomcat, early in the startup I see the following
> exception in the catalina.out file. If I run the configupdate utility
> and set the admin password, this error goes away.
>
>
> 2016-06-19 22:36:43,418 [localhost-startStop-1] FATAL
> com.sssw.fw.directory.api.EboDirectoryFactory- The admin user null could
> not be authenticated against authority 192.168.0.51. Please verify the
> admin credentials.
> com.sssw.fw.directory.api.EboInvalidCredentialsException
>
> 2) How is the "OAuth client secret" values set under the "SSO Clients"
> tab when doing a silent install? It seems the fields get a value set to
> something. Again I get around this by running the configupdate utility,
> and I set them to a known value.
>
> 3) Since I am not using SSPR, how can I *_NOT_* set a value for the "OSP
> Oauth redirect url" field under the "SSO Clients" tab in the SSPR
> section when using the silent install?
>
> Thanks in advance for any solutions or ideas!
>
>

Greetings,
Do you have the following property set in your
"user_app.configure.properties" file:

NOVL_UA_OSP_LDAP_ADMIN_PWD

--
Sincerely,
Steven Williams
Lead Software Engineer
Micro Focus
0 Likes
Highlighted
Absent Member.
Absent Member.


Thanks for the reply. I do not see that property in either my file or
the template file from the IDM45 media. Any chance you mean the
following property instead, "NOVL_UA_OSP_PWD="?


--
rsimonsatidentropy
------------------------------------------------------------------------
rsimonsatidentropy's Profile: https://forums.netiq.com/member.php?userid=3816
View this thread: https://forums.netiq.com/showthread.php?t=56054

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.