ALERT! The community will be read-only on April 19, 8am Pacific as the migration begins. Read more for important details.
ALERT! The community will be read-only on April 19, 8am Pacific as the migration begins.Read more for important details.
Absent Member.
Absent Member.
1285 views

Upgrade Identity Reporting from 4.5.3 to 4.5.6

Hello everyone, i am upgrading a development environment from one of my clients from IDM from version 4.5 to version 4.7.
I already upraded the eDirectory and the next step is to upgrade de Identity Engine. When i try to run the installer, it fails with this error:
Installer has detected one or more obsolete components of Identity Manager
1) Identity Reporting [Version "4.5.3"] [Upgrade is not supported]

So like the error says, i need to upgrade the version 4.5.3 of identity reporting to version 4.5.6 (according to what the guide says). But when i trying to find the path in the novell download page, the only version that i cant find is the 4.5.3.
Can anyone give me a hint of how to procede with this installation? i need to find the patch and know the needed steps to install it sucesfully
Thanks in advance!!!
Labels (1)
6 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

gtejo wrote:

> Can anyone give me a hint of how to procede with this installation


You could try an intermediate upgrade to 4.6 and move on to 4.7 from there. I
would expect the 4.6.0 installer to be able to upgrade from the previous
current patch version.

You could open a service request and have MF sort that out.

You could probably fake your 4.5 install to report 4.5.6 as version or tweak
the install script to accept 4.5.3 (both definitely unsupported but may be fun
- it's a dev environment, you said, right?)

--
http://www.is4it.de/en/solution/identity-access-management/

(If you find this post helpful, please click on the star below.)
______________________________________________
https://www.is4it.de/identity-access-management
Absent Member.
Absent Member.

Thank you very much for the answer!! I will try tomorrow again.
Knowledge Partner Knowledge Partner
Knowledge Partner

gtejo;2495613 wrote:
Hello everyone, i am upgrading a development environment from one of my clients from IDM from version 4.5 to version 4.7.
I already upraded the eDirectory and the next step is to upgrade de Identity Engine. When i try to run the installer, it fails with this error:
Installer has detected one or more obsolete components of Identity Manager
1) Identity Reporting [Version "4.5.3"] [Upgrade is not supported]

So like the error says, i need to upgrade the version 4.5.3 of identity reporting to version 4.5.6 (according to what the guide says). But when i trying to find the path in the novell download page, the only version that i cant find is the 4.5.3.
Can anyone give me a hint of how to procede with this installation? i need to find the patch and know the needed steps to install it sucesfully
Thanks in advance!!!


IDM 4.5 Identity Applications 4.5.6

https://download.novell.com/Download?buildid=H25aINSpV88~

Good luck with your upgrade.
Knowledge Partner Knowledge Partner
Knowledge Partner

dgersic wrote:

> IDM 4.5 Identity Applications 4.5.6
>
> https://download.novell.com/Download?buildid=H25aINSpV88~
>
> Good luck with your upgrade.


AFAIK, Reporting is not part of that patch...

--
http://www.is4it.de/en/solution/identity-access-management/

(If you find this post helpful, please click on the star below.)
______________________________________________
https://www.is4it.de/identity-access-management
Absent Member.
Absent Member.

Yep i already try this one, today im going to try the upgrade to the IDM 4.6 version
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

***UPDATED RESPONSE***

For anyone else who runs into this issue attempting to upgrade NetIQ IDM 4.5.6 to 4.7 (as outlined here: https://www.netiq.com/documentation/identity-manager-47/releasenotes_idm47/data/releasenotes_idm47.html#upgrading-from-identity-manager-456-to-identity-manager-47) and receives the following error:

Do you accept the terms of Identity Manager 4.7 license agreement [y/n/q] ? y
Installer has detected one or more obsolete components of Identity Manager
  1 ) Identity Reporting [Version "4.5.3"] [Upgrade is not supported]
Installation failed. Check /var/opt/netiq/idm/log/idminstall.log for more details.
 
You can bypass this error message by modifying the installation script for IDM 4.7.0 (since you will no longer be able to use EAS for Identity Reporting):
 

1) Copy mounted ISO into different location (For modification)
2) Open install.sh file
3) Search for isupg='isReportingAppUpgReq'
4) Comment out the line referenced above and add a new line with the value below:

#isupg='isReportingAppUpgReq'
isupg=0
ver='ReportingAppVersion'

5) Save the changes
6) Launch install.sh to proceed with the upgrade

 

PLEASE NOTE: This solution has provided for your convenience and is offered 'AS IS' without any implied warranty
 
Explanation of why this is necessary: As you might be aware, 'Identity Reporting Version 4.5.3' was the last/most current version of EAS/Identity Reporting released for IDM 4.5.x and has since been deprecated in favor of 'Sentinel Log Management for IGA' as the Identity Reporting component.
 
This is explained further in the NetIQ Identity Manager 4.7 Release Notes section 'Upgrading from Identity Manager 4.5.6' as well as Step 3 of each of the following IDM 4.7.x docs:
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.