Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Anonymous_User Absent Member.
Absent Member.
527 views

UserApp unable to load Keystore during JBoss startup ?


New installation of UserApp and I wanted to install HPD. After
configuring SSO provider and JBoss restart, I get the below error
message: The key password was correctly punched during config and not
sure how to resolve this, as UserApp is inaccessible now ? Any thoughts
? Please help.

Root Exception: java.io.IOException
Keystore was tampered with, or password was incorrect
2014-06-25 14:57:14,706 INFO [STDOUT] (main) OSPLOGGING.150002001
2014-06-25 14:57:14,707 ERROR [STDERR] (main) OSPCommonException
Base Cause Exception: IOException
Base Cause Message: Keystore was tampered with, or password was
incorrect
LocalizableMessages
User Messages:
Loggable Messages:
LocalizableLoggableMessage
LocalizableMessage
Res Desc: com.novell.osp.resource.logging.OSPLoggingResDesc
Resource Id: OSPLOGGING.150002004
Resource Parameter:
/opt/iam/netiq/jboss/server/IDMProv/conf/osp.jks
Level: FATAL
Java Class: com.novell.osp.OSPKeys
Java Method: A
Jave Line Number: -1
Thread Name: main
Correlation Id: b84fe1d4-9b17-476f-a61a-9008b00c5ac0
Was logged: true
2014-06-25 14:57:14,707 ERROR [STDERR] (main) at
com.novell.osp.OSPKeys.A(Unknown Source)
2014-06-25 14:57:14,708 ERROR [STDERR] (main) at
com.novell.osp.OSPKeys.B(Unknown Source)
2014-06-25 14:57:14,708 ERROR [STDERR] (main) at
com.novell.osp.OSPKeys.initialize(Unknown Source)
2014-06-25 14:57:14,708 ERROR [STDERR] (main) at
com.novell.osp.OSPTenantConfig.setKeys(Unknown Source)
2014-06-25 14:57:14,708 ERROR [STDERR] (main) at
com.novell.osp.OSPTenant.start(Unknown Source


--
sunnikrishnan
------------------------------------------------------------------------
sunnikrishnan's Profile: https://forums.netiq.com/member.php?userid=7619
View this thread: https://forums.netiq.com/showthread.php?t=51179

Labels (1)
0 Likes
5 Replies
Highlighted
Anonymous_User Absent Member.
Absent Member.

Re: UserApp unable to load Keystore during JBoss startup ?


Q: Is there any special characters in the password for the keystore?
(i.e. quote, ampersand, etc)


--
ScorpionSting
------------------------------------------------------------------------
ScorpionSting's Profile: https://forums.netiq.com/member.php?userid=469
View this thread: https://forums.netiq.com/showthread.php?t=51179

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: UserApp unable to load Keystore during JBoss startup ?


Yes special characters were there. Couple of them. Is that not supported
? 😞


--
sunnikrishnan
------------------------------------------------------------------------
sunnikrishnan's Profile: https://forums.netiq.com/member.php?userid=7619
View this thread: https://forums.netiq.com/showthread.php?t=51179

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: UserApp unable to load Keystore during JBoss startup ?


It wouldn't be the first time that such a bug existed... If you can, try
configuring without special characters and see if that resolves the
issue. If it does, log an NTS call so a bug can be raised.


--
ScorpionSting
------------------------------------------------------------------------
ScorpionSting's Profile: https://forums.netiq.com/member.php?userid=469
View this thread: https://forums.netiq.com/showthread.php?t=51179

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: UserApp unable to load Keystore during JBoss startup ?

On 06/25/2014 07:04 PM, ScorpionSting wrote:
>
> It wouldn't be the first time that such a bug existed... If you can, try
> configuring without special characters and see if that resolves the
> issue. If it does, log an NTS call so a bug can be raised.
>
>

Greetings,
I would do the following:

Stop jboss

Confirm that you can list the contents of the file
/opt/iam/netiq/jboss/server/IDMProv/conf/osp.jks using keytool. You will
have to provide the password.

If that works then, stop jboss, lauch configupdate, go to the Auth tab,
and make sure the patch to the osp.jks file is correct, the alias is
correct, and re-enter the password. Then press ok to save the changes.

Then delete the tmp and work directories under JBoss

Restart JBoss

Examine the log


--

Sincerely,
Steven Williams
Lead Software Engineer
NetIQ
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: UserApp unable to load Keystore during JBoss startup ?


Thanks. Content listing with the current password worked. I ran
configupdate again and the path to osp.jks was not set right and I fixed
that and it worked. Thanks all for the help. Sunil.


--
sunnikrishnan
------------------------------------------------------------------------
sunnikrishnan's Profile: https://forums.netiq.com/member.php?userid=7619
View this thread: https://forums.netiq.com/showthread.php?t=51179

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.