kmaule Absent Member.
Absent Member.
286 views

Which Designer for getting latest AD Exchange packages


My client is in an IDM 4.0.2 engine environment running 4.0.0.0 AD
drivers. We want to enable the PowerShell method for provisioning
Exchange mailbox. I did a test upgrade of my Designer 4.0.2 with latest
packages.

Saw a warning (attached) that Designer 4.5 is needed to "address a
weighting problem with policies..."

Also
"AD Entitlement and Exchange Mailbox Package requires:
IDM 4.0.2 w/Eng Patch 5 or IDM 4.5
Designer version 4.0.2. Auto Update 3 or Later or Designer 4.5"

My question: is Designer 4.5 "safe" with IDM 4.0.2?
Cheers,
Kirk

284


+----------------------------------------------------------------------+
|Filename: Screen Shot 2015-05-19 at 15.16.08.png |
|Download: https://forums.netiq.com/attachment.php?attachmentid=284 |
+----------------------------------------------------------------------+

--
kmaule
------------------------------------------------------------------------
kmaule's Profile: https://forums.netiq.com/member.php?userid=306
View this thread: https://forums.netiq.com/showthread.php?t=53507

Labels (1)
0 Likes
3 Replies
Knowledge Partner
Knowledge Partner

Re: Which Designer for getting latest AD Exchange packages

I've been using Designer 4.5 SP0 Auto-update-whatever-is-current with IDM
4.0 SP2 for quite a while now without any issues. Designer is pretty
smart about understanding version differences, or it seems to be anyway.


--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...
0 Likes
Knowledge Partner
Knowledge Partner

Re: Which Designer for getting latest AD Exchange packages

kmaule <kmaule@no-mx.forums.microfocus.com> wrote:
>
> My question: is Designer 4.5 "safe" with IDM 4.0.2?


It is with the latest patch to Designer 4.5 (make sure to check for updates
within the app after installing 4.5)

The issue that the post 4.5 update fixes was with user app and has nothing
to do with the ad/exchange parts, but you should update regardless.

Alternatively there is nothing wrong with sticking with the very latest
Designer 4.0.2

Engine side to use the latest Exchange packages though you really do need
the latest 4.0.2 engine patch and watch out for the JRE update that comes
with the engine patch.

--
If you find this post helpful and are logged into the web interface, show
your appreciation and click on the star below...
Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Which Designer for getting latest AD Exchange packages

On 5/19/2015 11:07 AM, kmaule wrote:
>
> My client is in an IDM 4.0.2 engine environment running 4.0.0.0 AD
> drivers. We want to enable the PowerShell method for provisioning
> Exchange mailbox. I did a test upgrade of my Designer 4.0.2 with latest
> packages.
>
> Saw a warning (attached) that Designer 4.5 is needed to "address a
> weighting problem with policies..."
>
> Also
> "AD Entitlement and Exchange Mailbox Package requires:
> IDM 4.0.2 w/Eng Patch 5 or IDM 4.5
> Designer version 4.0.2. Auto Update 3 or Later or Designer 4.5"
>
> My question: is Designer 4.5 "safe" with IDM 4.0.2?


As Aaron and Alex already answered for the most part you are fine.

The issues are:

IDM Patches added a new version of jdbm (now called MapDB) and the newer
shims expect the new version. So there are now shim and engine
dependencies.

The Weighting problem is real, but not a big deal. If every policy in a
driver is weighted 500, which comes first? They finally came up with a
method of handling that consistently. (I THINK It is alphabetic).

The Jade/PCRS packages need an engine patch 4.02 Patch 5 I think to add
Startup and Shutdown policies to the engine, and the Designer Auto
Update to add support for those policy sets. D4.5 handles
Shutdown/Startup polices much better than 4.02 AU-latest.

So short answer, use 4.5 with latest AU's and engine with latest patches.

The Package Repo for 4.5 and 4.02 are the same. 4.01 uses a different
repo, since 4.01->4.02 changed the package naming to include a date/time
stamp.


0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.