Anonymous_User Absent Member.
Absent Member.
222 views

iFrame inside UA redirects the whole page to iManager page


Hi! Please, help me with the next issue.
==========================================
Initial conditions:
There is a custom iFrame page inside UA. It is a "Create User
Certificate" iManager portlet and its url is http://tinyurl.com/at77y25
..

Also I have an iFrame portlet inside UA that logs out from iManager. It
finishes the iManager session. Its url is
https://is:8843/nps/servlet/portalservice?fw.exit=true . I called it
"finish session" portlet. (In this case I don't need any authentication.
It just logs out)

Both portlets were configured according to this documentation
http://www.novell.com/support/kb/doc.php?id=7007403 . But "finish
session" portlet doesn't contain any post parameters in its portlet
preference. Only url.

Everything works fine!
=============================================

Issue:
Then we setup Access Manager. And now it is not possible to access
iManager directly, only through Access Manager. Now the URL of UA is
https://dns/idm. And URL of iManager is https://dns/nps.
So, "Create User Certificate" iManager portlet works fine. But "finish
session" portlet does its work - it logs out from iManager session. It
is ok. But "finish session" portlet also redirect the whole UA page to
IManager page. So, when I click on "finish session" portlet then the
whole page is changed to iManager page (not just iFrame).
Somehow the fact that now it is only possible to get iManager through
AccessManager leeds to this strange situation.
=====================================

Is there a way to avoid the behavior when I totally chage the page
addresss while clicking the iFrame that doesn't have any authentication
parameters?
Any help will be very appreciated!!!


--
hello_amigo
------------------------------------------------------------------------
hello_amigo's Profile: https://forums.netiq.com/member.php?userid=211
View this thread: https://forums.netiq.com/showthread.php?t=46341

Labels (1)
0 Likes
1 Reply
Anonymous_User Absent Member.
Absent Member.

Re: iFrame inside UA redirects the whole page to iManager page

hello,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.netiq.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.netiq.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.netiq.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your NetIQ Forums Team
http://forums.netiq.com


0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.