morganginga Absent Member.
Absent Member.
190 views

iManager IDM issue

IDM 4.02 running on RHEL 6.3 with eDir 8.8.7 (plus patch) with iManager
2.7.5 with all plug-ins installed during iManager installation.

When trying to use iManager to do IDM tasks I receive the following error:

The version of the DirXMLCommon plug-in that is installed is not
compatible with the Identity Manager Configuration plug-ins package.

Tried uninstalling and reinstalling iManager following
http://www.novell.com/support/kb/doc.php?id=7000349 but still have the same
error related to IDM functions.

Does anyone have any suggestions on what to try next to get iManager working
for IDM?

Any help is greatly appreciated.

-Morgan

Labels (1)
0 Likes
3 Replies
Anonymous_User Absent Member.
Absent Member.

Re: iManager IDM issue

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

> IDM 4.02 running on RHEL 6.3 with eDir 8.8.7 (plus patch) with
> iManager 2.7.5 with all plug-ins installed during iManager
> installation.


Install what you need, and nothing else. Also, do it manually as
described below.

> When trying to use iManager to do IDM tasks I receive the following
> error:
>
> The version of the DirXMLCommon plug-in that is installed is not
> compatible with the Identity Manager Configuration plug-ins package.


Uninstall iManager. Be sure everything about iManager goes away.
Reinstall it and do not install plugins at the same time. When done,
patch to SP5 (you may be able to do this during the initial installation
to save time, but I never do because I am lazy). After restarting
Tomcat install the latest eDirectory 8.8 plugins. Once done, restart
Tomcat. Now install the latest IDM 4.0 SP2 plugins. Restart Tomcat.

IF you need more plugins, add those, but you likely will not as with
just these you have everything eDir/PKI (I believe), auditing, IDM, etc.
etc. etc. You may see 'Password' plugins listed separately; do not get
those as you already have the functionality and I suspect the
conflicting NPM is present in there.

Good luck.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

iQIcBAEBAgAGBQJQj/uCAAoJEF+XTK08PnB5q3IQAJj/VRidOrbjTc0QnlGJOyBV
NSfwCaM4WGzrNbav6vAP6bv4SBZtkgf9TH0WTumtMgZ7aI8NPmvOipPTCfx87g5o
UAvoUvjyAKpsW6ukH4jqbNCoKeC/goYlNo6BWqb7xfwcExQPwq3yev+C7oX038Ks
+Q1PQzHwVV26UNCagA3DwZ/rzoIsg86/95Qcdhvs5uTG9UkBjyKs/nn4rJFlYsZB
3Fduq3qlrna1JE3hdUdw4LNpeLEE2V7djNeitai5KhOtVTrpxbmp+TAAnVbf3LpB
Ohi9pTN4xJvRDfIvjzw4yfyLtQxtMJ67dSLOYQwVgRJQT6VcBquN1Av/wv+V4MQu
ZRApCY/gD4Mj1nwtCipfBeG+i1U1U9bdyreKRmDmqywaDbv6nGHBmLp9eYy96Zr7
AqTc2JdB6s6xspTXXdLt6Vsh8x7qMeegy9CEFs4q74zfCgDNZVWUPIo0FBCIXZky
lfRbyv7n0+xpfzJ00Y40pyWYWL7x+v+hlXx/XOCCi9D7YaTFZst43Cl7VbO0h/TN
tYXKgrJFTl5YlrL5xLj0xUX0IjGlAxDPNJMwhyKUMKfzr3Ns/gBexD+L+VMluWXc
Rg0alyZu1LBHbs+bBbJpkkwdQjNDziDn+H8NzVlIQLEyo7/2wS7ST8S2T0I6HFXl
0JkGA1iBuSoRAddls/Jv
=lam5
-----END PGP SIGNATURE-----
0 Likes
morganginga Absent Member.
Absent Member.

Re: iManager IDM issue

Following your suggestion worked. A bit inconvenient but it did work. I
appreciate you help.

-Morgan

"ab" wrote in message news:7YSjs.223$wt6.192@kozak.provo.novell.com...

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

> IDM 4.02 running on RHEL 6.3 with eDir 8.8.7 (plus patch) with
> iManager 2.7.5 with all plug-ins installed during iManager
> installation.


Install what you need, and nothing else. Also, do it manually as
described below.

> When trying to use iManager to do IDM tasks I receive the following
> error:
>
> The version of the DirXMLCommon plug-in that is installed is not
> compatible with the Identity Manager Configuration plug-ins package.


Uninstall iManager. Be sure everything about iManager goes away.
Reinstall it and do not install plugins at the same time. When done,
patch to SP5 (you may be able to do this during the initial installation
to save time, but I never do because I am lazy). After restarting
Tomcat install the latest eDirectory 8.8 plugins. Once done, restart
Tomcat. Now install the latest IDM 4.0 SP2 plugins. Restart Tomcat.

IF you need more plugins, add those, but you likely will not as with
just these you have everything eDir/PKI (I believe), auditing, IDM, etc.
etc. etc. You may see 'Password' plugins listed separately; do not get
those as you already have the functionality and I suspect the
conflicting NPM is present in there.

Good luck.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

iQIcBAEBAgAGBQJQj/uCAAoJEF+XTK08PnB5q3IQAJj/VRidOrbjTc0QnlGJOyBV
NSfwCaM4WGzrNbav6vAP6bv4SBZtkgf9TH0WTumtMgZ7aI8NPmvOipPTCfx87g5o
UAvoUvjyAKpsW6ukH4jqbNCoKeC/goYlNo6BWqb7xfwcExQPwq3yev+C7oX038Ks
+Q1PQzHwVV26UNCagA3DwZ/rzoIsg86/95Qcdhvs5uTG9UkBjyKs/nn4rJFlYsZB
3Fduq3qlrna1JE3hdUdw4LNpeLEE2V7djNeitai5KhOtVTrpxbmp+TAAnVbf3LpB
Ohi9pTN4xJvRDfIvjzw4yfyLtQxtMJ67dSLOYQwVgRJQT6VcBquN1Av/wv+V4MQu
ZRApCY/gD4Mj1nwtCipfBeG+i1U1U9bdyreKRmDmqywaDbv6nGHBmLp9eYy96Zr7
AqTc2JdB6s6xspTXXdLt6Vsh8x7qMeegy9CEFs4q74zfCgDNZVWUPIo0FBCIXZky
lfRbyv7n0+xpfzJ00Y40pyWYWL7x+v+hlXx/XOCCi9D7YaTFZst43Cl7VbO0h/TN
tYXKgrJFTl5YlrL5xLj0xUX0IjGlAxDPNJMwhyKUMKfzr3Ns/gBexD+L+VMluWXc
Rg0alyZu1LBHbs+bBbJpkkwdQjNDziDn+H8NzVlIQLEyo7/2wS7ST8S2T0I6HFXl
0JkGA1iBuSoRAddls/Jv
=lam5
-----END PGP SIGNATURE-----

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: iManager IDM issue

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

> Following your suggestion worked. A bit inconvenient but it did
> work. I appreciate you help.


I agree it is inconvenient. I'm a little surprised iManager worked at
all when adding all plugins from the start because of another issue when
adding plugins during installation, but that other issue must be
depending on which plugins, or the order of them, or the combination of
them. Anyway, glad it's up for you. Thank-you for posting back your
results.

Good luck.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

iQIcBAEBAgAGBQJQl+TmAAoJEF+XTK08PnB5Ku8P/iyM79iXQ+Z1ICcYlrymf/b+
WnfuRPv+uAU4mPt9a44tQSym82G3JD0ZHZ91o7E4yUEaBaLX8tGduOALDMSeuTed
SHWRgsXipSJz/UlKUCuTp0hNt7Tl8loI7E73JvXRMnYXO0BKpHVrBW9Sq7BE/Sov
IPPjFEv2D+pSz4X7XaYkg7PPTX+sZqFPBWkSBt+Kh+YYHK3YEtDLq48FGiM0Tw8V
KgNXhKVqTBkLNuc9hZ8RkzTEMg7en8WjU6JWXS/8tuGR6Hq3k1oQvMi7PpgKXhzB
x3aDnAckxJleC6bfgEX6Bp6yIkFLgQza+JlhQsXFcioHI5KfTvV+DWvOm8rth7Sd
fBUdHmfYAALVtIxqOmi3TFsp74PbuBbvTrkyfeYA3p5fkPhd9Cg3GFguiXQuiVqs
KRv0qj/nFNXabvzwS7Izc74/UMMlAU9tepCG/wvSM1hnL3lg7/cwsSkVgk374BbW
2AMx2fkszYS3skOSi/xHxe7Lh4f/dG9Qz5/YAd2Eb/lk6Lq95hCk4CKfoCmV6LvM
wk71k7IAKDe2d+wZj7COtcNCmvfd7A9tswjmR6ICVzPRFtEou2pBHWOr1oMibilT
nVnGUNJZAR3QVaq295hWmburWgzHrzUs9fGztUf9uiwM60hYamjzEi6MoVf3TbxF
bn5ZSRqQv406p1BR8Xd/
=bM7Q
-----END PGP SIGNATURE-----
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.