Commodore
Commodore
824 views

localized approval form

Jump to solution

Screenshot_2.png

Screenshot_3.png

 Hello! I have when using the Russian language. When I set up a sequential role approval process, the approver form displays incorrectly encoded text. In iManager, the srvprvJSONData form attribute is also encoded with an error. If I correct, then it does not allow to save. How to fix it?

0 Likes
1 Solution

Accepted Solutions
Knowledge Partner Knowledge Partner
Knowledge Partner

Ok,
I believe that I have a quick (dirty), but a working solution for you. 🙂

IManager "corrupt" data format, when he tried save data (even, when you change nothing), but you can do it thru LDAP. 🙂

I used Apache LDAP Studio.

Find Role Approval Form object (cn=Role Approval Form,cn=WorkflowApprovalForms,cn=WorkflowForms,cn=AppConfig,cn=UserApplication,cn=driverset1,o=system), Edit Value for srvprvJSONData attribute , Save Data ...

I saved value of this attribute to the text file.

"Corrected" corrupted words in the good text editor. (I used Notepad ++, NPP).

Load this updated file with Apache Load Data.

iMonitor shows correct string value after update.

 

My way is an "unsupported way" and you have to follow official support instructions.

Source of the issue is "incorrect" code page (for the Russian words) in "original" srvprvJSONData NetIQ attribute

View solution in original post

16 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner
What encoding setting you can see in the beginning of your file?
I can expect UTF-8 (<?xml version="1.0" encoding="UTF-8"?>)

UTF-8 is suitable for texts that are mostly English letters. For example, English, Spanish, French, and most web technology such as HTML, CSS, JavaScript.
Most Linux's files are in UTF-8 by default. UTF-8 encoding system is backwards compatible with ASCII. (meaning: If a file only contain characters of ASCII, then encoding the file using UTF-8 results the same byte sequence as using ASCII as encoding scheme.)
UTF-16 is another coding system from Unicode. With UTF-16, every char is encoded into 2 or more bytes, and commonly used characters in Unicode are exactly 2 bytes. For Asian languages containing lots of Chinese characters, such as Chinese and Japanese, UTF-16 creates smaller file size.

What "default" codepage set on your server, that hosted your app?
0 Likes
Commodore
Commodore

In my "Resource Approval Form" file, the srvprvJSONData attribute does not have a field that specifies the file encoding. This is what the beginning of the file looks like.

Screenshot_1.png

0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Another "stupid" question, but maybe to will help to understand your issue.
1. What is your server platform and localization settings on the server?
2. What is your clients/workstations platforms and localization settings on the client?
3. If your client platform is Windows, what is your Windows Display Language and Administrative Language settings (Control Panel->Language->Administrative Language Settings->Language for non-Unicode programs?
(my suspicious, that "Language for non-Unicode programs" set incorrectly.

0 Likes
Commodore
Commodore

1. My server side is installed on SUSE Linux 12sp4, localization is ru_RU.UTF-8. 2. The client part is installed on Windows 10, Russian localization. 3. Windows Display Language and Administrative Language is installed - Russian. It is strange that this error only occurs with standard Approval Forms (Role Approval, Resources Approval, SOD Conflict, Help-desk Approval). If I create my own forms, then everything shows well.

0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner
In this case, explanation can be even more simple (and crazy).
It doesn't look like developer, who created this Russian version of standard Approval Forms has properly configured localization in his development environment.
You can create ticket with support and report about potential bug.
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner
Could you confirm, that "Language for non-Unicode programs" is also Russian?
0 Likes
Commodore
Commodore

Screenshot_1.png

0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Thank you for the confirmation!
Now you have 2 options (that can go in parallel):
1. Open support ticket
2. Create your own version of srvprvJSONData file with "corrected" spelling and "replace" original NetIQ file.

0 Likes
Commodore
Commodore

Thanks for the help! Not sure if the second option will work, as when I fix the srvprvJSONData attribute and save, the error appears.

Screenshot_2.png

0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner
Could you export you object to ldif file? I will try to import and review it?
0 Likes
Commodore
Commodore
 
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.