Anonymous_User Absent Member.
Absent Member.
644 views

submission failed - ater upgrading designer to 4.5


Submission failed.

Failed to submit resource request [id =
cn=Delegate,cn=RequestDefs,cn=AppConfig,cn=xxxUserApp,cn=IDVDriverset,o=xxxidv]
due to:Provisioning system error:Process id
[cn=Delegate,cn=RequestDefs,cn=AppConfig,cn=xxxUserApp,cn=IDVDriverset,o=xxxidv],
version [45]: Invalid xml - Engine only supports xml that is compliant
with ApprovalProcess3_6_1.xsd

The error began after I upgraded my designer to 4.5. If I make a change
to a workflow or create a new workflow for a 4.0,2 system, I get this
error when I submit the workflow. The work-around is to have someone
with 4.0.2 designer pull the deployed workflow into their older designer
then deploy it. After that it works until I make another mod. What's
the fix?


--
ptown
------------------------------------------------------------------------
ptown's Profile: https://forums.netiq.com/member.php?userid=418
View this thread: https://forums.netiq.com/showthread.php?t=52126

Labels (1)
0 Likes
15 Replies
ffreitas Frequent Contributor.
Frequent Contributor.

Re: submission failed - ater upgrading designer to 4.5

On 11/6/2014 7:11 PM, ptown wrote:
>
> Submission failed.
>
> Failed to submit resource request [id =
> cn=Delegate,cn=RequestDefs,cn=AppConfig,cn=xxxUserApp,cn=IDVDriverset,o=xxxidv]
> due to:Provisioning system error:Process id
> [cn=Delegate,cn=RequestDefs,cn=AppConfig,cn=xxxUserApp,cn=IDVDriverset,o=xxxidv],
> version [45]: Invalid xml - Engine only supports xml that is compliant
> with ApprovalProcess3_6_1.xsd
>
> The error began after I upgraded my designer to 4.5. If I make a change
> to a workflow or create a new workflow for a 4.0,2 system, I get this
> error when I submit the workflow. The work-around is to have someone
> with 4.0.2 designer pull the deployed workflow into their older designer
> then deploy it. After that it works until I make another mod. What's
> the fix?
>
>


Not sure on the fix, could not dup it in a quick lab test. what OS is
Designer running on? What is the patch level of IDM/RBPM on the live
system? Did you import the workspace or opened it in 4.5? With the info
above I can try again to dup it.

Cheers,

-Fernando

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: submission failed - ater upgrading designer to 4.5


My environment is a little out of the ordinary. I run a VM on my MAC.
The VM is win2KR3. That helps test the AD driver and remote loader as
needed. I install my designer in the win2kR3 VM. I did not create a new
workspace. I pointed the install to the old installation and let it
upgrade the old 4.0.2 installation.

The customer environment is 4.0.2 patch D.

I have experimented with changing the Designer version in preferences.
I currently have it set at 4.0.2, but I have tried 3.6.1 and 4.5.


--
ptown
------------------------------------------------------------------------
ptown's Profile: https://forums.netiq.com/member.php?userid=418
View this thread: https://forums.netiq.com/showthread.php?t=52126

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: submission failed - ater upgrading designer to 4.5

On 11/10/2014 12:35 PM, ptown wrote:
>
> My environment is a little out of the ordinary. I run a VM on my MAC.
> The VM is win2KR3. That helps test the AD driver and remote loader as
> needed. I install my designer in the win2kR3 VM. I did not create a new
> workspace. I pointed the install to the old installation and let it
> upgrade the old 4.0.2 installation.
>
> The customer environment is 4.0.2 patch D.
>
> I have experimented with changing the Designer version in preferences.
> I currently have it set at 4.0.2, but I have tried 3.6.1 and 4.5.
>
>

Greetings,

1) Designer 4.5 supported O/S

https://www.netiq.com/documentation/idm45/setup_guide/data/b16mhabj.html

Operating System:

openSUSE 13.1 (32-bit or 64-bit)

SUSE Linux Enterprise Server 11 SP3 (64-bit)

Windows Server 2012 R2 (64-bit)

Windows 8.1 (32-bit or 64-bit)

Windows 7 SP1 (32-bit or 64-bit)



2) We do not support User Application 4.0.2 on Windows 2012R2

3) Do you have a typo in the O/S version?



--

Sincerely,
Steven Williams
Lead Software Engineer
NetIQ
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: submission failed - ater upgrading designer to 4.5


No typo. I'm out of compliance. I made sure the servers, eDir and
everything else met the minimums and totally overlooked the designer
requirements. I'll see about upgrading my VM. I'm actually relieved.
The idea of needing two versions of designer was not making me happy.
Sorry to waste your time.


--
ptown
------------------------------------------------------------------------
ptown's Profile: https://forums.netiq.com/member.php?userid=418
View this thread: https://forums.netiq.com/showthread.php?t=52126

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: submission failed - ater upgrading designer to 4.5


Steven Williams;250810 Wrote:
>
> 1) Designer 4.5 supported O/S
> http://tinyurl.com/nmpa9kp
> Operating System:
> openSUSE 13.1 (32-bit or 64-bit)
> SUSE Linux Enterprise Server 11 SP3 (64-bit)
> Windows Server 2012 R2 (64-bit)
> Windows 8.1 (32-bit or 64-bit)
> Windows 7 SP1 (32-bit or 64-bit)
>


I thought we were supposed to see MacOS support with designer 4.5?

--
Liam Hoekenga
ITS Identity and Access Management
The University of Michigan
liamr@umich.edu


--
liamr
------------------------------------------------------------------------
liamr's Profile: https://forums.netiq.com/member.php?userid=1044
View this thread: https://forums.netiq.com/showthread.php?t=52126

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: submission failed - ater upgrading designer to 4.5


Sorry, server is Windows 2008R2.


--
ptown
------------------------------------------------------------------------
ptown's Profile: https://forums.netiq.com/member.php?userid=418
View this thread: https://forums.netiq.com/showthread.php?t=52126

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: submission failed - ater upgrading designer to 4.5

On 11/10/2014 01:45 PM, ptown wrote:
>
> Sorry, server is Windows 2008R2.
>
>

Greetings,
Just to confirm, the VM is Windows Server 2008R2 and you installed
Designer 4.5 on it. Is that correct?



--

Sincerely,
Steven Williams
Lead Software Engineer
NetIQ
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: submission failed - ater upgrading designer to 4.5


Yes. Correct.


--
ptown
------------------------------------------------------------------------
ptown's Profile: https://forums.netiq.com/member.php?userid=418
View this thread: https://forums.netiq.com/showthread.php?t=52126

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: submission failed - ater upgrading designer to 4.5

On 11/06/2014 09:11 PM, ptown wrote:
>
> Submission failed.
>
> Failed to submit resource request [id =
> cn=Delegate,cn=RequestDefs,cn=AppConfig,cn=xxxUserApp,cn=IDVDriverset,o=xxxidv]
> due to:Provisioning system error:Process id
> [cn=Delegate,cn=RequestDefs,cn=AppConfig,cn=xxxUserApp,cn=IDVDriverset,o=xxxidv],
> version [45]: Invalid xml - Engine only supports xml that is compliant
> with ApprovalProcess3_6_1.xsd
>
> The error began after I upgraded my designer to 4.5. If I make a change
> to a workflow or create a new workflow for a 4.0,2 system, I get this
> error when I submit the workflow. The work-around is to have someone
> with 4.0.2 designer pull the deployed workflow into their older designer
> then deploy it. After that it works until I make another mod. What's
> the fix?
>
>

Greetings,
I will investigate into this and if we will support Designer 4.5
with prior versions of IDM.

--

Sincerely,
Steven Williams
Lead Software Engineer
NetIQ
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: submission failed - ater upgrading designer to 4.5


I have upgraded my server to windows2012R2. I fought all the resulting
battles. I reinstalled my designer and created a new workspace. The
error is unchanged. I really don't want to keep multiple designer
versions. I hope you find a fix.


--
ptown
------------------------------------------------------------------------
ptown's Profile: https://forums.netiq.com/member.php?userid=418
View this thread: https://forums.netiq.com/showthread.php?t=52126

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: submission failed - ater upgrading designer to 4.5

On 11/12/2014 01:19 PM, ptown wrote:
>
> I have upgraded my server to windows2012R2. I fought all the resulting
> battles. I reinstalled my designer and created a new workspace. The
> error is unchanged. I really don't want to keep multiple designer
> versions. I hope you find a fix.
>
>

Greetings,
To be clear

1) Install Designer 4.5

2) Start Designer and select a new workspace

3) Import from the Vault that is 4.0.2 (at least the UAD, if not all of
the Drivers)

The User App is deployed on JBoss with Public Patch "E" for 4.0.2 and
using Java 1.7

4) Either create a new Workflow or modify an existing
a) Deploy the above
b) Get the error at runtime when after trying to submit the workflow


Can the server that the App is deployed on access the Internet?



--

Sincerely,
Steven Williams
Lead Software Engineer
NetIQ
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.