Highlighted
Absent Member.. Absent Member..
Absent Member..
133 views

ALM Performance Center - Maintenance Tasks issues

Hello,

 

We're currently running PC 11.52p1 (11.52.5113.0), and I've just discovered kind of major issue, that I would be happy to get a couple of valid input to.

 

The case is that it seems like the Maintenance Tasks (MT) are running, as you can see on below screendump, but the is absolutely no cleanup done on the LG's, as the results file are now several month old.

 

1st question: Where (if at all available) can I find the log files showing what's happening during the MT runs?

 

Next a discovered that (as I understand it) that the "ALM Lab Service" has to be installed on each host, which was not (as I discovered yesterday) to make the MT's to run on the hosts. So for a trial I installed that on one of our hosts, and it all looked good till the registration part, where it keeps saying: "Lab administrator approval pending" (as shown below).

 

If I look in the Lab Resources - Hosts, there is nothing pending (as shown below).

 

2nd question: Can someone please tell me what's up and down here, and how to troubleshoot this issue?

 

Many thanks in advance.

 

Bjarne

 

 

Best Regards,

Bjarne Dein
0 Likes
3 Replies
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: ALM Performance Center - Maintenance Tasks issues

Hi Bjarne,

 

Regarding ALM Lab Service issue, please refer the HP ALM Lab Managerment Guide version 11.5 - page 227 - Approve the Host Registration in Lab Management, it mentions that:

"If you set Registration Auto Approval to Y when you created the host, then the registration will be automatically approved. If the host is not set to be automatically approved, you must approve it manually. The host registration request can be approved from within Lab Management by a Lab Administrator. If the host was created as a private host from within an ALM project, registration can be approved from within that project. Select your host from the grid in the Hosts module, and click the Approve Registration button. The Registration Status changes from Pending to Registered."

 

And about Maintenance Tasks issue, please following the below document to check the RESULT_EXPIRY_DAYS value to see is it expired?

 

https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM00521356

 

If it is expired and the results still are not deleted, I think it might be a defect in PC 11.5 and it is fixed in PC version 12 because I have found these documents, please refer:

 

https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM00571305

https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM00571131

 

Regards,

Chau

 

Regards,

Chau Nguyen | SW Technical Support Consultant.
LoadRunner and Performance Center


If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: ALM Performance Center - Maintenance Tasks issues

Hi Chau,

 

Thanks for your update, but it did not put any further light on my issue.

 

I have been through all these (poor) documents, that really don't tell anything except for novices - unfortunately!

 

There is (btw) not a single word about logfiles nor troubleshooting:-(

 

 

BR Bjarne

Best Regards,

Bjarne Dein
0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: ALM Performance Center - Maintenance Tasks issues

Hi Bjarne,

 

You can check the log in: C:\Program Files (x86)\HP\Performance Center Server\orchidtmp\LTLogger\w3wp

I have tried to install ALM Lab Service on host machine and also got "Lab administrator approval pending" popup.

However, after clicking OK button to close ALM Lab Service, there is a popup to start the host service (service.png), I clicked Yes and in Lab Management, the Registration column changes from blank to Registered. (registered.png).

 

 

Regards,

Chau

Regards,

Chau Nguyen | SW Technical Support Consultant.
LoadRunner and Performance Center


If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.