Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..
162 views

Connection to Oracle DB fails in PC12.61 whereas works fine locally in Vugen

Jump to solution

In a HTTP/HTML script, i want to connect/disconnect with Oracle DB to run a query and fetch value which is a 6 digit number.

I was able to do this and works fine in Vugen locally in my machine whereas same fails when i run a scenario in PC12.61.

I suspect it is something related to Load Generator machines but i am not sure, any help would be appreciated.

Labels (2)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: Connection to Oracle DB fails in PC12.61 whereas works fine locally in Vugen

Jump to solution

The solution was to install Oracle Client on the LG's with correct version. Even if it doesn't work then re-install the LG clients on LG machines. Also in some LG's i got firewall issue which is odd because all LG's have same configuration so used '-cancel_security_mode' in PC Scenario under edit command line next to edit runtime setting, this will disable the security mode

View solution in original post

2 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Connection to Oracle DB fails in PC12.61 whereas works fine locally in Vugen

Jump to solution

Hello,

It is t cheek if the application under test (AUT) is accessible from the Load Generators. An easy check is to open RDP to one of the LGs, copy the script there and replay it locally.   The logs will show you what's the problem is.

Best,

Ivo

IvoHri
0 Likes
Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: Connection to Oracle DB fails in PC12.61 whereas works fine locally in Vugen

Jump to solution

The solution was to install Oracle Client on the LG's with correct version. Even if it doesn't work then re-install the LG clients on LG machines. Also in some LG's i got firewall issue which is odd because all LG's have same configuration so used '-cancel_security_mode' in PC Scenario under edit command line next to edit runtime setting, this will disable the security mode

View solution in original post

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.