Highlighted
Absent Member.
Absent Member.
79 views

Correlation not working

Hi,

I have recorded scripts and I have tried to correlate them automatically. When I try to scan for correlations Vugen throws an error and asks to restart. Is this just a problem with Vugen or possibly a problem with my script?

One other question I have is that when I record my script and I run tests again the application seems to save the results. For example I have a list of parameters of accounts (account names) I wish to create in the application and if I run the script more than once I get an error saying that they already exist. Is there a setting I am not including here which allows it to only simulate the actions and not actually perform them?

Thanks in advance
0 Likes
3 Replies
Highlighted
Absent Member.
Absent Member.

Re: Correlation not working

First, the automatic correlation for me usually doesn't works very well, is better do it manually, anyways can you give more details like in which protocol are you working with.
0 Likes
Highlighted
Established Member..
Established Member..

Re: Correlation not working

Hi,

You can give a try as mentioned below:

Correlation:
1. Tools > General Option > Correlation (Check the settings)
2. After changing the correlation setting (Shift + f8).


Script:
1. Are you able to create two accounts with the same name or data manually. IF you are then your script should work in case you are not changing you parameter list every time.

2. If you cannot create two accounts with the existing accounts data, then you need to make sure before running you are making the parameter unique which are not existing in Data base.


Thanks,
Champ
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Correlation not working

Thanks for the replies - I cannot manually create an account with the same name - so looks like I will need to generate a unique record everytime I run the scripts! I am new to Loadrunner and I was thinking that with this simulation that records were not generated in the db but I guess they are.

Correlation settings seem to be ok (as far as I can tell) so will just manually correlate scripts.

Thanks again.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.