Highlighted
Absent Member.
Absent Member.
561 views

Correlation of QC Load Test Vugen Code Failing..

I am doing Load Testing of the QC10.0. The necessary Security settings have been disabled on QC server.

Recorded the script in VUGen performing routine QC Login and Access QC Defect Module, Finally QC Logout. On replay I got session authentication failed error.Identified that Session Id need to be correlated.

The correlation is continuously failing I am not able to make out how to fix this correlation issue.

I am constantly getting error as below:
"Error -26377: No match found for the requested parameter "WCSParam_Text1". Check whether the requested boundaries exist in the response data." This is followed by Error -26374.

Below is the code
I see some postings related to this in here but no details. Your help is much appreciated.


VuGen Code function:
web_custom_request("TDAPI_GeneralWebTreatment_3",
"URL=http://usri-dapp-qc001:8080/qcbin/servlet/tdservlet/TDAPI_GeneralWebTreatment",
"Method=POST",
"Resource=0",
"RecContentType=application/octet-stream",
"Referer=",
"Snapshot=t6.inf",
"Mode=HTML",
"EncType=text/html; charset=UTF-8",
"Body={\r\n0: \\00000017\\0:conststr:PingToServer,\r\n1: \"0:int:0\",\r\n2: \"0:int:{WCSParam_Text1}\",\r\n3: \\00000023\\0:conststr:7cYX4aEc2d1rnqlZXR0i+A**,\r\n4: \"0:int:-1\",\r\n5: \"0:int:0\",\r\n6: \"65536:str:0\"\r\n}\r\n",
LAST);


here WCSParam_Text1 holds dynamic sesion id value : 6001.

Correlation function is :
web_reg_save_param("WCSParam_Text1",
"LB=0:pint:",
"RB=\"",
"Ord=1",
"RelFrameId=1",
"Search=Body",
"IgnoreRedirections=Yes",
LAST);

I tried to use the values (following code)from Generation log still the correlation issue persists with same errors

web_reg_save_param("WCSParam_Text1","LB=LOGIN_SESSION_ID:","RB=\"",LAST);


Pl. let me know how to fix this Correlation issue.

Thanks In advance!

0 Likes
8 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Correlation of QC Load Test Vugen Code Failing..

Have you played back your script with full logging on and reviewed the replay log to see if the command that your web_reg_save_param is pointing at succeeds, has the data you are looking for, and verified the boundaries?

General-->Log Check Enable logging, Always send messages, Extended log, Parameter substitution, and Data returned by server.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Correlation of QC Load Test Vugen Code Failing..

Thank you. This got resolved. In VUGen it is working fine without any errors.

Now the issue is Run Timeviewer is not showing any QC 10 Screens except for the login page.

As part of recording in VUGen, I have traversed though TestPlan/Test Lab and defects module. But on replay though no errors, VUGen runtime viewer is not showing the repsctive QC test Plan/Test lab/Defects module screens.

Is this that they are client side screens so will not be displayed?

Please let me know if I am missing some settings.

Thanks In advance..
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Correlation of QC Load Test Vugen Code Failing..

Hi Bharatam,

I saw your script. Currently myself also involved in QC load testing.

Can you please provide me some info on how to create scripts like setting while recording and replay.

Here, we need to simulate only login alone.
It will be helpful if you provide your login script alone.

Also can you provide me the security settings that should be disabled in QC

Thanks in advance.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Correlation of QC Load Test Vugen Code Failing..

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Correlation of QC Load Test Vugen Code Failing..

hi,

me too have the same problem - session error while running the recorded script. kindly advice.
i tried with web_reg_save_param - same error as u mentioned...

thanks,
vairav
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Correlation of QC Load Test Vugen Code Failing..

Hi Bharatm,

Its very simple to correlate binaray data.

But for that you need to reformate your web_custom_request().

hint :there are some online site avilable to reformate web_custom_request binary format.

http://www.jds.net.au/tools/reformat/
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Correlation of QC Load Test Vugen Code Failing..

You have mentioned "The necessary Security settings have been disabled on QC server"

can you please explanin how and what you have disabled.

Since am also getting 403 error code, so i wanted to disable the authentication issues.


0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Correlation of QC Load Test Vugen Code Failing..

Guys,

At last i found the solution for this and its working fine.

Simple Method :

Change the hp qc authentification as False in our registery.

Let me know if u guys required any help on this.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.