Highlighted
Knowledge Partner Knowledge Partner
Knowledge Partner
6892 views

Enabling Terminal Service while selecting the Load Generator is resulting in Errors!!

Hi All,

 

Issue Background:

 

In order to run multiple SAP GUI Vuser's on a Windows-Based Load Generator.

We performed the Load Runner 11.0 Software installation to run its Agent as a PROCESS.

 

 

As per the Performance Center Admin Guide we Enabled the Terminal Service accordingly.

 

 

We tried to run the load test with 2 Vusers, each one on each terminal session by selecting the below options.

 

 

 

After running the test , the test is failing with the below error messages.

 

***********************************************************************
Error: Communication error: Failed to send message - socket is not connected yet.
Error: Process "mmdrv.exe" was not created on remote host "138.133.6.30". Reason: communication error. Make sure the Agent process or service is running on the remote machine..
Error: Communication error: Failed to connect to remote host [server IP: 138.133.6.30].
************************************************************************

 

 

Additional Information:

 

i) The Load Runner Patch that is installed is Patch 4.

 

ii) The issue is replicating not only for SAP Tests for also other tests when the terminal service is enabled on the load generator.

 

iii) On the same Load Generator if LR Agent is installed as a service, and if a test is run by disabling terminal service on the load generator, the test is running fine for any number of Vusers.

 

iv) Made sure that Agent Process is always running on the LG even then the issue is replicating.

 

v) Made sure that Local Account Admin on LG is never logged off during the execution of the load test, even then we are facing the same error messages.

 

vi) Remote Management Agent Service, Terminal Services,RPC service is running on the LG machine.

 

vii) When terminal service is enabled on LG even if we run the test with 1 Vuser it is failing with above said error messages.

 

viii) We have unlimited terminal session Windows license on the load generator.

 

ix) Ran the same test on different controllers but the same errors re occured.

 

x)Firewall is disabled on the Load Genarator Machine.

 

xi)Removed Stand alone Load generator from the pool and readded it, the same errors reoccured.

 

Please advise/guide on how to solve the errors and how to run a GUI test with multiple GUI Vusers.

 

Please let me know in case of any questions.

 

Regards,

Srihari

404-579-5368

 

0 Likes
3 Replies
Highlighted
Absent Member.
Absent Member.

Re: Enabling Terminal Service while selecting the Load Generator is resulting in Errors!!

Since it is a communication error, you want to be sure that port 54345 is opened bi directionally, and that Host Security Setup is on "Allow non secure communication"

 

Also does this occur with other tests?

 

Regards,

Mario

HP LR/PC Support

If you are customer you can try posting on our internal forums for more personalized support.

LoadRunner:
http://h30499.www3.hp.com/t5/LoadRunner-Support-Customer/bd-p/loadrunner-support-customer-forum

Performance Center:
http://h30499.www3.hp.com/t5/Performance-Center-Support/bd-p/performance-center-support-customer

How to:
http://www.youtube.com/watch?v=4ChlysWupWM

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
0 Likes
Highlighted
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Enabling Terminal Service while selecting the Load Generator is resulting in Errors!!

Hi All,

 

The issue is resolved now.

 

1) Make sure that the machine is enabled for multiple terminal sessions we should have multiple terminal server license.

 

2) open multiple terminal sessions( login multiple times into the same server )  when running the test this will solve the problem.

 

Regards,

Srihari

404-579-5368 

0 Likes
Highlighted
New Member.

Re: Enabling Terminal Service while selecting the Load Generator is resulting in Errors!!

Hi,

 

for this issue, please make sure that LoadRunner agent process is started on the Load Generator machine. Also, when using the ‘Terminal Services Manger’ setup,  lr_bridge runs on a different terminal than the mdrv process(es). As such, you need to start an additional Agent (1 + the number of LoadGenerator specified in the Controller). This can be accomplished by either launching the Agent on the physical Citrix/MTS Server or by starting an additional Terminal Session

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.