Highlighted
Absent Member.
Absent Member.
773 views

Encountered : error 26224 (web_edit_field not found)

I have recorded a script in Load Runner using the AJAX (Click and Script) protocol. However, while replaying the script I am getting this error:

error 26224 (web_edit_field not found)

For your reference, please find below the script. I have marked the line where the error is happening.

Action()
{

web_browser("favicon.ico",
DESCRIPTION,
ACTION,
"Navigate=https://sit-oipa.jp.intranet/PASJava/Splash/Splash.ifaceataki",
LAST);

/*login with user id and password*/

web_edit_field("mainForm:clientNumberInputText",
"Snapshot=t1.inf",
DESCRIPTION,
"Type=text",
"Name=mainForm:clientNumberInputText",
ACTION,
"SetValue=naveenr",
LAST);

web_edit_field("mainForm:personalIdInputSecret",
"Snapshot=t2.inf",
DESCRIPTION,
"Type=password",
"Name=mainForm:personalIdInputSecret",
ACTION,
"SetEncryptedValue=4dc2377e34ed96bfd44309e774",
LAST);

web_button("INPUT",
"Snapshot=t3.inf",
DESCRIPTION,
"Type=submit",
"Tag=INPUT",
"ID=mainForm:loginCommandButton",
ACTION,
"UserAction=Click",
LAST);

/*Click Policy->Search*/

web_text_link("Search",
"Snapshot=t4.inf",
DESCRIPTION,
"Text=Search",
"Ordinal=1",
ACTION,
"UserAction=Click",
LAST);

/*Provide all values to search a pending policy and click FIND*/

web_list("mainForm:policySearchSubView:company",
"Snapshot=t5.inf",
DESCRIPTION,
"Name=mainForm:policySearchSubView:companySelectOneMenu",
ACTION,
"Select=Primary Company 1",
LAST);

web_list("mainForm:policySearchSubView:planSel",
"Snapshot=t6.inf",
DESCRIPTION,
"Name=mainForm:policySearchSubView:planSelectOneMenu",
ACTION,
"Select=Term Life and LCV-II",
LAST);

web_edit_field("mainForm:policySearchSubView:policyN",
"Snapshot=t7.inf",
DESCRIPTION,
"Type=text",
"Name=mainForm:policySearchSubView:policyNameInputText",
ACTION,
"SetValue=PerfTest014",
LAST);

web_button("INPUT_2",
"Snapshot=t8.inf",
DESCRIPTION,
"Type=submit",
"Tag=INPUT",
"ID=mainForm:policySearchSubView:findCommandButton",
ACTION,
"UserAction=Click",
LAST);

/*Select policy to open it*/

web_element("PerfTest014",
"Snapshot=t9.inf",
DESCRIPTION,
"Text=PerfTest014",
"Tag=SPAN",
"Ordinal=2",
ACTION,
"UserAction=Click",
LAST);

/*Click on ACTIVITIES*/

web_text_link("Activities",
"Snapshot=t10.inf",
DESCRIPTION,
"Text=Activities",
ACTION,
"UserAction=Click",
LAST);

/*Click on ADD ACTIVITY*/

web_text_link("Add Activity",
"Snapshot=t11.inf",
DESCRIPTION,
"Text=Add Activity",
ACTION,
"UserAction=Click",
LAST);

/*Select "Initial Premium Policy" from dropdown of Activity field*/

/*Provide all values for Activity Details and click OK*/

-------------- This is where the error occurs. If I comment this request, the error is being shown in the next request----------

web_edit_field("mainForm:EffectiveDate",
"Snapshot=t12.inf",
DESCRIPTION,
"Type=text",
"Name=mainForm:EffectiveDate",
ACTION,
"SetValue=10/12/2000",
LAST);

web_edit_field("mainForm:activityDynamicFieldsSubVie",
"Snapshot=t13.inf",
DESCRIPTION,
"Type=text",
"Name=mainForm:activityDynamicFieldsSubView:j_id736:0:j_id747:0:j_id877",
ACTION,
"SetValue=10/12/2000",
LAST);

web_edit_field("mainForm:activityDynamicFieldsSubVie_2",
"Snapshot=t14.inf",
DESCRIPTION,
"Type=text",
"Name=mainForm:activityDynamicFieldsSubView:j_id736:1:j_id747:0:j_id1436",
ACTION,
"SetValue=111",
LAST);

web_edit_field("mainForm:activityDynamicFieldsSubVie_3",
"Snapshot=t15.inf",
DESCRIPTION,
"Type=text",
"Name=mainForm:activityDynamicFieldsSubView:j_id736:1:j_id747:1:j_id1436",
ACTION,
"SetValue=111",
LAST);

web_edit_field("mainForm:activityDynamicFieldsSubVie_4",
"Snapshot=t16.inf",
DESCRIPTION,
"Type=text",
"Name=mainForm:activityDynamicFieldsSubView:j_id736:0:j_id747:1:j_id798",
ACTION,
"SetValue=4000000",
LAST);

web_edit_field("mainForm:activityDynamicFieldsSubVie_5",
"Snapshot=t17.inf",
DESCRIPTION,
"Type=text",
"Name=mainForm:activityDynamicFieldsSubView:j_id736:2:j_id747:0:j_id798",
ACTION,
"SetValue=40000000",
LAST);

web_edit_field("mainForm:activityDynamicFieldsSubVie_6",
"Snapshot=t18.inf",
DESCRIPTION,
"Type=text",
"Name=mainForm:activityDynamicFieldsSubView:j_id736:2:j_id747:0:j_id798",
ACTION,
"SetValue=40,000,00",
LAST);

web_button("INPUT_3",
"Snapshot=t19.inf",
DESCRIPTION,
"Type=submit",
"Tag=INPUT",
"ID=mainForm:okCommandButton",
ACTION,
"UserAction=Click",
LAST);

/*Process "Initial Premium Payment"*/

web_image_link("mainForm:policyActivityDataTableSubV",
"Snapshot=t20.inf",
DESCRIPTION,
"Alt=",
"ID=mainForm:policyActivityDataTableSubView:activityDataTable:0:j_id454",
"Name=",
ACTION,
"ClickCoordinates=7,4",
LAST);

/*process "Issue new Policy"*/

web_image_link("mainForm:policyActivityDataTableSubV_2",
"Snapshot=t21.inf",
DESCRIPTION,
"Alt=",
"ID=mainForm:policyActivityDataTableSubView:activityDataTable:1:j_id454",
"Name=",
ACTION,
"ClickCoordinates=9,8",
LAST);

/*Process "Record Policy Month Aversary" for month1*/

web_image_link("mainForm:policyActivityDataTableSubV_3",
"Snapshot=t22.inf",
DESCRIPTION,
"Alt=",
"ID=mainForm:policyActivityDataTableSubView:activityDataTable:4:j_id454",
"Name=",
ACTION,
"ClickCoordinates=8,6",
LAST);

/*Process "Record Policy Month Aversary" for month 2*/

web_image_link("mainForm:policyActivityDataTableSubV_4",
"Snapshot=t23.inf",
DESCRIPTION,
"Alt=",
"ID=mainForm:policyActivityDataTableSubView:activityDataTable:4:j_id454",
"Name=",
ACTION,
"ClickCoordinates=6,4",
LAST);

/*Process "Record Policy month Aversary" for month 3*/

web_image_link("mainForm:policyActivityDataTableSubV_5",
"Snapshot=t24.inf",
DESCRIPTION,
"Alt=",
"ID=mainForm:policyActivityDataTableSubView:activityDataTable:4:j_id454",
"Name=",
ACTION,
"ClickCoordinates=6,4",
LAST);

/*Process "Record Policy Month Aversary" for month 4*/

web_image_link("mainForm:policyActivityDataTableSubV_6",
"Snapshot=t25.inf",
DESCRIPTION,
"Alt=",
"ID=mainForm:policyActivityDataTableSubView:activityDataTable:4:j_id454",
"Name=",
ACTION,
"ClickCoordinates=9,9",
LAST);

/*Process "Record policy Month Aversary" for month 5*/

web_image_link("mainForm:policyActivityDataTableSubV_7",
"Snapshot=t26.inf",
DESCRIPTION,
"Alt=",
"ID=mainForm:policyActivityDataTableSubView:activityDataTable:4:j_id454",
"Name=",
ACTION,
"ClickCoordinates=4,7",
LAST);

/*Process "Record Policy month Aversary" for month 6*/

web_image_link("mainForm:policyActivityDataTableSubV_8",
"Snapshot=t27.inf",
DESCRIPTION,
"Alt=",
"ID=mainForm:policyActivityDataTableSubView:activityDataTable:4:j_id454",
"Name=",
ACTION,
"ClickCoordinates=5,9",
LAST);

/*Process "Record Policy Monrth Aversary" for month 7*/

web_image_link("mainForm:policyActivityDataTableSubV_9",
"Snapshot=t28.inf",
DESCRIPTION,
"Alt=",
"ID=mainForm:policyActivityDataTableSubView:activityDataTable:4:j_id454",
"Name=",
ACTION,
"ClickCoordinates=4,7",
LAST);

/*Select "Maximum Results" to 100*/

web_list("mainForm:policyActivityDataTableSubV_10",
"Snapshot=t29.inf",
DESCRIPTION,
"Name=mainForm:policyActivityDataTableSubView:upperDataPaginatorPageSize",
ACTION,
"Select=100",
LAST);

/*Process "Tax Deduction"*/

web_image_link("mainForm:policyActivityDataTableSubV_11",
"Snapshot=t30.inf",
DESCRIPTION,
"Alt=",
"ID=mainForm:policyActivityDataTableSubView:activityDataTable:12:j_id454",
"Name=",
ACTION,
"ClickCoordinates=9,10",
LAST);

/*Process "Record Policy Month Aversary" which is child of "Tax Deduction" for month 1*/

web_image_link("mainForm:policyActivityDataTableSubV_12",
"Snapshot=t31.inf",
DESCRIPTION,
"Alt=",
"ID=mainForm:policyActivityDataTableSubView:activityDataTable:5:j_id454",
"Name=",
ACTION,
"ClickCoordinates=6,7",
LAST);

/*Log Out*/

web_text_link("Logout",
"Snapshot=t32.inf",
DESCRIPTION,
"Text=Logout",
ACTION,
"UserAction=Click",
LAST);

return 0;
}

Please help me. I am in a fix.
0 Likes
1 Reply
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Encountered : error 26224 (web_edit_field not found)

Hi Sid,

Are you recording with Recording options->Web Event Config-> Medium level?
If no then trying increasinf the level of event configuration.

As GUI script are recorded based on x,y co ordinates of a particular test box or other objects. It is crucial to replay the scirpt in the same resolution as while recroding.

If you could put up the extended logs and share the error message,should help further.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.