Highlighted
Absent Member.. Absent Member..
Absent Member..
424 views

Error: nca_java_action when I am running script here I am using Loadrunner 9.5 and Oracle Applicati


Here I am using LR9.51 and Oracle Forms Patchset 19 and Connection level is socket.
Below are the errors I am getting.

I am using NCA and Web HTML protocol
I am attaching script Please look at it and let me know.


Action.c(34): ObjID=148, Name=Universal Work Queue - Error Console, Visible=0
Action.c(34): ObjID=148; ObjName="Universal Work Queue - Error Console", visble=0, key="148"
Action.c(34): ObjID=149; ObjName="Universal Work Queue - Error Console", visble=1, key="149"
Action.c(34): ObjID=15, Name=Progress, Visible=0
Action.c(34): ObjID=15; ObjName="Progress", visble=0, key="15"
Action.c(34): ObjID=150; ObjName="Universal Work Queue - Error Console", visble=1, key="150"
Action.c(34): ObjID=151; ObjName="Universal Work Queue - Error Console", visble=1, key="151"

Error: nca_java_action("IEXSTTAB_STRATEGY_STRATEGY_GRID_0","selectionStateChanged") failed, Window or object is not displayed.
0 Likes
3 Replies
Highlighted
Absent Member.
Absent Member.

Re: Error: nca_java_action when I am running script here I am using Loadrunner 9.5 and Oracle Applicati

Hello Srinivas,

What you can do is to add the statement nca_step_begin(); before your first java_action and nca_step_end(); after all the java_action statements like below

nca_step_begin();
:
nca_java_action(..............);
nca_java_action(..............);
:
nca_java_action(..............);
nca_step_end();

Try running the script after this change and let me know if it helps

Thanks
Prashanth T

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Error: nca_java_action when I am running script here I am using Loadrunner 9.5 and Oracle Applicati

I have tried that but still I am getting the same problem.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Error: nca_java_action when I am running script here I am using Loadrunner 9.5 and Oracle Applicati

Try changing the timer mode. Go to your script folder and open the default.cfg file and go to the [NCA_GENERAL] section. In this section, add the line NcaTimerWaitMode=3. Save this file and run the script again. If it doesn't work try changing it to 2,1, and 0.

Thanks
Prashanth Thimmavajjala
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.