Highlighted
Absent Member.
Absent Member.
733 views

Error starting Tuxedo recording with VuGen 9.50

I have been able to record scripts with Tuxedo protocol prior to upgrading to VuGen 9.50. I was on 9.10 just last week. After upgrading, however, I have been getting "16-bit application recording is not supported" error that I haven't seen before. Oddly, I can execute previously recorded/developed Tuxedo scripts. Any idea why it's happening? Thanks.
0 Likes
5 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Error starting Tuxedo recording with VuGen 9.50

Help Says:

If you encounter problems recording or running Tuxedo applications, check
that the Tuxedo application runs without VuGen, and that the environment
variables have been defined correctly.

Note that after you set or modify the Tuxedo
variables, you should restart VuGen and your application, in order for the
changes to take effect.

If your application is 16-bit, then you also need to kill the NTVDM process.

~~Shivaram
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Error starting Tuxedo recording with VuGen 9.50

Thanks for the reply. Tuxedo application works without VuGen running as it's the first thing I checked, and I went as far as installing the Tuxedo application and Vugen on a different computer and got the same behaviror.

I think I have had a work-around solution which I instrumented myself. Our Tuxedo application requires a batch command file to launch. For some reason I guess VuGen thinks such batch commands are 16-bit applications. So I created a console application (.exe) wrapper that simply invokes the batch command. Now the recording works like before when I had VuGen 9.10 version previously. I wish LoadRunner team can help resolve this issue which I think is not unusual.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Error starting Tuxedo recording with VuGen 9.50

Yes, You are on the right track..

I think LR team can help you in better way..

I suggest you to log a case with HP support for better response.

Do come back and provide their opinion here !

~~Shivaram
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Error starting Tuxedo recording with VuGen 9.50

Hello guys,

I am getting little bit differnt problem here.

I am getting below error while replying the recorded script using Tuxedo protocol "ERROR: Failed to load TUXEDO library".

Can anybody help me?
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Error starting Tuxedo recording with VuGen 9.50

I got the solution for "ERROR: Failed to load TUXEDO library" error.

Solution: Copy all lib files into LoadRunner bin folder.

Now I am getting below error.
lrt_tpinitialize: TPESYSTEM - internal system error

Please reply if anybody has any idea.

thanks in advance 🙂
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.