Highlighted
New Member.
464 views

Failed to find java.exe while compiling an unmodified java protocol script in VUgen

Hi,

I am doing a POC on MQ for which I need to create a Java script. To begin, I tried to create a new Java Vuser script on 12.5 version of Loadrunner (VuGen). Unfortunately, when I try to compile the script to begin with (empty script having just the init, action and end methods within Actions.java, I get the following error -

"Failed to find java.exe.
Please add the <JDK>\bin to the path and try again. [MsgId: MERR-22968]"

This is after I installed jdk version 1.7.0_80 under C:\Java\jdk1.7.0_80\. I have also included the C:\Java\jdk1.7.0_80\bin in my classpath and my path environment variables. 

Previously I had even tried to install 1.8.0 version of JDK but that did not help. 

Can someone please help me here as I am have been struggling with this issue for last 2 days now. I have even tried the various recommendations on the forums such as installing LR and JAVA under C and not under Program Files, having jdk path only in path and not under classpath but none of them have worked. Your help would be much appreciated. 

 

Thanks,

Rajas Shanbhag

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.