Highlighted
Absent Member.
Absent Member.
2472 views

Getting errors 19800 & 19799 while running scripts pointing to other load agents

Load Runner Version:8.1.4.0

I am getting 19800 and 19799 errors while running load scripts pointing to some other load agents.
I am trying to run load runner scripts in a ditributed enviroment where some of the scripts are pointing to the local controller and others pointing to some other load agents(different machines). The vusers fail to start when they pointing to some other machines except locally.

I would appreciate for a prompt response.

Thanks
Asim
0 Likes
7 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

Those error numbers are not useful by themselves - can you paste the errors?

My first guess is connectivity. Is there a firewall between the Controller and the Generator?
0 Likes
Highlighted
Absent Member.
Absent Member.

19800=Error: Vuser compilation failed.

19799=Error: CCI compilation error -In file included from c:\documents and settings\......\brr_yar.101\global_dir\176324672\combined_Script.c:2:

I dont think so there is any firewall issue.

Thanks
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Still too hard to determine. Can you zip your logs and attach?

Are you using or attaching external files that are not present on the load generator box?
0 Likes
Highlighted
Absent Member.
Absent Member.

Hi,

I am also now facing same issue as specified above please let me know if you know the solution for this thank you.

Regards,
Lalith
0 Likes
Highlighted
Absent Member.
Absent Member.

Hi Lalith,

Could you provide discription about u r issue and how did you schedule u r scenario.
Also about how did u configured loadagent.

Prasad
0 Likes
Highlighted
Absent Member.
Absent Member.

I, too, had the same error. Upon examination of the "logfile.log" in the directory specified in the error message on the agent machine, I found an error entry referencing an external include file which did not affect running on localhost, but crashed the compile on the remote agent machine as it was not pushed from the controller - include it in your project (Vuser Generator) with the "Add files to Script" option and it should solve the problem.
0 Likes
Highlighted
Absent Member.
Absent Member.

I had a similar problem. Ended up that my scripts used VTS and I had to install VTS on the Load Generator.

See http://www.wilsonmar.com/1mercvts.htm
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.