Highlighted
Absent Member.
Absent Member.
4112 views

Got unexpected disconnect event, exiting ..

Hi Citrix Gurus,

I'm running a citrix load test with LR9.1 and citrix client 10.100.55836. Recently we have turned off both compression and encryption on injector machines. Since then, im getting the below error in controller.

Got unexpected disconnect event, exiting ..

At this time, following message is displayed in ICA window.

Presentation Server is not available, please try later.

At the moment, i have added a do-while loop around the ctrx_set_connect_option function as a temp fix.

Just wondering anyone of you have seen this error before. If so, please let me know what needs to be done on server side.

Regards,
Prashanth.
0 Likes
11 Replies
Highlighted
Absent Member.
Absent Member.

Re: Got unexpected disconnect event, exiting ..

Hi Prasanth,
This is resolved with patch LR_00671, attached.
Its a patch for the Citrix v10 client to allow VuGen to support agent channels, a DLL that has to be regsvr32'd on the VuGen/Citrix client PC.

Cheers
Ray


0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Got unexpected disconnect event, exiting ..

Hi prashanth,
I have a similar issue. Could you please let me know the solution in details as I am not able to download the attachement below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Got unexpected disconnect event, exiting ..

Hi Guys,
The patch suggested baove is been imported successfully. I am still facing the same issue (Got unexpected disconnect event, exiting ..). Your help in this regrd is much appreciated.

Details:
Citrix client Version: 10.0
Load Runner : 8.1
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Got unexpected disconnect event, exiting ..

Hi Prashanth,

I am working on Citrix app and getting the same message sometimes but not all the time, and have gone thru the forums and opened ticket with HP support but never get the proper reply and am still facing the same issue.

I am using Loadrunner9.1 and we have installed citrix metaframe presentation server 4.0.3 and loadrunner citrix agent 9.0.0.

can you please suggest me how did you overcome the issue.

I really appreciate if you could give me some suggestions.

Thanks,
Hari
harry.gpt@gmail.com
0 Likes
Highlighted
Contributor.
Contributor.

Re: Got unexpected disconnect event, exiting ..

Hi,

We have somewhat the same problem as you do. Our LR is 9.1 and Citrix Client is 10.2, using Citrix and Web protocols. For some reason we keep having the same "Got unexpected disconnect event, exiting .." message after executing more than 2 vusers on the controller or using vugen sessions, but not manually. After a heavy re-search we were told by a Senior Citrix admin that when LR is doing replay of a script it does so by opening every browser (and citrix) session with the "SEAMLESS" feature Off. So we had to find a workaround because it seemed that even if we force it ON on the script itself, LR will always turn it off (this feature will consume a license per user). So we had to ask to the Citrix Admin that they publish more APPs on the browser.

We hadn't have any luck finding a real solution, other suggestions have been to update LR to 9.5 and see if that works.

I hope this information give you some other leads. If you hapen to came across something new on the matter, please share it.

Regards.

Eduardo Zurita C
0 Likes
Highlighted
Established Member..
Established Member..

Re: Got unexpected disconnect event, exiting ..

Hi Prashanth,

This can be because of the session overriding if you use same user name to login, check manually by opening multiple windows.

one more thing I have observed, if citrix trying to resize the window using sync function, if it fails to resize the window, it may send disconnect event, for example you are trying to select Open Menu item from File menu, while recording the size of the Menu window may be different than the replayed window (it can be because of some dynamic menu items added like Recent visited document etc.)

Regards,
Param
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Got unexpected disconnect event, exiting ..

Prashanth: I'm trying to get a do-while loop around the ctrx_set_connect_option function to work in a script of mine. I get the error "Protocol Driver error". I have added these protocols to my ICA-file:
[Compress]
DriverNameWin16=pdcompw.dll
DriverNameWin32=pdcompn.dll

[EncRC5-0]
DriverNameWin16=pdc0w.dll
DriverNameWin32=pdc0n.dll

[EncRC5-128]
DriverNameWin16=pdc128w.dll
DriverNameWin32=pdc128n.dll

[EncRC5-40]
DriverNameWin16=pdc40w.dll
DriverNameWin32=pdc40n.dll

[EncRC5-56]
DriverNameWin16=pdc56w.dll
DriverNameWin32=pdc56n.dll

Could you give me some input on how you got the do while loop working?

Regards
Fredrik Andersson
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Got unexpected disconnect event, exiting ..

Hi,

i got below error...while trying to replay the script, objective is to test no.of RDP connections using MS terminal services through citrix ICA.

"Error: Got unexpected disconnect event, exiting ..."

this is not happening all the time, it just happen once a while and is very annoying. i kind of did my own research before posting my questions here but nothing really worked.

Can any one help get around this issue or had faced this similar issue before please share your re-solution that worked.

Thanks in advance...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Got unexpected disconnect event, exiting ..

sorry i missed to mention tool versions i am using in post earlier...LR 9.52 and Citrix client 10.00.52110
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Got unexpected disconnect event, exiting ..

Hi Gurus,

 

Any suggestions on how to resolve this issue "Error: Got unexpected disconnect event, exiting ..." while running in controller. i am using LR 9.52, citirix ica file. 

0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: Got unexpected disconnect event, exiting ..

I am observing same error for LR 12.02 version. If this patch is installed then the problem will be solved?

Could anyone help me how to proceed

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.