Highlighted
New Member.
247 views

HP ALM 12.53 REST API test update not happening

Hi All,

I have been using ALM 11.52 and recently it was upgraded to 12.53 version. For automation i was using REST API to update the test status in test lab. But now the update is not happening for the latest version 12.53. I am using Selenium java. What are the changes that i need to make inorder to make the updates happen in latest version as well?

Below is the updated entity xml used for 11.52 version for reference: Any difference in 12.53 version for the xml format?

<?xml version='1.0' encoding='UTF-8' standalone='yes'?><Entities TotalResults='1'><Entity Type='test-instance'><Fields><Field Name='test-instance'><Value>1</Value></Field><Field Name='cycle-id'><Value>2302</Value></Field><Field Name='status'><Value>Passed</Value></Field><Field Name='test-id'><Value>399</Value></Field><Field Name='id'><Value>1418</Value></Field><Field Name='exec-date'><Value>2017-05-18</Value></Field><Field Name='exec-time'><Value>16:06:54</Value></Field></Fields><RelatedEntities /></Entity></Entities>

Appreciate your assistance here please.

Thanks in advance.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.