Highlighted
Absent Member.. Absent Member..
Absent Member..
352 views

HP ALM Performance Center 11.52 and Jenkins Integration Issues (HP Application Automation Tools)

Jump to solution

Hello,

 

I am using the HP Application Automation Tools  to connect Jenkins to our ALM Performance Center 11.52 server. The build fails in Jenkins with the following error - 

 

Started by user 
Building in workspace C:\Users\.jenkins\workspace\Simulated Day Test
[Simulated Day Test] $ "C:\Users\.jenkins\workspace\Simulated Day Test\HpToolsLauncher.exe" -paramfile props25032014161817184.txt
"Started..."
Timeout is set to: 500
Run mode is set to: RUN_LOCAL
The OTA version is not compatible with the current version of the Application Lifecycle Management server: http://myservername:8080/qcbin/wcomsrv.dll.
OTA version: 11.52, OTA build number: 341. Server version: 11.52, server build number: 444.
Error: Cannot Login to QC: Authorization failed.
Build step 'Execute HP tests from HP ALM' changed build result to FAILURE
Finished: FAILURE

I even followed the instructions in the FORUM and deleted my Client Installation before re installing with Admin rights on IE. Its Still fails.

Any help would be highly appreciated!!
0 Likes
1 Solution

Accepted Solutions
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: HP ALM Performance Center 11.52 and Jenkins Integration Issues (HP Application Automation Tools)

Jump to solution

Hello

 

run the Connectivity tool on the PC server machine.


Login to PC server as the PC user (IUSR_METRO or a domain user if it has been changed)> run IE browser> connect to the ALM (http://<alm server>:8080/qcbin) server, go to the Add-In and run the Connectivity tool (http://<alm server>:8080/qcbin/TDConnectivity_index.html )

 

Regards

View solution in original post

0 Likes
2 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: HP ALM Performance Center 11.52 and Jenkins Integration Issues (HP Application Automation Tools)

Jump to solution

Hello

 

run the Connectivity tool on the PC server machine.


Login to PC server as the PC user (IUSR_METRO or a domain user if it has been changed)> run IE browser> connect to the ALM (http://<alm server>:8080/qcbin) server, go to the Add-In and run the Connectivity tool (http://<alm server>:8080/qcbin/TDConnectivity_index.html )

 

Regards

View solution in original post

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: HP ALM Performance Center 11.52 and Jenkins Integration Issues (HP Application Automation Tools)

Jump to solution

Thanks for the help . I got through that issue and got stuck at the next one:

 

The build starts fine, Connects to the test set correctly but HP tools launcher crashes as below. If I hit cancel, it fails the build.

 

Started by user 
Building in workspace C:\Users\.jenkins\workspace\Simulated Day Test
[Simulated Day Test] $ "C:\Users\.jenkins\workspace\Simulated Day Test\HpToolsLauncher.exe" -paramfile props26032014142304511.txt
"Started..."
Timeout is set to: 500
Run mode is set to: RUN_LOCAL
============================================================================
Starting test set execution
Test set name: UAT1_SimulatedDay, Test set id: 711
"Number of tests in set: "1
Test 1: [1]UAT1_SimulatedDay_100 will run on host: my local machine
"Scheduler started at:26/03/2014 14:23:07
-------------------------------------------------------------------------------------------------------
Test: [1]UAT1_SimulatedDay_100, Id: 56, Execution status: Error, Message: Cannot get RemoteAgent's ClassID for test type <PERFORMANCE-TEST>
Test: [1]UAT1_SimulatedDay_100, Status: Error, Message: Cannot get RemoteAgent's ClassID for test type <PERFORMANCE-TEST> \nLink: td:/:/qcbin/TestLabModule-000000003649890581?EntityType=IRun&EntityID=283\n
 
Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object.
   at HpToolsLauncher.AlmTestSetsRunner.RunTestSet(String tsFolderName, String tsName, Double timeout, QcRunMode runMode, String runHost)
   at HpToolsLauncher.AlmTestSetsRunner.Run()
   at HpToolsLauncher.Launcher.RunTests(IAssetRunner runner, String resultsFile)
   at HpToolsLauncher.Launcher.Run()
   at HpToolsLauncher.Program.Main(String[] args)
Report not found
Build step 'Publish HP tests result' changed build result to FAILURE
Finished: FAILURE
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.