Highlighted
Respected Contributor.
Respected Contributor.
167 views

Host XXXXXX could not be allocated. Reason: Timeout. No response was received from the controller

We just start the migration of LoadRunner to Performance Center 12.63, we have set up ALM12.63, Performance Center 12.63 and the required licensing and Controllers/LG's.

When I try to run the scenario, it is failing at the initialization with the below error in the screen and logs.

"Host xxxxxx could not be allocated. Reason TImeout. No response was received from the controller."

I checked the controller and I am able to see the agent running as a service. (magentservice.exe and alagentservice.exe), after the failure, the controller changes the status to Non-Operational and I have to change the status back to Operational from Performance Center Admin page.

What could be causing the test to fail in this way? I tried to use different Controllers and all gives the same error.

Josue A. Chavez D.
3 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Host XXXXXX could not be allocated. Reason: Timeout. No response was received from the controlle

Hello Jacd,

That behavior can be caused because of couple of reasons. As I understood, this is a new environment, so I recommend you to start wit running a health check. Is all green there? If not, reconfigure  the PC Server(s) and controllers and run the health check again. It will let you know what is not good. 

You can get oriented with more details about the actual issue looking on the logs in orchidtmp folder. 

<PC Server installation>\orchidtmp

and 

<PC Host installation>\orchidtmp

Best,

Ivo

 

 

IvoHri
0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

Re: Host XXXXXX could not be allocated. Reason: Timeout. No response was received from the controlle

Hello IvoHri

In LabManagement, I went to Lab Resources>Host, then selected the Controler and LG involved in my test, select Testing Host Menu>Check Host and all came back OK.

LG Connection check passed. - OK

Host installation check - OK

REST connectivity to ALM server check - OK

Josue A. Chavez D.
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Host XXXXXX could not be allocated. Reason: Timeout. No response was received from the controlle

Hi,


It is first to understand if that is script issue or environment issue. As per that, create an empty script, replay it locally in VuGen, upload it in the environment and run a test with it. Is the issue reproduced? If yes, then take a look on


<PC Server installation>\orchidtmp
and
<PC Host installation>\orchidtmp
as proposed before for more details.

If the issue still persist, it might be to open a formal ticket to the support .


Thanks,
Ivo

IvoHri
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.