Highlighted
Absent Member.
Absent Member.
558 views

LR 9.0 and .Net Application

Jump to solution

Hi I have a .NET application that is client/server based and when trying to record a script it records no data .
0 Likes
1 Solution

Accepted Solutions
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: LR 9.0 and .Net Application

Jump to solution
You don't need any protocol specific licenses for recording in VUGen.

Are you able to record any other sample (web) application.??


In case of .Net environment, by default, the VuGen environment is configured for .NET Remoting, ADO.NET, Enterprise Services, and WCF (Windows Communication Foundation) applications.

You need to understand on DEV environemnt, if they are using any other client-server activity.

View solution in original post

0 Likes
14 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: LR 9.0 and .Net Application

Jump to solution
I have always seen such issues, if you are using .Net record replay protocol.

Few suggestions:

1) Be sure to check, if LR v 9.0 supports your .Net application (Framework version etc)

2) Disable any antivirus and try recording

3) Disabale DEP (Data Execution Prevention)on windows XP, 2003 or UAC on Vista, 7.0

Check with your dev team, what's the communication (protocol) used for client server application...You can check, if you need to include any custom filters (VUGen recording option)

Hope this helps!

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LR 9.0 and .Net Application

Jump to solution

Hi , we do have a license for .NET application with LR 9.0 .

The application also uses web services but trying to add that to the protocol is not recording anything.

thanks
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: LR 9.0 and .Net Application

Jump to solution
You don't need any protocol specific licenses for recording in VUGen.

Are you able to record any other sample (web) application.??


In case of .Net environment, by default, the VuGen environment is configured for .NET Remoting, ADO.NET, Enterprise Services, and WCF (Windows Communication Foundation) applications.

You need to understand on DEV environemnt, if they are using any other client-server activity.

View solution in original post

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LR 9.0 and .Net Application

Jump to solution
Thanks , well this is what they are doing ,

We start with a browser and launch the application, this starts the service and the application. Application is based on .NET framework .

The entire application is client server based
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: LR 9.0 and .Net Application

Jump to solution
It's bit tricky to understand the root cause of the issue.

I would suggest you log a support case, if you have a licensed copy.

You can however, try using latest version of LR...there is lot of product feature enhancement from LR v9.0 to v9.1/9.52& 11.0

All the best!
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LR 9.0 and .Net Application

Jump to solution

Is there a way to bypass proxy during recording option. This is present in run time setting sbut not present during recording script
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: LR 9.0 and .Net Application

Jump to solution
Does this application uses WCF?
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LR 9.0 and .Net Application

Jump to solution

No it does not, but the following error appears in script:
/* Request with GET method to URL "https://xxxxxx.com/favicon.ico" failed during recording. Server response : 404*/

so even though I can change the IP address for the web_url parameter that bypasses the proxy I am not sure how to bypass this
Thanks
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LR 9.0 and .Net Application

Jump to solution

So since this uses Web services, I changed the script to HTTP/HTML ptotocol, now we get the web_custom_request but post still gives an error.

What is strange is that when I try to do this manually , it works but LR just does not record the script
any ideas?
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: LR 9.0 and .Net Application

Jump to solution
Any luck on it?

Did you happened to enable port mapping before recording (Proxy/Direct)?

Thanks,
Raj

Regards,
Raj

Like this Post? Click Kudos! to show appreciation.
Is your issue addressed? Click "ACCEPT AS SOLUTION" against the post which helped you the most.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LR 9.0 and .Net Application

Jump to solution
yes it did work finally. the problem is that there are no snapshots created so validating the response was an issue . Then corrrelation became an issue. LR would simply not correlate because there are no snapshots.

So I had to go through the server response and finally correlate

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.