Highlighted
Absent Member.
Absent Member.
666 views

LR 9.1 error

Hi Folks,

While performing load generation test, we have some failed transactions with this error. Can someone help us on this?

“Communication: server didn't get responsive select handle. (user’s call backs can’t be called). mchan_pp_init API must be called first.”

Thanks,
Senthil


0 Likes
6 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: LR 9.1 error

Hi Senthil,

Can you let us know what version of LR you are usine & what protocol you are ussing? And for what inout code (Action line) you are getting this error. Atleast this minimal information is necessary to understand the problem.

-Raj

Regards,
Raj

Like this Post? Click Kudos! to show appreciation.
Is your issue addressed? Click "ACCEPT AS SOLUTION" against the post which helped you the most.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LR 9.1 error

Hi,

We are using HTTP and HTTPS protocol.

Kindly let us know what is being referred to as inout code in the above message.

Thanks,
Senthil


0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: LR 9.1 error

Sorry, its input code. Can you copy the section of the code for which you are getting this error.

Regards,
Raj

Like this Post? Click Kudos! to show appreciation.
Is your issue addressed? Click "ACCEPT AS SOLUTION" against the post which helped you the most.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LR 9.1 error

We are getting this same error message.  it looks to me that this is a generator side error, not a controller or script error.  Does anyone else have an input on this?  We're using PC 9.52.

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: LR 9.1 error

Hi,

What is the OS in use ?

Is there an Antivirus running on the Controller/Agent?

Has the Data Execution Prevention(DEP) been taken care of ?

0 Likes
Highlighted
New Member.

Re: LR 9.1 error

I'm getting this error when I run a test with more than 1500 users on Loadrunner 12.63.

I'm using a multiple protocol script with web http and webservice.

Fisrt 1500 users are running ang any user coming after that goes to Error state with the below error messages:

Error: Communication error: Server didn't get responsive select handle (user's call backs can't be called) , mchan_pp_init API must be called first.Error: The remote host's status is 'Failed'. Check the remote host machine [and verify that it has not crashed]. [MsgId: MERR-29722]

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.