Absent Member.
Absent Member.

LR 9.5 Controller/Generator Connectivity

Load Controller keeps dropping the connection with one of the generators during test. IS there a fix?

1 Reply
Super Contributor.
Super Contributor.

Re: LR 9.5 Controller/Generator Connectivity

Since you have not mentioned what error you are getting , you can check all the below mentioned

Troubleshooting a connectivity problem

Different problems can cause the above error. Some of the things you can verify include:

1. Make sure that you apply the same LoadRunner version and Service Pack on the Controller and Load Generator machines.
2. Make sure that you can ping the Controller and host machine bidirectionally. You may need to add the IP address and machine name on the host file:

1. Go to the host machine.
2. Navigate to C:\WINNT\system32\drivers\etc\.
3. Open the hosts file in a word editor.
4. At the end of the file, add another line with the IP address and machine name of the Controller machine.

Example: MI_Controller

5. Repeat steps a - d for all the host machines.
6. Repeat steps a - d for the Controller machine, but adding the IP and machine name of the hosts machines.

3. Make sure that the LoadRunner Agent is running either as a process or a service on the remote host machine. Refer to Document ID 10464- How to set LoadRunner Agent as a service or process after installation to do this.

4. Make sure the Controller and host are connected to the network. In some networks, the Microsoft LOOP back IP address is used when a computer is not connected to the network. As a result, the Controller will not be able to detect the host machine. You will need to stop the loop back service, connect to the network, and make sure that the machine has a valid IP address.

5. If there are multiple network cards in the machines, please refer to Document ID 11685 - Using LoadRunner with machines that have multiple NICs.

6. It might as well be possible that some network environment issue might be the cause and the network monitor can be used to diagnose the problem. Make sure that you are using the latest driver and firmware for your network cards and routers. Also try to force the network card to use 100Mbs/Full Duplex instead of the 'Detect automatically the best speed settings'. In case of miscommunication with the router or other network device the automatic settings could be set in an inappropriate way and have huge consecuencies on the network performances.
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.