Highlighted
Absent Member.
Absent Member.
309 views

LR 9.5 Error while trying to record .NET application

Hello,

I'm trying to record .NET application by using NET.Framework protocol in LR 9.52.

While launching the recording I get following error from VU Generator: "Microsoft .NET Framework is not installed on this machine. Before recording a script, you must install Microsoft .NET Framework 1.1".

But .NET Framework 1.1 is installed exactly.

Does anybody know the reason and how to solve it? Could you please help to resolve this issue?

OS Version: Microsoft Windows Server 2003. Enterprise Edition. SP2.
VUGen Version: 9.52 build 3282.
0 Likes
6 Replies
Highlighted
Absent Member.
Absent Member.

Re: LR 9.5 Error while trying to record .NET application

Hi Vitali

i got a piece of infromation for you from LR:

Applications created with .NET Framework 1.1 which are not compatible with Framework 2.0, cannot be recorded. To check if your Framework 1.1 application is compatible, add the following XML tags to your application's .config file:






Invoke the application (without VuGen) and test its functionality. If the application works properly, VuGen can record it. Remove the above tags before recording the AUT with VuGen. For more information regarding this solution, see the MSDN Knowledge Base.

Let me know if it helped you in any way
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LR 9.5 Error while trying to record .NET application

Hi vidhyasg,

my .NET application uses framework 2.0.

The error I get - is VU Generator error. It seems that VUGen can't find .NET Framework installed on the machine.

Does anybody have any other suggestions?
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LR 9.5 Error while trying to record .NET application

Hello,

the issue above hasn't been resolved yet.

It seems, that LoadRunner can't find .NET Framework at all.

Don't you know why is it appears? And how to resolve it?

Best Regards,
Vitali Banad
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LR 9.5 Error while trying to record .NET application

Hi Vitali

Can you reinstall the .net frame work again and try... may be this might sound stupid.. but just try it once more.. and hope ur using .net protocol to record the application, kindly use single protocol, u cannot use multiple protocol with .net

Let me know if ur problem still persists.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LR 9.5 Error while trying to record .NET application

hi Vitali...

any progress regrading this thread?? let me know.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: LR 9.5 Error while trying to record .NET application

Is there any resolution for this error?

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.